nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Nvidia nforce drivers for RH9 (http://www.nvnews.net/vbulletin/showthread.php?t=14322)

ashish_v 07-03-03 04:15 PM

Nvidia nforce drivers for RH9
 
HI all..
This Issue may have been addressed before but i am just frustrated with RH9 and NVIDIA nforce unified drivers for video and Network card.

i have recently installed RedHat 9 with kernel with kernel version 2.4.20-8, i have downloaded and tried to install the drivers which are availble from NVIDIA web site. but as of now i am not able to get the Ethernet interface running.

when i try to configure the interface eth0 and try to activate it, it gives error " eth0 doesn't exist! delaying initialization".

I had installed Mandrake 9.1 before installing redhat 9, the drivers for that from the nvidia site they ran fine and i never had any issues with Mandrake drivers.
But for last 2 days i am getting really frustrated with redhat... I really want to use redhat for some stuff that i am working and that is compatible only with Redhat...

I wou;ld reallly appreciate if someone could help me out...

qiyuwang 07-07-03 11:21 AM

for redhat9.0 with kernal 2.40.8
 
you must do it with tar provided by the nvdia web.I try it ,and suceed.but before I use tar,I fail like you with rpm driver.
now,I update redhat 9.0 with kernal 2.40.18.9,I found ,though the OS found nvnet,but can not active eth0.

artsci2 07-07-03 12:43 PM

I have similar problems as described in this thread. RH 9 does not recognize my onboard LAN card (realtek 8201BL). I did download the Nvidia drivers and burned them onto CD using windows and was able to access them with RH 9 running. The system then could apparently see the onboard LAN adapter. However there is still no access to the lan. I am using RH 9 PRO (CDR0121US). Has anyone tyried the most recent download version of RH 9? Maybe that has the nessesary driver and configuration files?

John

bahamot 07-08-03 09:54 AM

just do:
1. download the newest driver
2. extract
3. cd to driver directory (/complete/path/to/nforce/nvnet)
4. make && make install
5. reboot

and done :)

artsci2 07-08-03 11:48 PM

Thanks for your reply but the problem I am having is that I can't get onto the network so that makes "downloading" impossible. As I mentioned I did log into the nVidai web site using Win ME and then burned them onto CD. After booting onto RH 9 I tried to install the drivers and this produced nothing. I tried to reinstall and the RPM manager reported that I had already installed the platform and the nvnet driver. I rebooted and saw that in the boot (grub) system selection there was a choice of the -6 kernel but no -9 kernel that i had installed. Thanks fot the try though.
I found in another thread where an nVidia employee recommended rebuilding the driver or kernel but this apparently has to be done without x11 running. I havent found how to do that yet.

John

bahamot 07-09-03 06:15 AM

you could try d/l the tarball one and copy it into floppy or other media.
then extract, compile and make install

cheers

Thierry 07-09-03 01:17 PM

Dunt Worry Be Happy!!!
 
Hello my frined I had the same problem and Pheran gave me his code n fixed the Problem:

You should be able to get your network connection going if you grab Pheran nvnet RPM for RedHat 9 from here:

http://www.pheran.com/nv7linux/

Just download the RPM file and run rpm -ivh on it.

It worked for me should for u!!

Cheers,
Thierry

Frito 07-18-03 11:12 PM

Nvidia nforce drivers for RH9
 
Did you have any luck?

Am also looking for a solution to the nvidia ethernet problem.

I found an old 3com ethernet card RH would recognize. This gives me access to the internet so I can at least download things to work on the problem. I see cards for $5 in the stores and catalogues if you can't beg borrow or steal one.

A good investment if it cuts down your frustration.

Another suggestion would be to dual boot with the Mandrake if that will give you internet access. Tho I tried dual booting with RH9 and Suse and the latter wiped out the RH boot. Was able to recover by reloading RH to all linux partitions.

Let me know what you end up with.

Frito

glo 07-19-03 12:19 AM

Hi

I got my ethernet card to work with the package from this link.

But my environment is

AMD 2200+
Windows XP
Redhat 7.3
Linux 2.40.20-8

http://www.pheran.com/nv7linux/

But I think it did something weird. When I start up, its says Welcome to {some garbage letters}

When I log in, I get a warning saying something like {some garbage letters} not found. Please add {some garbage letters } to /etc/host file. Or something like that.

Would anyone have any suggestions as to why i'm getting this warning.

Thanks.

Geoff

Thierry 07-19-03 05:42 AM

Garbage letters?
 
1 Attachment(s)
Hello Folks,

I'm surprise you got garbage letters? Are you sure it is related to this install and not another one or something else yo've been doing? I dunt have any of this at all. The only message i ever got was during booting and asking me to configure the adapter which I did successfully!! :o)

Just in case that guy who did the driver updated it and included some kind of ads then I've attached the file I used.

I could not attached the file as .rpm so DUNT FORGET TO RENAME IT .RPM

Cheers,
Thierry

glo 07-19-03 11:26 AM

Hi,

Well, the 1st half of the letters i figured out that its my ethernet address, the 2nd half, i'm not sure yet.

I'll try your attachment and give it a go.

Thanks for providing that link, http://www.pheran.com/nv7linux/.
It really narrowed my search time :D


Thanks,

Geoff

jj00 08-15-03 01:15 AM

I just got a Shuttle sn41g2 (which uses the NVidia NForce chipset), and it had the same problem with the network card not working.

I am very grateful that I found the rpm file posted here and was able to get my RH9 distro working on the net. However, once I updated to the newest kernel update, the network interface quit working again. This was noted in another post, but I was hopeful that doing an update of my system might have some type of fix associated with it by now.

Regardless, I'm a little puzzeled by the lack of support from NVidia. I noticed all these links to Linux drivers, but none of them seem to work. The only successful file I got was from another party, and now I have to be cautious of kernel upgrades.

I must say, I'm a bit disappointed that this didn't go any smother, I always thought of NVidia as a good supporter of Linux drivers and such.

Has anyone found a work around to get the NForce driver (completely) working correctly with linux (specifically RH9)?


All times are GMT -5. The time now is 04:30 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.