nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   ./nvidia-installer: not found, Ubuntu 9.04 (http://www.nvnews.net/vbulletin/showthread.php?t=143449)

mbushroe 01-06-10 10:31 PM

./nvidia-installer: not found, Ubuntu 9.04
I have been having multiple problems installing the latest (or even several versions back) Linux X86_64 Nvidia drivers.

I am running Ubuntu 9.04, Jaunty Jackalope on an AMD Athelon 64 with 2GBytes RAM, and initially my Kernel was 2.6.28-17. When I first tried to install the kernel modules, I did something wrong and the kernel began to fail, losing the ability to read CDROM disks, USB drives, run modprobe or depmode. So I downloaded a pristine Kernel source package from Kenrel.Org, 2.6.32 and installed that and started over trying to install the Nvidia video drivers.

My first step was to download the latest version from Nvidia, NVIDIA-Linux-x86_64-190.53-pkg2.run. Then I ran chmod 777 to make it executable. But when I try to run it, it verifies the archive file then fails to extract the nvidia-installler, or any other file. This happens if I run as me, "sudo sh", "sudo su", and even rebooting to run level 3 (difficult to do under Ubuntu!). I also tried adding the Kernel Source directiry option "sh NVIDIA-Linux-x86_64-190.53-pkg2.run --kernel-source-path=/usr/src". In each case, the output is:

root@mike-desktop:/home/mike/Downloads# sh NVIDIA-Linux-x86_64-190.53-pkg2.run
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 190.53............................................ .................................................. .................................................. ...............
NVIDIA-Linux-x86_64-190.53-pkg2.run: 880: ./nvidia-installer: not found

Since it never extracts the nvidia-installer, there is no log file in /var/log. I tried under earlier, Ubuntu installed Kernels, but apparently they are all 32bit, so the 64bit version would not install. Since only the 2.6.32 Kernel was running properlly, there was no point in downloading the 32bit version and trying again in a kernel that could read USB flashdrives.

My next attempt was to use the Ubuntu supplied driver, version 180. I used the System/Administration/Hardware Drivers. In the pull down menu, NVIDIA accelerated graphics driver (version 180) [Recommended] is not activated. When I select activate, it requests my password, downloads a copy of the driver, but fails to activate it. I have tried using version 173 but it also fails to become activated.

Next I Googled installing Nvidia drivers on Ubunutu and found a third party package to help with the install, EnyNG. I was able to download an run this program, but it reports that the Kernel Headers were not available, even though I had just downloaded the source, ran menuconfig, and compiled for 2 hours the current Kernel from source, and had not deleted anything. The sample output is:

root@mike-desktop:/var/lib/dkms/nvidia/180.44/build# envyng -t

| |
| Welcome to EnvyNG |
| Developed by Alberto Milone (aka tseliot) |
| |

| EnvyNG Menu |
| |
| 1 - Install the NVIDIA driver |
| |
| 2 - Uninstall the NVIDIA driver |
| |
| 3 - Install the ATI driver |
| |
| 4 - Uninstall the ATI driver |
| |
| 5 - Restart the Xserver |
| |
| 6 - Restart your computer |
| |
| 7 - Exit |
| |
Please select one of the activities displayed above and press ENTER:

| Number | Candidate Version | Installed Version | Compatible | Recommended |
| 0 | 180.44-0ubuntu1 | 180.44-0ubuntu1 | + | + |
| 1 | 173.14.16-0ubuntu1 | - | + | - |
| 2 | 96.43.10-0ubuntu1 | - | - | - |
| 3 | 71.86.08-0ubuntu1 | - | - | - |
Please select the number corresponding to the desired driver and press ENTER
(or type another number and press Enter to go back to the previous menu):
Compiled Kernel

| Error: |
| |
| EnvyNG has detected that the headers for |
| your kernel are missing and cannot be installed |
| |


My Fourth attempt to load the Nvidia video drivers involved finding the directory "/var/lib/dkms/nvidia/180.44/build". I tried "make module", according to the README file, but the compile failed with the message:
/var/lib/dkms/nvidia/180.44/build/nv.c: In function ‘nvos_proc_create’:
/var/lib/dkms/nvidia/180.44/build/nv.c:596: error: ‘struct proc_dir_entry’ has no member named ‘owner’
/var/lib/dkms/nvidia/180.44/build/nv.c:597: error: ‘struct proc_dir_entry’ has no member named ‘owner’
/var/lib/dkms/nvidia/180.44/build/nv.c:598: error: ‘struct proc_dir_entry’ has no member named ‘owner’
/var/lib/dkms/nvidia/180.44/build/nv.c:618: error: ‘struct proc_dir_entry’ has no member named ‘owner’
/var/lib/dkms/nvidia/180.44/build/nv.c:632: error: ‘struct proc_dir_entry’ has no member named ‘owner’
/var/lib/dkms/nvidia/180.44/build/nv.c:643: error: ‘struct proc_dir_entry’ has no member named ‘owner’
/var/lib/dkms/nvidia/180.44/build/nv.c:653: error: ‘struct proc_dir_entry’ has no member named ‘owner’
/var/lib/dkms/nvidia/180.44/build/nv.c:663: error: ‘struct proc_dir_entry’ has no member named ‘owner’
/var/lib/dkms/nvidia/180.44/build/nv.c:674: error: ‘struct proc_dir_entry’ has no member named ‘owner’
/var/lib/dkms/nvidia/180.44/build/nv.c:681: error: ‘struct proc_dir_entry’ has no member named ‘owner’
/var/lib/dkms/nvidia/180.44/build/nv.c: In function ‘nvos_proc_add_warning_file’:
/var/lib/dkms/nvidia/180.44/build/nv.c:708: error: ‘struct proc_dir_entry’ has no member named ‘owner’
make[4]: *** [/var/lib/dkms/nvidia/180.44/build/nv.o] Error 1
make[3]: *** [_module_/var/lib/dkms/nvidia/180.44/build] Error 2
make[2]: *** [sub-make] Error 2
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2

Next I tired to download a copy of my Kernel headers, but since I ran menuconfig, I realized that I could not download them from somewhere else and tried to figure out how to extract the headers from the source files. I ran "fakeroot make-kpkg --initrd --revision=custom1.0 kernel_image kernel_headers so that I coudl then load the Kernel headers, but that failed to build also. I also tried adding soft links to help EnvyNG to find the headers, adding /usr/src/linux-headers-2.6.32 and /usr/src/linux, both pointing to /usr/linux-2.6.32, but that did not work either.

Could someone please recommend a way to get _some_version of the NVIDIA graphics drivers running on my system? I really miss having that second sreen when running schematic capture and PCBoard layout. Thanks in advance.


wantilles 01-07-10 02:39 AM

Re: ./nvidia-installer: not found, Ubuntu 9.04
Make a standard package for your distribution.

This is the correct Linux way.

Arup 01-07-10 05:09 AM

Re: ./nvidia-installer: not found, Ubuntu 9.04
In Ubuntu you can't install it within GUI, you have to log out of terminal by hitting ctrl+alt+F2. login and then do a sudo /etc/init.d/gdm stop

after that do a sudo sh NVxxxxxxxxxxx

Make sure you have the nvidia driver in your home folder. Also before all that do a sudo apt-get build-essential

mbushroe 01-07-10 01:00 PM

Re: ./nvidia-installer: not found, Ubuntu 9.04

Originally Posted by wantilles (Post 2159593)
Make a standard package for your distribution.

This is the correct Linux way.

wantillies, I do not understand. I downloaded a complete source package from Kernel.Org, ran menuconfig, then compiled and built the kernel. To me, that sounds as close to a standard kernel as you can get. Are recommending I download a precompiled kernel from somewhere else? Is there some way to use the Ubuntu updater to repair an existing kernel that has lost several file systems, and that modprobe no longer works on. Or are you suggesting that I use the Ubuntu updater to upgrade to 9.10 and that will fix all my problems?

Arup, as I had described in the first posting, I tried running the self-extracting driver installer under various conditions, even after running /etc/init.d/gdm stop and using sudo su to become 'root'. I tried that again since I had forgotten the process to get Ubuntu completely out of X, but it had exactly the same effect. The self extractor first verifies the archive as valid, then fails to extract nvidia-installer.

I was also confused on the [qoute]sudo apt-get build-essential [/quote] I get an invalid operation build. When I Googled it, I saw that it needed install first, but 'sudo apt-get install build-essential' without a list of packages makes 0 changes. What list of packages should I be verifying?

I am currently having a hard time each reboot. The screen comes up red on top and black on the bottom. Little grey squares appear in columns in spurts, looking like improperly displayed bootup messages. At one point they stop growing downward. If I hit enter, I get a brief pulse of more squares. If I hit ctrl-alt-dlt then it finishes making squares, the display flashes several times, then an error message says that the Nvidia module could not be found, do you want to finish in low graphics, build a new configuration, trouble shoot, or boot to command prompt. If I answer to go on, it then says that display 0 is already in use, should I start with a different number, or retry 0. No matter what I enter here, it seems to fight for several iterations before finding an unused display number to use.

While I was in run level 3 trying Arup's suggestions, I also tried envyng -t again. This time I tried removing the Nvidia drivers and reboot. I still got many of the same error messages, but fewer iterations of trying to find a display. After logging in again I tried the Ubuntu Hardware Driver console, and once again tried to activate the version 180 driver. Rebooting after that resulted in another 'could not load Nvidia Module' error.


AaronP 01-07-10 01:15 PM

Re: ./nvidia-installer: not found, Ubuntu 9.04
Are you trying to run the 64-bit installer on a 64-bit kernel with 32-bit userspace? That's not a supported configuration and leads to the "./nvidia-installer: not found" error because the interpreter is missing. Try extracting the .run file with the -x option and verify that nvidia-installer is there.

mbushroe 01-07-10 09:49 PM

Re: ./nvidia-installer: not found, Ubuntu 9.04
AaronP, good call. If I use the -x option, it creates a subfolder and extracts the nvidia-installer. So, how do I get a 64bit build to fit the kernel, if I am stuck with 32bit userland?


AaronP 01-08-10 12:01 AM

Re: ./nvidia-installer: not found, Ubuntu 9.04
Well, here's the problem: you need a 64-bit kernel module but a 32-bit X driver. We don't built a package with that configuration, so you'd have to install it manually. We don't officially support that configuration, so you're pretty much on your own there. If you want to use the .run installer, you'll need to either install the appropriate 64-bit runtime files or use a 32-bit kernel (and the 32-bit driver package, obviously).

mrn 01-08-10 11:09 AM

Re: ./nvidia-installer: not found, Ubuntu 9.04
I think your huuuugely complicating things here.

Why are you running a 64bit kernel on 32bit ubuntu install? Why are you using a custom kernel/custom nvidia installer/envyng to install a driver which is readily available in your distribution? You should have the nvidia binary driver up and running graphically within a minute of installing ubuntu.

If you wanna grab a newer driver than 180 you can get them from the nvidia-vdpau ppa (and or upgrade to 9.10).

All times are GMT -5. The time now is 01:18 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.