nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   New nvidia drivers for FreeBSD problem. (http://www.nvnews.net/vbulletin/showthread.php?t=14398)

nefarios102 07-05-03 02:38 AM

New nvidia drivers for FreeBSD problem.
 
Alrighty, well ill start off by saying the old drivers have worked on my, and my friends machine. Upon installing the new drivers, they seem to work fine, until reboot. I get this following messages right after it attempts to mount my root partition:

pid 84 (fsck_ufs), uid0: exited on signal 8
pid 85 (fsck_ufs), uid0: exited on signal 8

The system countinues to halt and i cannot access the machine, even in single user mode. My friend has had the same problem as me, and we thought it was user error upon installing the drivers, so he put FreeBSD on another computer and the new drivers worked fine.

The only thing i could notice that was simliar on both the machines that these drivers did not work on was the nforce chipsets, i have an nforce chipset, my friend has an nforce2 chipset.

Anyone have any ideas? Please? It would be nice to get these drivers working, or even know what the problem is. Thanks in advance.

AIM: Nefarios102
Email: rrl125@psu.edu

My hardware:
Geforce 3
Microstar motherboard with nforce chipset
1700xp+ athalon, 266 mhz bus
512 ddr ram

Friends hardware:
Geforce FX 5600
Asus motherboard with nforce2 chipset
2600xp+ with 333 mhz ddr bus
1 gig dual channel ddr ram

DualC 08-14-03 05:24 AM

Hi, there..

I got the exactly same problem.. when i installed the newest drivers and reboot the FreeBSD crash.. and the only way is to do a new install.. Can someonte explain it to me..

I forgotten.. my Hardware.. :

ASUS A7N8X-Deluxe (NForce2)..
GForce3 card...
512Mb, DualChannel DDR..

The Newest FreeBSD 5.1 R.
And the Newest NVIDIA Drivers.

/M

Lyfe 10-14-03 08:38 PM

While I'm not one to usually revive dead topics, this question does not seem to be answered.

The reason you have this issue is because the FreeBSD nvidia graphics driver attempts to be *the* driver for all nvidia hardware components, and given that you have a board based on the nforce2, that's a lot of components that the simple graphics driver does not know how to handle. The freebsd drivers, however, know how to handle them. One solution is to make the nvidia graphics driver only respond for the nvidia graphics card, which is done as such:

Extract the nvidia driver
edit NVIDIA-FreeBSD-x86-1.0-4365/src/nvidia_pci.c and change the following from (at about line 36):
Code:

    if (rm_get_device_name(device, NV_DEVICE_NAME_LENGTH, name)
            != RM_OK) {   
        strcpy(name, "Unknown");
    }

to:
Code:

    if (rm_get_device_name(device, NV_DEVICE_NAME_LENGTH, name)
            != RM_OK) {   
        /* altered to make it fall through on unkonwn devices still made by nvidia */
        return ENXIO;     
    }

This will make it only attempt to be the authoritative driver for the nvidia graphics card, which is the only device it knows how to be authoritative for anyway.

Then you can continue to follow the directions and do a "make setup" so it'll compile and install the kernel module.


Side note: to boot without reinstalling, go to the boot command prompt (in bsd 5.1, you choose option 6), and hit any key besides enter when it asks to hit enter to boot immediately. This will get you to a prompt where you can issue commands to keep it from loading the nvidia module:
disable-module nvidia
boot-conf

Your system should now load, so that you can make the changes to the nvidia module.

DualC 10-15-03 04:30 AM

Hey, It works perfect for me now, Thanks man.. great answer.. :)

/Mattias

Lyfe 10-23-03 07:57 PM

Glad it works for someone besides myself. :)


All times are GMT -5. The time now is 02:20 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.