nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Quadro FX 880M Stability Problems (http://www.nvnews.net/vbulletin/showthread.php?t=145105)

d3mia7 02-13-10 04:33 PM

Quadro FX 880M Crash - 195.36.03
 
2 Attachment(s)
I've got a new Lenovo W510 with a Quadro FX 880M. Much like the G210 it requires 195.36.03 to get around the "fuzzy screen" problem after switching to a virtual console or anything else.

With this driver I'm getting random crashes from time to time - it's a hard lock up, you can't do anything but use the reset button when the crash occurs.

The only clue I have is these messags in my Xorg.0.log file when the crash occurs:

(WW) Feb 13 14:10:39 NVIDIA(0): WAIT (2, 6, 0x8000, 0x00009d10, 0x00005498)
(WW) Feb 13 14:10:46 NVIDIA(0): WAIT (1, 6, 0x8000, 0x00009d10, 0x00005498)

I've attached my Xorg log file complete with those messages at the bottom - any help would be great!!

Running Ubuntu 9.10 (Karmic) with all updates, etc.
X 1.6.4

d3mia7 02-13-10 04:57 PM

Re: Quadro FX 880M Stability Problems
 
I should add that the crash doesn't really seem to be easily reproducible on demand - there's nothing in specific that happens to trigger it, although it does seem to occur more often when loading pages in Firefox. Still though it's occurred for me a few times just while using Terminal.

I haven't yet managed to get more than about 30-40 minutes of usage before it blows up though.

d3mia7 02-14-10 02:16 PM

Re: Quadro FX 880M Stability Problems
 
1 Attachment(s)
I've tried running nvidia-bug-report.sh while X is hung, unfortunately it seems nvidia-bug-report itself hangs too!

I tried getting a backtrace with GDB, not sure if it is of any use... Can anyone give me any pointers for troubleshooting this kind of issue?

Same thing every time, I get a few of these types of messages:

(WW) Feb 14 12:08:32 NVIDIA(0): WAIT (2, 6, 0x8000, 0x0000d9a8, 0x0000ded4)
(WW) Feb 14 12:08:39 NVIDIA(0): WAIT (1, 6, 0x8000, 0x0000d9a8, 0x0000ded4)
(WW) Feb 14 12:10:24 NVIDIA(0): WAIT (2, 6, 0x8000, 0x0000d9a8, 0x0000ec5c)
(WW) Feb 14 12:11:11 NVIDIA(0): WAIT (1, 6, 0x8000, 0x0000d9a8, 0x0000ec5c)

Nothing in dmesg, and I can still successfully reboot the machine if logged in remotely. Curiously enough the pointer itself doesn't freeze, just everything else does. Can't switch to a virtual console or anything similar.

d3mia7 02-14-10 02:26 PM

Re: Quadro FX 880M Stability Problems
 
1 Attachment(s)
I noticed the attached text in my /var/log/messages as well, might just be related to running GDB though.

d3mia7 02-16-10 12:49 AM

Re: Quadro FX 880M Stability Problems
 
What's the normal release cycle for beta drivers? Or is there one?

darthvader42 02-18-10 05:32 PM

Re: Quadro FX 880M Stability Problems
 
Confirmed, the very same for me. Also using the latest beta on a Lenovo W510.

piojo2 02-19-10 03:35 AM

Re: Quadro FX 880M Stability Problems
 
I've just bought a W510 with the Quadro FX 880M, and it's working so far. I'll describe my system setup and usage in hopes that it may shed some light on the situation:

I'm using Arch Linux with xfce (not gnome). I installed nvidia-beta 195.36.03-1 and nvidia-utils-beta 195.36.03-1 (these packages are from the "archlinux user repository", the main collection of 3rd party packages). I got my xorg.conf file by running nvidia-xconfig. X has been running (but not in constant use) for 6 hours. I have briefly tested some of the 3D screensavers that come with xscreensaver, and I have used mplayer with VDPAU. Online flash videos play fine.

Here is my Xorg.0.log file. The only interesting part is that the nvidia driver encounters an error when it tries to communicate with acpid, which isn't running. There's a scary-looking error at the end, but that only happened when I used mplayer to do stress testing (and it did not crash the X server). Here is my computer's sudo lspci -vvv

Let me know if there's anything else I can do to help shed light on this problem!

d3mia7 02-19-10 11:01 AM

Re: Quadro FX 880M Stability Problems
 
Hey piojo, are you running Compiz?

My W510 will run for hours without Compiz enabled without trouble, but it dies relatively quickly when Compiz is turned on.

Interesting you're getting the 'WAIT' messages in your xorg.0.log as well. BTW I get the same ACPI message on Ubuntu - I'm guessing your screen brightness controls aren't working either?

piojo2 02-19-10 11:53 AM

Re: Quadro FX 880M Stability Problems
 
Quote:

Originally Posted by d3mia7 (Post 2191907)
My W510 will run for hours without Compiz enabled without trouble, but it dies relatively quickly when Compiz is turned on.

It died during the night when left running xscreensaver, actually. And no, I wasn't running Compiz. I'll try that to see if I can make it crash faster. When it did lock up, there was no message at all in Xorg.0.log.

Quote:

Originally Posted by d3mia7 (Post 2191907)
Interesting you're getting the 'WAIT' messages in your xorg.0.log as well. BTW I get the same ACPI message on Ubuntu - I'm guessing your screen brightness controls aren't working either?

By the way, I've noticed X "pause" for a second at a time, and maybe this corresponds to the WAIT message. And you're right about the brightness not working. I looked at the manpage of xbacklight, and it says it uses xrandr to do its stuff. I read somewhere that the nvidia drivers don't support newer versions xrandr, so I'm not surprised.

d3mia7 02-19-10 12:21 PM

Re: Quadro FX 880M Stability Problems
 
OK, so essentially the card seems stable for both of us when it's just doing 2D tasks, but throw some 3D at it and it crashes at some point. I'll try playing Tuxracer or something similar too, I'm guessing that'll crash it quickly as well.

Apparently the brightness stuff is fairly common on nVidia. The workaround is to switch to a virtual console, change the brightness and then flip back to X.

piojo2 02-19-10 02:30 PM

Re: Quadro FX 880M Stability Problems
 
To change the brightness, you can run nvidia-settings to use a GUI. Or on the command line, type "nvidia-settings -a brightness=n" where n is between -1 and 1 (0 being 100%).

I also can't get compiz to work, and I can't manage to force a crash. If I do get compiz working, I'll leave something heavy on the "rotate virtual desktop" button and see if that taxes the driver enough to cause a crash.

piotrq__ 02-19-10 03:37 PM

Re: Quadro FX 880M Stability Problems
 
Could you please see if disabling HPET with hpet=disable as your kernel parameter helps?


All times are GMT -5. The time now is 05:16 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.