nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nvnet performancde sucks (http://www.nvnews.net/vbulletin/showthread.php?t=14799)

ascompltd 07-14-03 12:13 PM

nvnet performancde sucks
 
Can anybody shed any light on this problem for me :confused:

I have an Epox 8RDA+ motherboard, FX5600 Graphic and 1GB Ram on my new board I thought I had researched this system before I purchased it but I have a real problem with network performance.

My Kernel is 2.4.22pre2-gss and have the nforce support built into kernel my nick comes up with a dhcp assigned IP but performance is woefull from time to time :mad: like now for example I have had to resort to (and appologies for swearing hear) my windowz box to post this message.

I have tried both 0261 and 0256 versions of the nvnet driver with no improvenment also acpi=noacpi amd acpi=off still no joy :(

mariuz 07-14-03 03:14 PM

I don't know
 
there is something like hdparm to test
the network card performance maybe ?!
If you run the with the stock kernel the performance is good ? Give it a try and disable
the dhcp , sometimes the performance is lower than with static ip .
ps : I run with kernel 2.4.20 and it works good (installed binaries not from source...)

Max3D 07-14-03 07:50 PM

Performance seems good here for data transfer speeds, same as within XP, one thing that annoys me is the time it takes for nvnet.o to negotiate with cable modem on bootup of kernel is rediculous, anywhere between 30 secs and 1 min it hangs there waiting (in XP its real quick to get IP and start working), tried all the nvnet.o combination of options (optimization, link speed, duplex) and switched between dhcp-client and pump client to no avail, anyone else have this issue?

These work great and negotiate quickly:
- Netgear FA311 (natsemi.o)
- Netgear FA310 (tulip.o)

why can't your drivers do the same?
Common nvidia, fix this!

bahamot 07-15-03 09:57 PM

Quote:

Originally posted by Max3D
Performance seems good here for data transfer speeds, same as within XP, one thing that annoys me is the time it takes for nvnet.o to negotiate with cable modem on bootup of kernel is rediculous, anywhere between 30 secs and 1 min it hangs there waiting (in XP its real quick to get IP and start working), tried all the nvnet.o combination of options (optimization, link speed, duplex) and switched between dhcp-client and pump client to no avail, anyone else have this issue? ...

nvnet works fine, but the audio driver in linux is lame :mad:

spurious-noise 07-15-03 10:43 PM

nvnet performance here is absulutley shocking

Small files take around 1 second each to transfer and it basically stops the box when doing so. The symptoms resemble excessive interrupts.

we are running Asus A7N266-VM mainboards with XP1800+ and 512Mb RAM
and revision 1.0.0261 nforce drivers

any tips?

:afro:

erwos 07-17-03 12:44 PM

I haven't used nvnet extensively, but I've never had any performance problems with file transfers. It does have an issue with insertion, but it's only a few seconds.

The driver has issues, but it ain't so bad.

-Erwos

betel 07-20-03 11:24 AM

Had some fun with this myself this past weekend. But, just about got it figured out now:

The performance was dire initially, but I added the module option "optimization=1" which bizarrely optimized for CPU according to the code. But, this got me up from 12k/sec to at least 5MB/s.

I also had what can only be described as crazy IRQ issues. All three of the devices that I would use most (ethernet, dxr3 and DVB card) were sharing the same IRQ. This manifested itself as nasty picture breakup when the network was in use (useful!). Hard coding the IRQs for the PCI slots in the bios seemed to sort it out.

Oh, this is 2.4.21-ac4 on an A7N266-VM.

cheers

sessland 08-08-03 11:17 PM

I am having the exact same issues. The whole system is choppy as hell when the NIC is being used. Reminds me of when I used to try to multi-task my 486DX33 on Win 3.1

Are people seeing the same problems from the RPM as well as the source? It shouldn't make a difference, but you never know.


All times are GMT -5. The time now is 10:51 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.