nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   display lag [regression from 190.25 to 195.30] (http://www.nvnews.net/vbulletin/showthread.php?t=148022)

HenryHu 02-19-10 07:19 AM

display lag [regression from 190.25 to 195.30]
 
1 Attachment(s)
I have been using nVidia driver 195.30 for a while(maybe one month or more), and I have to switch back to 190.25.
I'm using nVidia Geforce 8600MGS, on an Samsung R70 laptop.
My system version is FreeBSD 8.0-STABLE, which is somewhere old.
When using 195.30, I can feel frequent lagging, when running glxgears, or playing movies throught VDPAU in mplayer. The glxgears FPS is always below 55 FPS(I limit FPS to refresh rate), and sometimes drops to 40 or below. After downgrading to 190.25, the FPS is always above 59, and the movies play smoothly.
It seems like that glxgears uses more CPU resource under 195.30 than 190.25, and when it lags, the CPU usage goes high, and then returns to average level.

I want to report another problem here also. When I was using 195.30, I upgraded my avant window navigator to trunk version, and afterward X server hangs after a random period of time, maybe half an hour to several hours. I can shutdown normally by pressing the power button once however.
I found these in log:
When it hangs: (uptime more than 2 hours)
Feb 19 19:01:58 henryhu9 kernel: NVRM: Xid (0001:00): 13, 0003 00000000 00008297 00001b0c 1000f010 00000002
Feb 19 19:01:58 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE0001
Feb 19 19:01:58 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE0001
Feb 19 19:01:59 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE007e
Feb 19 19:01:59 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE007e
Feb 19 19:01:59 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE007e 0ff4 05000000 00000000 00000000 00000000
Feb 19 19:01:59 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE007e
When it hangs again: (uptime almost 50 minutes)
Feb 19 19:55:05 henryhu9 kernel: NVRM: Xid (0001:00): 13, 0003 00000000 00008297 00001530 00000001 00000001
Feb 19 19:55:05 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE0001
Feb 19 19:55:05 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE0003
Feb 19 19:55:05 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE0001
Feb 19 19:55:16 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE007e
When the screen flashed but not hanged (just booted up)
Feb 19 19:59:35 henryhu9 kernel: NVRM: Xid (0001:00): 8, Channel 00000001
Feb 19 19:59:43 henryhu9 kernel: NVRM: Xid (0001:00): 8, Channel 00000003
Feb 19 19:59:44 henryhu9 kernel: NVRM: Xid (0001:00): 13, 0001 00000000 0000502d 00000860 00000011 00000100
And it hanged later: (uptime almost 30 minutes)
Feb 19 20:26:42 henryhu9 kernel: NVRM: Xid (0001:00): 13, 0004 00000000 00008297 00001b0c 1000f010 00000002
Feb 19 20:26:43 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE0003
Feb 19 20:26:43 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE0001
Feb 19 20:26:43 henryhu9 kernel: NVRM: Xid (0001:00): 6, PE0001

I ran nvidia-bug-report before downgrading to 190.25. Now I'm waiting to see if this older version would also hang.


All times are GMT -5. The time now is 08:43 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.