nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia module on 2.6.33-rt (http://www.nvnews.net/vbulletin/showthread.php?t=148509)

slightlystoopid 03-02-10 09:51 PM

Nvidia module on 2.6.33-rt
 
Has anyone built this successfully? Trying to build 173.14.25 on 2.6.33-rt4. I can't build nvidia or nouveau. I found a couple patches on these forums for previous rts, but they appear to have already been applied upstream.

The build errors.

thefirstm 03-02-10 10:39 PM

Re: Nvidia module on 2.6.33-rt
 
173.xx won't compile against 2.6.33 in any form.

slightlystoopid 03-02-10 11:11 PM

Re: Nvidia module on 2.6.33-rt
 
Quote:

Originally Posted by thefirstm (Post 2199629)
173.xx won't compile against 2.6.33 in any form.

huh? that's wrong. I've compiled it against 2.6.33 vanilla, bfs, and ck patches. rt is the only one that's a problem.

darkless 03-03-10 01:54 AM

Re: Nvidia module on 2.6.33-rt
 
I experience the exact same errors as the OP when trying to compile 195.36.08 on 2.6.33-rt4.

ledoc 03-03-10 02:04 AM

Re: Nvidia module on 2.6.33-rt
 
Is there no patch (for earlier rt kernels) floating around here in the forum, somewhere? Could be a starting point for making it work on 2.6.33-rt.

darkless 03-03-10 02:32 AM

Re: Nvidia module on 2.6.33-rt
 
The changes from the previous -rt kernel patches have already been applied upstream. This issue is different.

slightlystoopid 03-03-10 05:40 AM

Re: Nvidia module on 2.6.33-rt
 
1 Attachment(s)
ok, I really have no idea if this is the best way to treat this, but it builds and I'm using it now. Comparing 2.6.33-rt4 with 2.6.31.12-rt21, it seems the semaphore_init function is gone from the kernel and all atomic_spin* stuff appears to have been renamed raw_spin* for some reason. I've attached my patch, like I said, it's working so far, no guarantees.

Los_Andros 03-19-10 02:59 AM

Re: Nvidia module on 2.6.33-rt
 
Hi,
I tried to apply this patch to the latest 195.36.15 driver, but that didn't work. So I manually tried to change the header file.

Sadly this also didn't work. I got a 2.6.33-rt Kernel from the jengelh opensuse repository.

I really hope NVidia will fix this soon.

Los_Andros 03-19-10 12:34 PM

Re: Nvidia module on 2.6.33-rt
 
.... ok found the problem, the first two line in the patch file have the path of the NVidia installation directory included. I deleted the leading path and only kept ./usr/src/..., copied the patch file into the nvidia installer directory and applied the patch.

Worked perfectly, the driver compiled without any problems and my system is up and running, thanks a lot.

paoleary 03-20-10 07:19 AM

Re: Nvidia module on 2.6.33-rt
 
Quote:

Originally Posted by Los_Andros (Post 2213108)
...I deleted the leading path and only kept ./usr/src/...

It's typical to require the -p# option to apply a patch. Check the man page for `patch'. Might save some time in the future. :)

Los_Andros 03-22-10 07:45 AM

Re: Nvidia module on 2.6.33-rt
 
Quote:

Originally Posted by paoleary (Post 2213607)
It's typical to require the -p# option to apply a patch. Check the man page for `patch'. Might save some time in the future. :)

indeed ;)

haunted 03-23-10 07:42 PM

Re: Nvidia module on 2.6.33-rt
 
Quote:

Originally Posted by Los_Andros (Post 2212796)
Sadly this also didn't work. I got a 2.6.33-rt Kernel from the jengelh opensuse repository.

Since you already have the kernel from there, you could have just as well also pulled the nvidia.rpm from the very same location!


All times are GMT -5. The time now is 03:29 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.