nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Enable audio through HDMI on GT240 (http://www.nvnews.net/vbulletin/showthread.php?t=150113)

odror 04-17-10 10:00 AM

Enable audio through HDMI on GT240
 
I just got the new GT 240 card that does not require SPDIF wire hookup. According to EVGA I need to have nvidia HDMI audio driver if I want to have audio through the HDMI output.

Is there a kernel driver that will support audio over HDMI for nvidia cards. if there is how do I make the kernel detect my NVIDIA card.

I have Ubuntu 10.04 (64 bit version) running on quad core dell computer.

Thanks

lspci:
Quote:

00:06.0 PCI bridge: Intel Corporation 82X38/X48 Express Host-Secondary PCI Express Bridge
00:19.0 Ethernet controller: Intel Corporation 82566DC-2 Gigabit Network Connection (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 RAID bus controller: Intel Corporation 82801 SATA RAID Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GT 240] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
03:00.0 Multimedia video controller: Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder (rev 02)
04:04.0 PCI bridge: Pericom Semiconductor PI7C9X110 PCI Express to PCI bridge (rev 04)
04:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
04:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
05:00.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9400 GT] (rev a1)
aplay -l:
Quote:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

paoleary 04-17-10 07:31 PM

Re: Enable audio through HDMI on GT240
 
You should only need to upgrade to ALSA 1.0.23. Complete details here.

odror 04-17-10 07:58 PM

Re: Enable audio through HDMI on GT240
 
Thanks

Do you know if it will be included in the final version of ubuntu 10.04 (in the current beta version it is not included, 1.022.1 is included.)

paoleary 04-18-10 11:26 AM

Re: Enable audio through HDMI on GT240
 
Quote:

Originally Posted by odror (Post 2235369)
Thanks

Do you know if it will be included in the final version of ubuntu 10.04 (in the current beta version it is not included, 1.022.1 is included.)

Highly improbable, as 1.0.23 arrived so late in the release cycle for 10.04 (about two weeks from release, and after Beta 2). I know I wouldn't take it if I ran the Ubuntu release process.

zim2dive 04-20-10 08:13 AM

Re: Enable audio through HDMI on GT240
 
Anyone figure out the needed /etc/modprobe.d/sound.conf settings for a GT240?

I have GIGABYTE GV-N240D5-512I GeForce GT 240 512MB 128-bit GDDR5

installing 1.0.23 was not enough by itself. alsamixer will show the card (F6), but aplay-l does not list it.

paoleary 04-20-10 06:31 PM

Re: Enable audio through HDMI on GT240
 
Quote:

Originally Posted by zim2dive (Post 2236567)
Anyone figure out the needed /etc/modprobe.d/sound.conf settings for a GT240?

I have GIGABYTE GV-N240D5-512I GeForce GT 240 512MB 128-bit GDDR5

installing 1.0.23 was not enough by itself. alsamixer will show the card (F6), but aplay-l does not list it.

There are reports (lost when the XBMC site went down) for working GT240s; I believe they were using settings similar/identical to G210 users. It was all the 220s that had problems...

zim2dive 04-21-10 05:27 PM

Re: Enable audio through HDMI on GT240
 
Quote:

Originally Posted by paoleary (Post 2237073)
There are reports (lost when the XBMC site went down) for working GT240s; I believe they were using settings similar/identical to G210 users. It was all the 220s that had problems...

I've tried playing with modprobe, but so far I still do not see any nvidia devices in aplay :(

paoleary 04-21-10 06:38 PM

Re: Enable audio through HDMI on GT240
 
Can you copy all the same diagnostics that odror did at the beginning of the thread, zim2dive--for your system, of course.

zim2dive 04-21-10 08:02 PM

Re: Enable audio through HDMI on GT240
 
Quote:

Originally Posted by paoleary (Post 2237791)
Can you copy all the same diagnostics that odror did at the beginning of the thread, zim2dive--for your system, of course.

Sure thing
Code:

>lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 10)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation Device 0ca3 (rev a2)
01:00.1 Audio device: nVidia Corporation Device 0be4 (rev a1)
03:00.0 Ethernet controller: Attansic Technology Corp. Device 1063 (rev c0)

>aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Alsamixer shows "HDA NVidia" card if I hit F6 but says "This sound device does not have any controls"

zim2dive 05-09-10 05:29 PM

Re: Enable audio through HDMI on GT240
 
I finally figured out the trick to getting 1.0.23 installed...

from the XBMC page: http://wiki.xbmc.org/index.php?title...T220,_or_GT240

Quote:

Note for Ubuntu users make sure to remove linux-backports-modules-alsa-`uname -r` or your newly compiled alsa drivers will be ignored.
I can now see my GT240 with aplay -l

Can't test yet tho.. my @#%@#% Denon does not decode HDMI audio... but a new one is on order.
EDIT:
Code:

>aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


primerib 05-09-10 06:04 PM

Re: Enable audio through HDMI on GT240
 
Quote:

Originally Posted by zim2dive (Post 2248363)
Can't test yet tho.. my @#%@#% Denon does not decode HDMI audio... but a new one is on order.

Your receiver can't do LPCM? Piece of crap. ;)

zim2dive 05-09-10 06:26 PM

Re: Enable audio through HDMI on GT240
 
Quote:

Originally Posted by primerib (Post 2248369)
Your receiver can't do LPCM? Piece of crap. ;)

Decodes digital audio over coax/SPDIF, but not HDMI.

EDIT: one of those nasty tricks Denon plays... things you don't even know to look for before you buy. But since nvidia didn't have HDMI audio until just recently, it didn't matter. Mobo has digital out.


All times are GMT -5. The time now is 10:30 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.