nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   (EE) NVIDIA(0): Failed to to map framebuffer (http://www.nvnews.net/vbulletin/showthread.php?t=15035)

TheOuch 07-18-03 03:41 PM

(EE) NVIDIA(0): Failed to to map framebuffer
 
1 Attachment(s)
Visiontek Ti 4600 . . X will not start with nvidia drivers.

XF86Config is stock config with Suse (not edited, except allowing Suse's configurator to turn on 3d)

Attached is log. (I can attach the XF86Config later, but I'm working now, and i need my gui)

Any ideas?

TheOuch 07-18-03 09:30 PM

What else can I provide?
 
Please let me know what other information I can provide to get things working . . . I really want accelerated 3d!

kregars 07-18-03 10:51 PM

try reconfing it..

X -configure or (not a SuSe Linux) SuperProbe and cut the output and put into the card<x> where X is your card number....

this will get a basic config (back to bone stock) and then you can start from scratch at making mods...I am willing to be that if you decided to go the other route, change 2 9bit color, and basic resolutions (ie *bleg* 640x480) and then work you way up..again..not a suse user, nor have I had some other problems/horrors that Ive read on here with NVidia cards..then again..I dont game..but I do use X. :)

Good Luck,



Scott Kregar

TheOuch 07-24-03 11:25 AM

Card verified under Windows XP
 
I just installed Windows XP to validate that the hardware was working.

I did notice one thing. The card did NOT want to install the drivers. Even when I did an advanced install and pointed it right at the directory.

I had to manually select that it was a NVIDIA Geforce 4 Ti 4600 from the list to get the driver installed.

Perhaps this VisionTek card has invalid / unknown PCI Id Settings that's keeping the driver from working right?

Here's the output from lspci

01:00.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti] (rev a3)

And the output from /proc/pci
Bus 1, device 0, function 0:
VGA compatible controller: PCI device 10de:0252 (nVidia Corporation) (rev 163).
IRQ 5.
Master Capable. Latency=32. Min Gnt=5.Max Lat=1.
Non-prefetchable 32 bit memory at 0xde000000 [0xdeffffff].
Prefetchable 32 bit memory at 0xd0000000 [0xd7ffffff].
Prefetchable 32 bit memory at 0xddc80000 [0xddcfffff].

TheOuch 07-24-03 12:03 PM

Ok . . more logs
 
1 Attachment(s)
Here are logs and configs from the working nv and the broken nvidia trials.

Let's get this working!

TheOuch 07-24-03 12:29 PM

Removed all framebuffer support from kernel
 
After reading http://www.nvnews.net/vbulletin/show...&threadid=3660
I tried forcing riva frame buffer, and then removing all framebuffer support from kernel.

it didn't help. Same error message.

TheOuch 07-25-03 10:12 AM

bump

TheOuch 08-20-03 08:38 AM

Still nothing?
 
I buy NVIDIA *only* because of their linux support. My money is feeling very wasted right now.

Guess I'll have to dig into the source and see why the framebuffer is not mapping. (I'm assuming that the full source is available, since it gets built.)


All times are GMT -5. The time now is 09:21 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.