nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia-settings do not persist clone and panning settings (http://www.nvnews.net/vbulletin/showthread.php?t=150396)

Darkstar 04-26-10 10:58 PM

nvidia-settings do not persist clone and panning settings
 
I am running a tool called nvidia-settings which from the X Server Information dialog within it, I am guessing is NV-CONTROL Version 1.22 Running under openSuSE 11.2, KDE 4.4.2

I have two monitors connected to my GeForce 8500 GT card, one is a large 1920x1080 screen and the other is a 800x600 small monitor. I have set the small monitor up as a clone of the large monitor and configured it's panning size to be 1920x1080. This works fine as expected, but when I reboot the system the panning setting and clone mode are lost (reset back to Absolute) and I have to reset them again every time. A PITA!

How do I persist these settings so that the clone mode and panning is restored on rebooting the system?

Marc..

Darkstar 04-26-10 11:59 PM

Re: nvidia-settings do not persist clone and panning settings
 
Ok well I think I figured out the problem.. This tool MUST be ran as root i.e. in superuser mode. It was installed as a menu item reachable via a normal user and is trying to modify the X11 config files. This tool should force the user to su to root before running, just like the Sax2 configuration tool does. IMHO this is a serious oversight and should be remedied as it leads to all kinds of confusion.

Marc..

luk1don 04-27-10 11:27 AM

Re: nvidia-settings do not persist clone and panning settings
 
Quote:

Originally Posted by Darkstar (Post 2240622)
Ok well I think I figured out the problem.. This tool MUST be ran as root i.e. in superuser mode. It was installed as a menu item reachable via a normal user and is trying to modify the X11 config files. This tool should force the user to su to root before running, just like the Sax2 configuration tool does. IMHO this is a serious oversight and should be remedied as it leads to all kinds of confusion.

Marc..

You're right. It's the question for developers - not for NVIDIA team:)

Darkstar 04-27-10 12:06 PM

Re: nvidia-settings do not persist clone and panning settings
 
Quote:

Originally Posted by luk1don (Post 2240831)
You're right. It's the question for developers - not for NVIDIA team:)

Well now that was a surprising answer! If the developers of Nvidia tools for Linux are not monitoring this forum, how do I reach them and/or submit a bug report?

Marc...


All times are GMT -5. The time now is 12:28 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.