nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nForce 730a USB audio failures (http://www.nvnews.net/vbulletin/showthread.php?t=150975)

oldcyberdude 05-14-10 01:15 PM

nForce 730a USB audio failures
 
1 Attachment(s)
After quite some time chasing various alternatives I have found a problem between the Linux kernel (usb core module) and the 730a MCP USB port. I have attached the nvidia-bug-report (with the USB device atttached, see lines 1438 and 2953) so I won't go into details of my system. In summary I'm running EVGA 730a motherboard with Ubuntu x64 v10.4

To get the "usb_set_interface failed" on line 2961 I simply opened gnome-volume-control and selected the USB audio device on the output tab.

Symptoms of the problem are failures of the Alsa sound mixer to control the output volume. The gnome applet continually reports...awaiting sound system response. The clue to the problem is revealed by dmesg. The kernel repeatedly reports usb_set_interface failed until the USB audio device is removed.

A little kernel checking shows the usb_set_interface call is in usbcore and being called by usbaudio. It described as follows "usb_set_interface Makes a particular alternate setting be current"

BTW, I have concluded that it is the nForce MCP by using both Ubuntu 10.4 and Fedora 12 on my system with exactly the same result. I also have used the USB audio device completely successfully on my EeePC using Linux EasyPeasy (a Ubuntu variant with the same basic kernel version).

Any thoughts anyone has would be greatly appreciate by this oldcyberdude :)

zbiggy 05-16-10 05:05 AM

Re: nForce 730a USB audio failures
 
Is this usb 1.1 or usb 2.0 device? If this is USB 1.1 device this can be usb 1.1 ohci bug on last nForce chipsets. Does adding noapic or acpi=noirq or using discrete card with usb ports solves the problem for you? If yes tell me your mainboard manufacturer and model. Does other usb 1.1 devices also does not work on your nForce mainboard?

oldcyberdude 05-16-10 09:14 AM

Re: nForce 730a USB audio failures
 
zbiggy - thanks for the reply

> Is this usb 1.1 or usb 2.0 device?
Appears to be a 1.1 device manufacturer specs say
Computer Connector: USB 1.1/2.0 Compatible
Standard USB "A" type Conn.

> Does adding noapic or acpi=noirq
Tried several combinations nothing solved the problem. Here are results
noapic noacpi -- same usb_set_interface failed
noapic acpi_os=linux -- no sound control, reported DBus warning, urbs active message missing from dmesg
noapic acpi=noirq -- no sound control, reported DBus warning, urbs active message missing from dmesg
noapic acpi=oldboot same usb_set_interface failed
noapic acpi=ht -- no sound control, just unhung

> using discrete card with usb ports solves the problem for you
If you mean can I use the onboard sound? Yes Unfortunately, I wanted to use the USB audio to provide a second sound card to free up the on-board so I don't have change cables constantly.

> tell me your mainboard manufacturer and model.
The motherboard is an EVGA model 730a

> Does other usb 1.1 devices also does not work on your nForce mainboard?
They seem to.

zbiggy 05-16-10 12:00 PM

Re: nForce 730a USB audio failures
 
Quote:

Originally Posted by oldcyberdude (Post 2252291)
> using discrete card with usb ports solves the problem for you
If you mean can I use the onboard sound? Yes Unfortunately, I wanted to use the USB audio to provide a second sound card to free up the on-board so I don't have change cables constantly.

I mean borrow from someone PCI or PCI-E card with usb ports, put inside your PC with nForce 730a and test if the problem still exist when you connect your usb device to connectors on this PCI/PCI-E card, not to those on mainboard.

nForce 7xx and Geforce 8xxx mainboards have broken USB OHCI controller which is used for connecting USB 1.1 devices. It just hangs. Nvidia know about this bug but did not provide fix for it. I doubt if they work on this. The last contact I had with Daniel Dadap from Nvidia was at 16/03/2010 when he was collecting hardware to reproduce the bug. He said tomorrow (the day after 16/03/2010) will send me the findings. Today is 16/05/2010 and have no response. Nvidia quit chipset business recently so we are probably left without support and fixes.

I was always buying and recommending nForce chipsets for all these years to everybody since nForce2 up to and including Geforce 8200 chipset from nForce7xx family. Now I'm sad I was treated this way. This is not a problem when company releases buggy chipset when it also releases a fix. But leaving chipset business with growing number of customers who encounter this not fixed bug is ugly. I'm enough. Next mainboard will be from AMD/ATI.

oldcyberdude 05-19-10 07:44 PM

Re: nForce 730a USB audio failures
 
Zbiggy..... You were absolutely right!!!:captnkill: I bought an Ultra 6 port USB PCI card that uses a VIA VT82xxxx chipset and my problems are gone :D

NOBODY SHOULD BUY A NVIDIA BASED MOTHERBOARD!!! and shame on NVIDIA for not standing up and fixing the problem!! Like you, I used to think Nvidia was pretty good particularly when it came to Linux. But no longer! You are right; avoid Nvidia products based on poor support. Running a bulletin board is easy, fixing real problems is the test.

zbiggy 05-26-10 02:15 PM

Re: nForce 730a USB audio failures
 
@oldcyberdude I forgot to tell you that usb 1.1 is broken only in full speed mode.
The usb 2.0 controller is working perfect so you can connect any usb 2.0 device to mainboard and never have trouble.
usb 1.1 low speed devices like keyboards, mice should work well but this is not sure.

oldcyberdude 05-27-10 09:29 AM

Re: nForce 730a USB audio failures
 
Thanks Zbiggy, It does seem that my USB mouse works fine directly on the motherboard. I have also found that my Prolific Technology brand (PL2303) USB->Serial converter works much better on the VIA board. Before the Prolific was very "unstable" sometimes it would work other times not. Now everything ,USB->Serial and USB audio are on the VIA board and are very solid!


All times are GMT -5. The time now is 11:25 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.