nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   signal 11 with 195.36.24 amd64 (http://www.nvnews.net/vbulletin/showthread.php?t=151116)

bschwand 05-19-10 08:18 AM

signal 11 with 195.36.24 amd64 when hitting certain keys
fresh install of FreeBSD8 on an asus M4A785TD-V EVO mobo, amd phenom II X4 965 cpu, two asus EN8400GS silent videocards. Mobo graphics disabled. X starts fine, works for a while, then at some point quits on signal 11. Nothing special in the Xorg log, besides that it caught a signal 11.

The crash seems to happen on a backspace or up/left arrow. I disabled X zapping (CTRL ALT BACKSP), it still happens from time to time.

I found this post http://forums.freebsd.org/showthread.php?t=9141 that claims it is related to xinerama. However, since I have three monitors on 2 video cards, I can not use twinview, can I ? right now I use three separate screens and xinerama.

Anybody can enlighten me, or knows of a workaround ?
I can provide any logs and anything that will help fix this crash. I am not familiar with the kernel debugger but I have several machines so i could connect after a crash and if anybody can provide a little guidance on what to do to investigate and help fix this crash, I will do it.

Any Help much appreciated, thanks

zander 05-19-10 10:45 AM

Re: signal 11 with 195.36.24 amd64
Please generate an nvidia-bug-report.log file (see http://www.nvnews.net/vbulletin/showthread.php?t=150452) following one of the crashes and attach it.

bschwand 05-20-10 02:39 AM

Re: signal 11 with 195.36.24 amd64
1 Attachment(s)
well now it is not happening because... I cannot interact with x long enough to see it crash. After a few seconds of operating normally, the focus gets stuck on a window and I can not do much basically. I can't even kill the window that has focus. If I ssh and kill the window with focus, some other window gets the focus and gets stuck on that. Keyboard and mouse do work however within that focused window, as well as switching to the console with CTRL-ALT-F1. I changed window manager (from KDE to fvwm2) and it is still happening.

Here is a nvidia-bug-report produced from the console while X running, stuck focus.

bschwand 05-20-10 04:01 PM

[solved] Re: signal 11 with 195.36.24 amd64
looks like the issue was unrelated to the nvidia driver. I am not sure exactly which part solved it, but this is what I did:

I updated and rebuilt everything from the ports (portupgrade -a), then disabled dbus and hal in rc.conf, then added the following to xorg.conf :

Option "AutoAddDevices" "false"
Option "AllowEmptyInput" "false"

then removed the usb wireless keyboard/mouse and replaced it with a standard usb keyboard and a PS/2 mouse.

System has been up for 3 hours, everything seems to work (well excpet some broken ports but I don't care), no problem. NVidia rocks !

All times are GMT -5. The time now is 01:19 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.