nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   VDPAU does not work with GT 230M and 195.36.03 (http://www.nvnews.net/vbulletin/showthread.php?t=151135)

larophel 05-19-10 10:34 PM

VDPAU does not work with GT 230M and 195.36.03
 
4 Attachment(s)
Hi,

I have tried to get VDPAU running with my GT 230M and the 195.36.03 drivers.
Unfortunately, it seems not to work.
I have searched this forum but nobody seems to get the same error code as I do (6192).

I have attached:

- nvidia-bug-report.sh output
- two mplayer output logs, one using ffmpeg12 and the other using ffmpeg12vdpau, both with: "export VDPAU_TRACE=1" and "export VDPAU_NVIDIA_DEBUG=3".
- output of vdpauinfo

The video file I use for testing I downloaded from http://inventaaustralia.zftp.com.nyu...3MBPS30sec.mpg (it was linked in another thread as a good testing example).

Please let me know if you need anything else and I will happily provide it.

Thanks,

Manuel

larophel 05-20-10 11:12 AM

Re: VDPAU does not work with GT 230M and 195.36.03
 
Alternative question: the reason why I want to use VDPAU is because I am experiencing skipping of frames when playing a video file on my LCD TV using HDMI.
It is not a HD video file (low resolution), does not have HD audio and the skipping does not happen when I play it on my laptop's screen.
Is there a way to play these files on my LCD TV without skipping?

Stephen Warren 05-20-10 11:39 AM

Re: VDPAU does not work with GT 230M and 195.36.03
 
larophel,

Firstly, NVIDIA doesn't recommend the use of driver version 195.36.03; there were some fan control issues; see http://www.nvnews.net/vbulletin/announcement.php?f=14.

Can you please try the latest driver; 195.36.24.

Based on your error code, my initial suspicion is a driver installation problem. Hopefully, installing the most recent driver will correct this.

larophel 05-20-10 12:35 PM

Re: VDPAU does not work with GT 230M and 195.36.03
 
Hi Stephen,

Silly me! It seems like there was a left-over from when I installed version 195.36.03 on my machine with the nvidia installer and then updated to 36.24 using the Gentoo package manager.
I uninstalled the driver, used NVIDIA-Linux-x86_64-195.36.24-pkg2.run --uinstall and installed the Gentoo package again and now it works!

Thanks a lot :)

larophel 06-14-10 12:09 AM

Re: VDPAU does not work with GT 230M and 195.36.03
 
3 Attachment(s)
It seems I am having problems with vdpau again. I had not used in some time and tried to play a movie yesterday using vdpau but it did not work.
vdpauinfo shows some weird errors that were not there before.
I have attached the usual log files.

I appreciate any hints you have to solving this problem!

Stephen Warren 06-14-10 12:29 PM

Re: VDPAU does not work with GT 230M and 195.36.03
 
larophel,

As far as I can tell, vdpauinfo is working fine; I'd expect to see some errors from an application that queries which features a driver supports.

I can't tell why MPlayer fails; I don't really see any kind of error message. Can you please run the following commands before running MPlayer, and post the results:

export VDPAU_NVIDIA_DEBUG=3
export VDPAU_TRACE=1

Thanks.

larophel 06-14-10 09:08 PM

Re: VDPAU does not work with GT 230M and 195.36.03
 
Last night, as a last resort, I downgraded from Xorg 1.8.901 to 1.8
This did not work, but when I started my computer today vdpau output was working again.
Then I updated again to Xorg 1.8.901 and vdpau keeps working.
Sorry for the false alarm I guess!


All times are GMT -5. The time now is 07:56 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.