nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Kernel sometimes (!) not loading module (http://www.nvnews.net/vbulletin/showthread.php?t=151145)

Wise Ferret 05-20-10 05:32 AM

Kernel sometimes (!) not loading module
 
Ubuntu lucid, dell xps 13 (geforce 9500m).
When I turn the laptop on, I always get an error in kern.log and fail to load X with nvidia. If I reboot several minutes later, it is sometimes fixed - and sometimes it is not.
I attach the bug report, but here are the immediately relevant lines from kern.log:

May 20 01:29:52 aku kernel: [ 1613.675079] ACPI: PCI Interrupt Link [LPMU] enabled at IRQ 23
May 20 01:29:52 aku kernel: [ 1613.675084] nvidia 0000:00:03.5: PCI INT B -> Link[LPMU] -> GSI 23 (level, low) -> IRQ 23
May 20 01:29:52 aku kernel: [ 1613.675110] nvidia 0000:02:00.0: enabling device (0000 -> 0003)
May 20 01:29:52 aku kernel: [ 1613.675120] nvidia 0000:02:00.0: PCI INT A -> Link[Z00Q] -> GSI 23 (level, low) -> IRQ 23
May 20 01:29:52 aku kernel: [ 1613.675144] vgaarb: device changed decodes: PCI:0000:02:00.0,olddecodes=io+mem,decodes=none:ow ns=none
May 20 01:29:52 aku kernel: [ 1613.675422] NVRM: The NVIDIA probe routine was not called for 1 device(s).
May 20 01:29:52 aku kernel: [ 1613.675424] NVRM: This can occur when a driver such as rivafb, nvidiafb or
May 20 01:29:52 aku kernel: [ 1613.675425] NVRM: rivatv was loaded and obtained ownership of the NVIDIA
May 20 01:29:52 aku kernel: [ 1613.675425] NVRM: device(s).
May 20 01:29:52 aku kernel: [ 1613.675427] NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel module
May 20 01:29:52 aku kernel: [ 1613.675428] NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
May 20 01:29:52 aku kernel: [ 1613.675429] NVRM: support), then try loading the NVIDIA kernel module again.
May 20 01:29:52 aku kernel: [ 1613.675431] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.15 Fri Mar 12 00:29:13 PST 2010
May 20 01:30:12 aku kernel: Kernel logging (proc) stopped.

If you ave any ideas for a solution, a workaround or even further examination of the problem, I will be most grateful!

leigh123linux 05-20-10 05:36 AM

Re: Kernel sometimes (!) not loading module
 
Try blacklisting nouveau

http://www.nvnews.net/vbulletin/show...75&postcount=5

Wise Ferret 05-21-10 08:42 PM

Re: Kernel sometimes (!) not loading module
 
Sorry for not answering - I had to make sure my solution works, and so far it does.

Thank you very much for your help. It seems that the problem is not with nouveau, as it was not solved by blacklisting it. The problem is that ubuntu pre-loads the driver vga16fb in order to enable plymouth graphical boot.

I did:

sudo gedit /etc/modprobe.d/blacklist.conf

And added the following lines:

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

And now my system behaves, although with textual booting sequence.


All times are GMT -5. The time now is 11:33 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.