nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GT 330M Driver problems (http://www.nvnews.net/vbulletin/showthread.php?t=151243)

scratch2.0 05-22-10 06:59 PM

GT 330M Driver problems
1 Attachment(s)

im running linux mint 9 / also tried ubuntu 10.4 but had the same problem.

i have a sony vaio VPCF11S1E with a Nvidia GT 330m

i searched the software manager but the is nothing for the 195.36.24

then the proprietary hardware driver asks if i like to install propritary drivers, when i do that i get a black screen after the next reboot.

After a new install, i deinstalled everything from nvidia (i read that on a board)
i tried to install the driver from the nvidia site 195.36.24 during the installation i get a error massage:
Unable to load the Kernel module nvidia.ko

i got the log .

i hope somebody can help me figure this out.


scratch2.0 05-24-10 06:43 AM

Re: GT 330M Driver problems
over 100 hits, and not one reply

somebody has to know something.
am i the only one with that problem?


ledoc 05-24-10 11:48 AM

Re: GT 330M Driver problems
You have a conflict with the nouveau driver. So before you run the nvidia installer, do an rmmod nouveau and make sure nvidiafb is not loaded either.

If either one is compiled into the kernel and not as module, you probably have to use/build another kernel.

It's also possible that you can't unload nouveau, then you have to blacklist it so that for the next boot it's not loaded in the first place. Not sure what exactly needs to be done for that (depends a bit on the distro, too).

damentz 05-24-10 07:36 PM

Re: GT 330M Driver problems
Monitor detection is broken for the laptop screen.

Try a variation of this:


Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "CustomEDID" "DFP-0:/proc/acpi/video/NGFX/LCD/EDID"
    Option        "ConnectedMonitor" "DFP-0,DFP-1"
    Option        "TwinView" "1"
    Option        "TwinViewXineramaInfoOrder" "DFP-0"
    Option        "metamodes" "DFP-0: 1600x900_60 +0+0, DFP-1: 1440x900_60 +1600+0"
    SubSection    "Display"
        Depth      24

This configuration in xorg.conf is for my setup, with an external monitor via HDMI.

The caveat is by specifying "ConnectedMonitor", monitor detection essentially breaks after you login (dynamic twin view no longer can detect changes to any of the ports).

There also seems to be a bug in card initialization when using the BFS scheduler. 3/4 of the time when you boot, you will get terrible performance. Con says that it's usually from real buggy code and that his scheduler is simply more prone to exploiting those bugs. There's nothing he can fix on that end.

NOTE: I'm very confused why the nVidia driver cannot detect the laptop lid when the EDID code is freely available from /proc/acpi/video/NGFX/LCD/EDID. Maybe the devs should look at how Linux gets the EDID data and contrast it with their own.

scratch2.0 05-25-10 06:50 PM

Re: GT 330M Driver problems

i dont had not enough to to work further on this, but i got a newsletter that there is a new driver for windows for the gt 330m.
and on May 21, 2010 there was a beta release for linux.

should i try to install the beta driver?
Does that mean in that in the next couple of weeks a stable release is coming.
maybe also a update for the linux mint 9 software manager?

im not really good with the terminal and i dont want to mess up my hardware,
i read about laptops were the motherboard or graphic card melted, because a fan wasn't running good.

i hope linux mint will bring a update to fix this soon.

thx anyway

gradinaruvasile 05-25-10 08:39 PM

Re: GT 330M Driver problems
You seem to have the nouveau driver loaded also as i read from that log file.
Edit the /etc/modprobe.d/blacklist.conf file with sudo rights:
Open a terminal and type:

sudo gedit /etc/modprobe.d/blacklist.conf

Add to the end of the file:

blacklist nouveau

Press enter at the end of the line. Save the file. Install the driver - first try the provided packages to see if they work. Reboot.
If still doesnt, you may need to disable KMS - it is a feature that the nvidia driver doesnt support. Google around how to do it exactly, in essence a kernel boot parameter has to be passed, not big deal. You probably use Grub2, i use Grub and they are different to set up.

I recommend using the nvidia-provided driver 195.36.24 or the 256 beta if the packaged driver doesnt work.

PS: I use that beta driver on Gf 210 and a 8200, both work well.

rfbeck1 05-25-10 11:54 PM

Re: GT 330M Driver problems
I think I can help you. I had the same problem. You have to "blacklist" other drivers that load and interfere with the installation of the NVIDIA driver.
The following is taken from this link:

2) Open module blacklist as admin

gksudo gedit /etc/modprobe.d/blacklist.conf

Add these lines and save:

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

3) Uninstall any previously installed Nvidia drivers:

sudo apt-get --purge remove nvidia-*

4) Reboot your computer

5) When an error message pops up saying that Ubuntu cannot load Nvidia drivers, choose Exit to terminal (Exit to console)

6) Login and cd to the directory where you saved your file

7)Install drivers

sudo sh NVIDIA-Linux-x86_64-195.36.24-pkg2.run

8)Start GDM

That worked for me anyway. Let me know how it turns out.

scratch2.0 05-26-10 11:02 AM

Re: GT 330M Driver problems
hi thx for the answers they sounded promising,
but unfortunately i still got the same problem

i tried it with both drivers but still got the same error..

im not sure about step 3

sudo apt-get --purge remove nvidia-*
[sudo] password for :
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting nvidia-vdpau-driver for regex 'nvidia-*'
Note, selecting nvidia-185-kernel-source for regex 'nvidia-*'
Note, selecting nvidia-96-kernel-source for regex 'nvidia-*'
Note, selecting nvidia-173-dev for regex 'nvidia-*'
Note, selecting nvidia-kernel-common for regex 'nvidia-*'
Note, selecting nvidia-common for regex 'nvidia-*'
Note, selecting nvidia-173 for regex 'nvidia-*'
Note, selecting nvidia-cg-toolkit for regex 'nvidia-*'
Note, selecting nvidia-180-libvdpau for regex 'nvidia-*'
Note, selecting nvidia-glx-96-dev for regex 'nvidia-*'
Note, selecting nvidia-current for regex 'nvidia-*'
Note, selecting nvidia-185-libvdpau-dev for regex 'nvidia-*'
Note, selecting nvidia-96 for regex 'nvidia-*'
Note, selecting nvidia-glx-dev for regex 'nvidia-*'
Note, selecting nvidia-current-modaliases for regex 'nvidia-*'
Note, selecting nvidia-vdpau-driver-ia32 for regex 'nvidia-*'
Note, selecting nvidia-185-libvdpau for regex 'nvidia-*'
Note, selecting nvidia-libvdpau for regex 'nvidia-*'
Note, selecting nvidia-glx-ia32 for regex 'nvidia-*'
Note, selecting nvidia-glx-173-dev for regex 'nvidia-*'
Note, selecting nvidia-glx-185-dev for regex 'nvidia-*'
Note, selecting nvidia-173-kernel-source for regex 'nvidia-*'
Note, selecting nvidia-glx-173 for regex 'nvidia-*'
Note, selecting nvidia-glx-180 for regex 'nvidia-*'
Note, selecting nvidia-glx-185 for regex 'nvidia-*'
Note, selecting nvidia-96-dev for regex 'nvidia-*'
Note, selecting nvidia-180-libvdpau-dev for regex 'nvidia-*'
Note, selecting nvidia-180-modaliases for regex 'nvidia-*'
Note, selecting nvidia-96-modaliases for regex 'nvidia-*'
Note, selecting nvidia-libvdpau-dev for regex 'nvidia-*'
Note, selecting nvidia-libvdpau-ia32 for regex 'nvidia-*'
Note, selecting nvidia-180-kernel-source for regex 'nvidia-*'
Note, selecting nvidia-libvdpau1 for regex 'nvidia-*'
Note, selecting nvidia-current-dev for regex 'nvidia-*'
Note, selecting nvidia-glx-96 for regex 'nvidia-*'
Note, selecting nvidia-173-modaliases for regex 'nvidia-*'
Note, selecting nvidia-185-modaliases for regex 'nvidia-*'
Note, selecting nvidia-glx for regex 'nvidia-*'
Note, selecting nvidia-glx-180-dev for regex 'nvidia-*'
Note, selecting nvidia-settings for regex 'nvidia-*'
E: Couldn't find package nvidia-*

when i go on with the installation i get the same error.

or does the * stands for the version number that i have to insert?
when yes, which one its a clean install and i uninstalled everything that the softwaremanager finds under "nvidia"


gradinaruvasile 05-26-10 12:50 PM

Re: GT 330M Driver problems
That should not be a problem. You dont have anything with nvidia installed.
Does the installer script begins and it goes through the installation procedure without ANY error?

scratch2.0 05-26-10 02:05 PM

Re: GT 330M Driver problems
yes, the installation goes to 100 % and then 3 seconds later the error shows up

gradinaruvasile 05-26-10 03:04 PM

Re: GT 330M Driver problems
The "unable to load module" one?

Are you absolutely sure you blacklisted nouveau&co and then rebooted?

Also, there is a thing called KMS - that should be deactivated too.
You have to append "nomodeset" to your kernel boot parameters.
If you are using Grub loader, edit the /boot/grub/menu.lst file:

sudo gedit /boot/grub/menu.lst

find the default boot entry (the upper one that appears in the boot options)

The entry contains a few lines beginning with title, root, kernel, initrd.
You need to edit the kernel line, appending to the end of it "nomodeset" without the quotes - make sure that it has a space between the previous option and the nomodeset.

If there is no menu.lst, you have the Grub2 loader. Edit the /etc/default/grub file:

sudo gedit /etc/default/grub

look for GRUB_CMDLINE_LINUX_DEFAULT, append to the existing options "nomodeset" withouth the quotes - leave spece between it and the rest of the options.

Reboot, repeat the rest of the procedure.

scratch2.0 05-27-10 01:32 PM

Re: GT 330M Driver problems
hi guys

thx for all the help but i stop it here

im tired of wasting my time, im trying to figure this out for the last 2 weeks (spending several hours a day).
so i'm just hoping that there will be a update that will fix that soon.
what do you think, how long this could take?
i cant be the only one who has that problem.

im not really good with the terminal, thats why i'm running mint in the first place, but it will not work.

thx again for all the help

if somebody figures this out, i'm still open for advises


All times are GMT -5. The time now is 07:22 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.