nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   195.36.24: No Signal on Displayport (http://www.nvnews.net/vbulletin/showthread.php?t=151882)

MeisterP 06-10-10 02:02 PM

195.36.24: No Signal on Displayport
 
2 Attachment(s)
Hello,

I try to connect an external monitor with a Displayport to DVI-D (Dual Link) cable. The graphical nvidia-settings tool recognizes the external monitor and I'm able to set up all options but after restarting X, the second monitor doesn't receive a signal. It's like everything is working (X starts, no errors, no segfault, I can move the mouse out off the laptop screen... ) just that the signal gets lost somewhere in the graphic card or in the adapter.

If I connect via VGA the external monitor works just fine.

I am running Fedora 13 on a HP Elitebook 8540w, the graphic card is a Quadro FX 880M.

Kernel: 2.6.33.5-112.fc13.x86_64
Driver: 195.36.24

Working configuration with VGA --> nvidia-bug-report.vga.log.gz
No Signal found with DP-DVI --> nvidia-bug-report.dp-dvi.log.gz

Any help would be appreciated. Thanks.

DanM 06-11-10 12:38 AM

Re: 195.36.24: No Signal on Displayport
 
Same issus here with a Quadro FX 3800.

danix 06-11-10 03:25 PM

Re: 195.36.24: No Signal on Displayport
 
DisplayPort to dual link DVI adapters are active devices; you might be seeing and configuring the adapter in the control panel, and the adapter may be failing to bring up the display. Have you tried a single link passive dongle?

MeisterP 06-12-10 01:33 PM

Re: 195.36.24: No Signal on Displayport
 
Hey Danix,

Thanks for your reply.

The adapter I use is not an active one. The DVI plug has all the pins like a dual link adapter (according to Wikipedia http://en.wikipedia.org/wiki/Digital_Visual_Interface) but apparently not all of them are really used.
To make it short, I already used a DisplayPort to DVI-D (Single Link) adapter - the information in my initial post is wrong. Sorry about that.

But more important, I was able to get the second monitor up and running via DisplayPort. The problem was that I patched the kmod-nvidia from rpmfusion. The patch solves a problem with Intel-VT enabled and can be found here: http://www.nvnews.net/vbulletin/showthread.php?t=151791

After installing the original driver from rpmfusion and readding iommu=soft to the kernel boot line the DisplayPort works fine.

The patch solved the vt-iommu issue but it seems to break the DisplayPort. I think the problem is either the patch or the way I applied it to the package.

If you need more information feel free to ask.

danix 06-14-10 12:49 PM

Re: 195.36.24: No Signal on Displayport
 
Thanks for the update. I'll investigate for possible interactions between the Intel-VT patch and DisplayPort functionality.


All times are GMT -5. The time now is 01:34 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.