nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   VDPAU Error 0 6291 with 9600GT (http://www.nvnews.net/vbulletin/showthread.php?t=152253)

EvilGuru 06-22-10 06:53 AM

VDPAU Error 0 6291 with 9600GT
 
1 Attachment(s)
Hi,

I am having trouble getting VDPAU to work under my 9600GT running Ubuntu Linux 10.04. The precise error (when running vdpauinfo) is as follows:
Code:

VDPAU nvidia: Version: NVIDIA VDPAU Driver Shared Library  195.36.24  Thu Apr 22 19:52:55 PDT 2010
VDPAU nvidia: Error detected 0 6291
VDPAU nvidia: Backtrace:
--: /usr/lib/vdpau/libvdpau_nvidia.so.1 [0x7f7cf549d000] DSO load base
00: /usr/lib/vdpau/libvdpau_nvidia.so.1 [0x7f7cf54a3ab9] vdp_imp_device_create_x11
Error creating VDPAU device: 1
display: :0.0  screen: 0

I have tried removing and purging the nvidia-current package from my system to no effect. In addition I have also tried installing the latest version of the libvdpau1 package from the vdpau PPA repository.

OpenGL works fine, no issues there and have no other reasons to suspect the driver is not functioning properly. Bug report attached.

EvilGuru 06-22-10 09:14 AM

Re: VDPAU Error 0 6291 with 9600GT
 
I tried switching the 9600GT this system with a 275GTX I have in another Linux system (where VDPAU is known to work fine, Gentoo ~AMD64).

The result is that with the 275GTX installed VDPAU works. In addition if I place the 9600GT into the system which usually houses the 275GTX VDPAU fails in a similar manner.

Hence it appears to be that the nvidia drivers do not like my 9600GT. Ideas? The profuse irony in all of this is that the sole reason I purchased a 9600GT was because I wanted a card that supported VDPAU.

Regards, Freddie.

Stephen Warren 06-22-10 10:30 AM

Re: VDPAU Error 0 6291 with 9600GT
 
EvilGuru, it's possible you're experiencing the problem described in thread http://www.nvnews.net/vbulletin/showthread.php?t=130690. To confirm this, could you please try driver version 185.18.14 and report which error message that version displays. Thanks.

EvilGuru 06-22-10 11:12 AM

Re: VDPAU Error 0 6291 with 9600GT
 
Quote:

Originally Posted by Stephen Warren (Post 2275400)
EvilGuru, it's possible you're experiencing the problem described in thread http://www.nvnews.net/vbulletin/showthread.php?t=130690. To confirm this, could you please try driver version 185.18.14 and report which error message that version displays. Thanks.

My distribution (Gentoo) provides:
Code:

ChangeLog                          nvidia-drivers-190.53.ebuild
files                              nvidia-drivers-190.53-r1.ebuild
Manifest                            nvidia-drivers-195.30.ebuild
metadata.xml                        nvidia-drivers-195.36.15.ebuild
nvidia-drivers-173.14.22.ebuild    nvidia-drivers-195.36.24.ebuild
nvidia-drivers-173.14.25.ebuild    nvidia-drivers-71.86.11.ebuild
nvidia-drivers-180.60.ebuild        nvidia-drivers-96.43.14.ebuild
nvidia-drivers-185.18.36-r1.ebuild  nvidia-drivers-96.43.16.ebuild
nvidia-drivers-190.42-r3.ebuild

Would 185.18.36 be suitable?

Regards, Freddie.

Stephen Warren 06-22-10 11:23 AM

Re: VDPAU Error 0 6291 with 9600GT
 
We made a change in the way a particular condition was reported. This old reporting method lasted until 185.18.14, and later drivers have the new method. I need to see the error codes from the old method, so unfortunately, you have to use 185.18.14 or older.

You should be able to download the .run file from our FTP site and use that to install the driver.

EvilGuru 06-23-10 06:12 AM

Re: VDPAU Error 0 6291 with 9600GT
 
Quote:

Originally Posted by Stephen Warren (Post 2275448)
We made a change in the way a particular condition was reported. This old reporting method lasted until 185.18.14, and later drivers have the new method. I need to see the error codes from the old method, so unfortunately, you have to use 185.18.14 or older.

You should be able to download the .run file from our FTP site and use that to install the driver.

I had a go with it but the combination of Xorg 1.8 and libvdpau (which for Gentoo is its own package with quite strong dependencies) meant that I was unable to install the driver. At least not without removing quite a few packages from the system.

Apologies there; is there anything else I can try?

Regards.

Stephen Warren 06-23-10 10:16 AM

Re: VDPAU Error 0 6291 with 9600GT
 
Ah yes. That old of a driver wouldn't support that X server. Sorry.

I'll look into enhancing the code that's triggering that error to report more fine-grained failure information. Whichever future driver includes this should print a debug message indicating the problem.

EvilGuru 06-24-10 04:33 AM

Re: VDPAU Error 0 6291 with 9600GT
 
Okay. Thank you.

When such a driver becomes available would you be able to ping me. I usually keep quite up to date when it comes to drivers so should be able to test soon after.

Regards, Freddie.


All times are GMT -5. The time now is 02:46 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.