nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia Dual FX4800 Cards - 2nd card not working all the time (http://www.nvnews.net/vbulletin/showthread.php?t=152315)

ikeurb 06-23-10 04:35 PM

Nvidia Dual FX4800 Cards - 2nd card not working all the time
 
Crazy issue...

I can get both of the Nvidia FX4800 working perfectly (PCIe cards).

The problem is, when I install my PCIe Audio Science card, my second video card drops offline.

When I run nvidia-settings, the second video card does not show up.

When I remove the audio card, then the second video card work great again and show up under nvidia-settings.

Soe sort of conflict for sure.

Ideas?

ikeurb 06-24-10 11:20 AM

Re: Nvidia Dual FX4800 Cards - 2nd card not working all the time
 
As a troubleshooting measure, I booted into Windows XP Professional, and everything worked as it should. Both video cards worked as well as the sound card. So its safe to say it is an issue isolated to Linux specifically.

I also tried blacklisting the Alsa "snd-asihpi" driver as well as the vendor supplied "asihpi" AudioScience driver.

Added both of the following lines to /etc/modprobe.d/blacklist.conf
blacklist asihpi
blacklist snd-asihpi

Upon reboot, both video cards wre working well. Then I manually loaded the driver using "sudo modprobe snd-asihpi". Audio played after this as well.

I then commented out the "snd-asihpi" driver from blacklist.conf and rebooted so that the "snd-asihpi" driver would load upon reboot. Audio played upon reboot but the second video card again stopped working again.

Blacklisting both asihpi and snd-asihpi cures the problem. But, I'm not liking the fact that I have to manually load the Alsa snd-asihpi after boot.

This will be an issue for our end users.


All times are GMT -5. The time now is 06:39 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.