nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Fedora 13+ multiple cards+ Xinerama = frustration (http://www.nvnews.net/vbulletin/showthread.php?t=152338)

Aquila2063 06-24-10 11:13 AM

Fedora 13+ multiple cards+ Xinerama = frustration
2 Attachment(s)
I recently upgraded from a fully working setup in fedora 11 to fedora 13. I
have a dual socket, quad core dell workstation running xeons and three nvidia
graphics cards: geforce 9500GT, geforce 9400 GT and an nvidia GTX 260. The
three graphics cards powered five monitors through xinerama using the nvidia
driver in fedora 11 without any problems.

After I installed fedora 13 and did a yum update on everything, I disabled the
nouveau driver, installed the latest nvidia driver and enabled xinerama. When I
move the cursor across monitors, I get the following error:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

The cursor starts to flicker and does not respond to mouse movements, the keyboard goes dead.
My guess is at this point X is pretty much dead at that point. Sometimes it restarts on
its own after this failure, sometimes it just hangs and I have to ssh and init 4 to
bring it down.

I have done some research on this for a couple of days now and this error
appears to be a symptom, not a bug in itself. That is to say it is a catch all
error that can be triggered in a number of places.

Also, I ran into something similar when I temporarily upgraded to Fedora 12. I
did not pursue the matter though and reverted back to fedora 11. If it helps, I
have tried to re-apply the patch suggested here:

to the VGA arbiter in the past but it did not help. I could have easily been
simply doing it wrong. I do however hope that the patch made its way into the
nvidia driver by now but I still trying to confirm this.

Does anybody have any idea how I can get more information regarding this
error or any idea how to fix it? Needless to say I am growing desperate and
want to revert back to fedora 11 however I prefer to keep up with the times
since I use my workstation as a development platform.

Aquila2063 06-24-10 11:15 AM

Re: Fedora 13+ multiple cards+ Xinerama = frustration
Sorry, I left out some important information.The system/component versions are as follows:

* Fedora 13
* uname -a
Linux defiant-sovereign #1 SMP Fri Jun 11 09:38:12 UTC
2010 x86_64 x86_64 x86_64 GNU/Linux
* X -version

X.Org X Server 1.8.0
Release Date: 2010-04-02
X Protocol Version 11, Revision 0
Build Operating System: x86-02 2.6.18-164.15.1.el5
Current Operating System: Linux defiant-sovereign #1
SMP Fri Jun 11 09:38:12 UTC 2010 x86_64
Kernel command line: ro root=UUID=1ef93da6-4809-4456-994b-814274216206
SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet rdblacklist=nouveau nomodeset
Build Date: 02 May 2010 02:56:53PM
Build ID: xorg-x11-server 1.8.0-12.fc13
Current version of pixman: 0.18.0
Before reporting problems, check http://bodhi.fedoraproject.org/
to make sure that you have the latest version.

I am using nvidia drivers for x86_64: NVIDIA-Linux-x86_64-256.35.run from the
install script not rpmfusion kmods.

Aquila2063 06-25-10 10:18 AM

Re: Fedora 13+ multiple cards+ Xinerama = frustration
So it turns out the bug I was seeing was a manifestation of this bug:

Updating to xorg-x11-server-Xorg- fixed the problem for the better part. However I still do get occasional graphical artifacts in the form of squares that follow the cursor but only on one particular monitor, the middle 30" monitor. All other monitors are fine, and obviously this was not the case with fedora 11 so I know the hardware is good. Anyone has any ideas?

Aquila2063 06-28-10 10:03 AM

Re: Fedora 13+ multiple cards+ Xinerama = frustration
The problem seems to be two fold. There is an issue with Fedora 13's X (up to Xinerama is broken and won't allow the cursor to jump from one screen to another out of order. This has been fixed in rawhide with a patch (X, details available here:

The second issue is the squares/artifacts that follow the cursor around only on the center screen. As of yet I have not determined what the primary cause is however I am inclined to conclude it is the nvidia driver. This is because I got the same squares/artifacts when I used the latest nvidia drivers on Fedora 11. That is to say, upgrading the nvidia drivers from 190 to 253 breaks my setup. There is nothing in X log to indicate any problems, nothing in messages or dmesg. Is there a way to enable more detailed logging from the nvidia drivers?

As I mentioned earlier, the issue only presents itself at the center screen. There is nothing special about it that I can discern, it is hooked up to the gtx 260. Any ideas, suggestions, are greatly appreciated.

All times are GMT -5. The time now is 12:30 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.