nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Weird problem with RPM (http://www.nvnews.net/vbulletin/showthread.php?t=1524)

jensa 09-04-02 04:59 PM

Weird problem with RPM
 
Hi, Im a newbie to Linux and was trying to install the drivers for geforce2 mx.
When I was running the package (rpm -ivh NVIDIA_kernel.whatever.rpm) I received an error message at the end. (I dont really remember what kind of error it was but it couldnt insmod the nvidia driver.)
Anyway, here comes the weird part.....when I try to uninstal/erase the package (rpm -e NVIDIA_kernel.whatever) I get the reply that the package isnt installed. But when I try to install it again, Im told it is already installed. Now what is it??? Installed or not.
When I run rpm -q NVIDIA* , Im told none of the packages are installed....
Has anyone else been through this? Or is this normal? I was using the newest packages so the old bug Ive heard of shouldnt be the problem.....
Ill write another post about the error I got later...have to check it out again..

HeX 09-04-02 05:40 PM

Root
 
You may want to either log in as root or issue command "su" (without quotes) and entering the root password to the command prompt before installing the rpm. I have had success installing the rpm, but when I rebooted, I was unable to get a GUI. I figured I might be able to help you while I'm looking for a solution myself.

jensa 09-04-02 05:46 PM

I've been operating as root all along, so that shouldnt be the problem...I am, however thankfull for any help...

It turns out I installed the wrong kerneldriver ....shouldve used athlon....anyway everytime I try to install the athlon (and any other nvidia .rpm) I get the message that the file /lib/modules/2.4.18-3/kernel/drivers/video/NVdriver is conflicting with a previsously installed package....
Unfortunately .... as I mentioned in the earlier post...I cant seem to uninstall the previous package....grrrrrr!!!

Does anyone have any idees?

jensa 09-04-02 06:10 PM

Go tarballs
 
YYEEESSS!!!
Those tarballs really did the trick...they automatically removed the old and conflicting files adn installed the new ones.
I tried to start xwindow and, yupp theres the nvidia logo.

Feels great to finaly have it working!

I recommend : tar balls

utiel 09-04-02 09:06 PM

rpm poblems...
 
To look where packages have installed

rpm -qa | grep NV*

/home/uti# rpm -qa | grep NV
NVIDIA_GLX-1.0-2960
NVIDIA_kernel-1.0-2960


To remove them

rpm -e NVIDIA_GLX NVIDIA_kernel


To install again, without removing

rpm -i NV*.rpm --force

To Update a new version

rpm -i NV*.rpm

To Update same version

rpm -U NV*.rpm --force


Installing NVidia drivers is not simply.

I always have to edit my XF86Config file!!! (only first time, for every distribution I try )


All times are GMT -5. The time now is 09:00 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.