nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia 256.35 driver fails to load on upcoming xorg-server-1.9 (http://www.nvnews.net/vbulletin/showthread.php?t=152439)

openelec.tv 06-27-10 06:59 AM

nvidia 256.35 driver fails to load on upcoming xorg-server-1.9
 
Hi,

i must do some tests with the upcoming xorg-server-1.9 (xorg-server-1.8.99.903) on an ION based mainboard.

the nvidia driver dont load:
xorg.conf:

Code:

[2035587.063]  compiled for 1.8.99.903, module version = 1.2.0     
[2035587.063]  ABI class: X.Org Server Extension, version 4.0                   
[2035587.063] (II) Loading extension DRI2                                         
[2035587.063] (==) Matched nvidia as autoconfigured driver 0         
[2035587.063] (==) Matched vesa as autoconfigured driver 1           
[2035587.063] (==) Matched fbdev as autoconfigured driver 2         
[2035587.063] (==) Assigned the driver to the xf86ConfigLayout       
[2035587.063] (II) LoadModule: "nvidia"                             
[2035587.063] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so         
[2035587.094] dlopen: /usr/lib/xorg/modules/drivers/nvidia_drv.so: undefined symbol: WindowTable                           
[2035587.094] (EE) Failed to load /usr/lib/xorg/modules/drivers/nvidia_drv.so                                                                               
[2035587.094] (II) UnloadModule: "nvidia"                                                     
[2035587.094] (EE) Failed to load module "nvidia" (loader failed, 7)                           
[2035587.094] (II) LoadModule: "vesa"                                                         
[2035587.098] (WW) Warning, couldn't open module vesa                                         
[2035587.098] (II) UnloadModule: "vesa"                                                       
[2035587.098] (EE) Failed to load module "vesa" (module does not exist, 0)                     
[2035587.098] (II) LoadModule: "fbdev"                                                         
[2035587.099] (WW) Warning, couldn't open module fbdev                                         
[2035587.099] (II) UnloadModule: "fbdev"                                           
[2035587.099] (EE) Failed to load module "fbdev" (module does not exist, 0)
[2035587.099] (EE) No drivers available.

this can be related of this commit: http://cgit.freedesktop.org/xorg/xse...dbf4117d928f9a where all references WindowTable[] are changed to screenInfo.screens[]->root

Code:

[stephan@x200t NVIDIA-Linux-x86-256.35]$ LANG=C grep -R WindowTable *
Binary file libnvidia-wfb.so.256.35 matches
Binary file nvidia_drv.so matches

because this is binary code, i cant create an patch.

for my tests i need an (beta) nvidia driver that works with xorg-server-1.8.99.x and up. is it possible to provide a new beta for testing newer xorg-server releases?

thanks very much

Stephan

AaronP 06-28-10 10:26 AM

Re: nvidia 256.35 driver fails to load on upcoming xorg-server-1.9
 
Hi Stephan. We generally try to follow development of the master branch of the X server closely and we do have support for it in our development codebase, but there are a lot of factors that contribute to when we can release betas. I'm afraid I can't give you an ETA on when a driver with those changes.

I can't make any promises, but if you sign up for the registered developer program, there's a chance we could give you early builds under NDA, if that's okay with you.

motote 06-29-10 10:57 AM

Re: nvidia 256.35 driver fails to load on upcoming xorg-server-1.9
 
Hello Aaron,
I'm also have the same problem with the main trunk of xorg.
I'm allready a registered developer, How can I proceed?

Thanks
Regards

AaronP 06-30-10 03:30 PM

Re: nvidia 256.35 driver fails to load on upcoming xorg-server-1.9
 
I actually just got permission to backport support for the latest xorg 1.9 release candidate to the 256.* series of drivers, so hopefully we'll be able to get a beta version of that out soon.

openelec.tv 07-01-10 07:23 AM

Re: nvidia 256.35 driver fails to load on upcoming xorg-server-1.9
 
Quote:

Originally Posted by AaronP (Post 2280645)
I actually just got permission to backport support for the latest xorg 1.9 release candidate to the 256.* series of drivers, so hopefully we'll be able to get a beta version of that out soon.

Thanks Aaron, that would be nice :-) I cant wait :-)

(for me it makes no sense at the moment to sign up for the registered developer program, only for the support of the new xorg-server, maybe later if i need other things :-) )

greetings Stephan

plun 07-21-10 05:22 AM

Re: nvidia 256.35 driver fails to load on upcoming xorg-server-1.9
 
Quote:

Originally Posted by AaronP (Post 2280645)
I actually just got permission to backport support for the latest xorg 1.9 release candidate to the 256.* series of drivers, so hopefully we'll be able to get a beta version of that out soon.

Hi Aaron

Any news about this new beta ??

seaweed 07-23-10 12:48 AM

Re: nvidia 256.35 driver fails to load on upcoming xorg-server-1.9
 
Quote:

Originally Posted by AaronP (Post 2280645)
I actually just got permission to backport support for the latest xorg 1.9 release candidate to the 256.* series of drivers, so hopefully we'll be able to get a beta version of that out soon.

Hi Aaron, I have a post under this link:

http://www.nvnews.net/vbulletin/showthread.php?t=153311

I think it is caused by a bug in earlier version of xserver. I would like to try out a patch as well, I am a registered developer. (we have an NDA with NVIDIA). Currently I am unable to compile the xserver 1.8 release.

Thanks


All times are GMT -5. The time now is 11:44 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.