nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Wrong interpolation between 2 vertices (http://www.nvnews.net/vbulletin/showthread.php?t=153124)

Funto 07-17-10 10:12 PM

Wrong interpolation between 2 vertices
 
Hi all,

I am using the experimental drivers 195.36.07.04 (I want modern OpenGL support).

I am drawing a line, from P0 to P1.
I have a varying variable declared like this in my vertex shader:

noperspective out vec3 var_debug_color;

In my vertex shader, I assign to var_debug_color the value vec3(0.0, 0.5, 0.0) for P0 and vec3(0.5, 0.0, 0.0) for P1.
P0 is visible, P1 is not inside the view frustum (behind the camera).

In my fragment shader, I just output vec4(var_debug_color, 0.0).

Problem: the values which appear on screen are above 127 for the green component!
Example RGB output I get:
0, 127, 0
0, 129, 0
0, 131, 0
0, 135, 0
...etc

I suppose this is a bug in the driver. I think I could provide a test case, if someone is willing to investigate this bug.

Thank you.

AaronP 07-18-10 12:19 AM

Re: Wrong interpolation between 2 vertices
 
195.36.07.04 is old, I'd suggest using 256.35. If the problem still occurs with that, then please do attach a simple test case, along with an nvidia-bug-report.log.gz file.


All times are GMT -5. The time now is 04:20 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.