nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Drivers won't load: EVGA GS250, Ubuntu 10.04(32bit),Asus A8N-SLI, AMD64 X2 4800 (http://www.nvnews.net/vbulletin/showthread.php?t=153493)

ProgrammerTim 07-27-10 09:50 PM

Drivers won't load: EVGA GS250, Ubuntu 10.04(32bit),Asus A8N-SLI, AMD64 X2 4800
3 Attachment(s)
Due to catastrophic system failure, I have decided I have the time to switch from Windows to Linux (since I have to format the hard drive anyway). I have been a programmer on Microsoft systems for 20+ years, but I know diddly about Linux. So it is possible that other posts on this forum may already tell me how to fix this issue, and I just don't understand them, and any help might be best phrased in simple to understand terms. :)

As stated in the title, I have an EVGA GeForce GS 250, an Asus A8n-SLI Premium, AMD 64 X2 4800 chip, and have installed Ubuntu 10.04.

I have a Sceptre x270W-1080p monitor. After installing, Ubuntu, my monitor runs properly at 1920x1080. Ubuntu detects the nvidia card and tells me I need the proprietary drivers. I install them and reboot and receive errors...

Failed to initialize the NVIDIA graphics device PCI:1:0:0
Failed to initialize the NVIDIA graphics device!
Screen(s) found, but none have a usable configuration.

I have the same error with the driver offered by ubuntu or downloading the latest nvidia drivers from the site. I have tried both options on a clean system (format and reinstall between attempts). I tried 9.01 (or whatever version the previous ubuntu was) and it failed with some sort of weirdness in which the view quickly flickered between a terminal and a black screen. I could type when it showed the terminal, not that it did me any good. I'm guessing it got caught in an infinite loop where it tried to load the gui, failed, dropped to the terminal for a split second, and then tried to load the gui again. I then tried 9.01 with an upgrade to 10.04. This is the current configuration and is getting the same errors.

I am attaching the bug report log file, my xorg.conf file (I'm running in "low graphics mode" right now, so I don't know if this is the real one or some sort of default one) and the output of ddcprobe.

I'd really like to get this resolved. I've wanted to get away from microsoft for a long time, and this gives me the chance. But I can't have Linux as my primary system if I can't get the hardware acceleration going to watch hulu without tearing and such. :)

AaronP 07-28-10 04:21 PM

Re: Drivers won't load: EVGA GS250, Ubuntu 10.04(32bit),Asus A8N-SLI, AMD64 X2 4800
Here's the error:

[ 18.797907] vmap allocation for size 16781312 failed: use vmalloc=<size> to increase size.
[ 18.798426] NVRM: RmInitAdapter failed! (0x26:0xffffffff:1076)
[ 18.798437] NVRM: rm_init_adapter(0) failed
Please see the section in the README that describes that message and what to do about it.

ProgrammerTim 07-28-10 08:29 PM

Re: Drivers won't load: EVGA GS250, Ubuntu 10.04(32bit),Asus A8N-SLI, AMD64 X2 4800
1 Attachment(s)
Ok, I looked in the readme. Couldn't find a way to search it, so I had to go through page by page. Still almost missed the entry because I was searching the pages for "vmap", which wasn't there.

The readme tells me it is some sort of memory issue, and I can't tell whether it is saying that Linux is allocating all of the memory for itself, or is allocating just a small portion for itself and not enough for the graphics drivers. Regardless, I need to set a kernel parameter.

Google search for "how do I set kernel parameters in ubuntu" came up with this:
Wasn't actually helpful, but the link for previous page took me to "Booting the installer in x86".
I'm using grub, so that at least told me I need to modify my grub menu.
Google search for "where is the grub menu" turned up this page,
which points to /boot/grub/menu.lst or /boot/menu.lst. Neither of those actually exist on my system, but one of the commenters pointed out that their system uses /boot/grub/grub.cfg. That I found.

Back to the error message, it gives me a parameter (vmalloc) and a number (16781312), so I prepared to add this to my my first kernel line. Unfortunately, I couldn't find "kernel" anywhere in the file. I do find what look like my boot entries, and I see a call to initrd that the HowToForge page said was supposed to be there, so I'm guessing that the "linux" line is used in linux instead of the "kernel" line. I have added the parameters to the first one, and commented out the old ones, which I am guessing are the original 9.1 and updated 9.(whatever) kernels. I did leave the "recovery" option, of course.

The comments at the top state that I shouldn't modify the file because it is autogenerated. Is there somewhere else I should make this change so it doesn't get overwritten by some future autogeneration, or is that not something I have to worry about until I upgrade/update again?

Anyway, I rebooted and still received the error. The new log file is attached and the relevant section of the grub menu is listed below in case I screwed something up. I found the error in the old log file and saw that it is present seven times with the same number. It is now present just twice, and both of them have different numbers. The first has 10817536 and the second has 67112960. Does this mean I need the larger of these in the file, or am I missing a point somewhere (I guess it does at least mean that I was right about "linux" being the linux kernel line, hopefully)? FYI, now that it appears related to memory, I have 3 gig of ram installed, if the log file isn't already telling you that. So what vmalloc size should I be using, or is it not calculable and I just have to rely on trial and error?

Relevant grub menu section...
menuentry 'Ubuntu, with Linux 2.6.32-24-generic' --class ubuntu --class gnu-linux --class gnu --class os {
insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set 4107a0c9-bc2f-43c7-8be0-3877f9a42d2d
linux /boot/vmlinuz-2.6.32-24-generic root=UUID=4107a0c9-bc2f-43c7-8be0-3877f9a42d2d ro quiet splash vmalloc=16781312
initrd /boot/initrd.img-2.6.32-24-generic

AaronP 07-29-10 12:13 PM

Re: Drivers won't load: EVGA GS250, Ubuntu 10.04(32bit),Asus A8N-SLI, AMD64 X2 4800
There's a text version of the README that is more easily searchable: ftp://download.nvidia.com/XFree86/Li...DME/README.txt

Just setting the vmalloc size to the size of the failed allocation isn't really what you want. If at all possible, I would recommend using a 64-bit version of Ubuntu as it should have plenty of space. Alternatively, I'd suggest following the suggestion in the README:

Incrementally raising this to find the best balance between the size of the
kernel virtual address space made available and the size of the direct system
memory mapping is recommended. You can achieve this by passing 'vmalloc=192M',
'vmalloc=256MB', ..., to the kernel and checking if the above error message
continues to be printed.
Please see the Ubuntu documentation or contact the Ubuntu support forums for help on passing parameters to the kernel.

ProgrammerTim 08-03-10 10:14 PM

Re: Drivers won't load: EVGA GS250, Ubuntu 10.04(32bit),Asus A8N-SLI, AMD64 X2 4800
I was out of town for a week...

I tried 192M and it worked. Hulu still tears at full screen, but I don't have a way to know whether it is really the driver or maybe flash doesn't use hardware acceleration under linux. I'll have to find some other test app before I worry about that.

But I still don't understand what I am doing with the memory. Is my system now acting as if it only has 192mb of physical memory? Or is the kernel using 192mb and the video driver is sharing that? If the former, why should I not set the parameter to use all of the memory? And if the latter, is there no way to calculate how large it is actually supposed to be? Do all of the drivers share the kernel memory, or is this just something strange with the nvidia drivers?

All times are GMT -5. The time now is 03:38 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.