nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Incorrect gtk rendering & sluggish compiz animations with 256.44 (http://www.nvnews.net/vbulletin/showthread.php?t=153683)

Wise Ferret 08-02-10 03:15 PM

Incorrect gtk rendering & sluggish compiz animations with 256.44
 
I use geforce 9500m with 64-bit ubuntu 10.10.

The system is very sluggish and unresponsive comparing to prior experience with the 195 series. Compiz animations stutter and window contents are being drawn slowly. Moreover, there are elements the system fails to paint correctly with the nvdia driver (probably gradient-related):

1. Selected menu items and progress bars are brighter then they should be.

2. The lovely glowing dots below docky icons, which mark which app is being ran, become large, ugly grey blobs.

Screenshots are found in the ubuntu bug report (https://bugs.launchpad.net/ubuntu/+s...rg/+bug/612614), but I fear this is an nvidia issue since the incorrect rendering goes away with nouveau. Is there a solution to this problem? if not, is there a way to install the 195 driver again?

brucecadieux 08-02-10 03:20 PM

Re: Incorrect gtk rendering & sluggish compiz animations with 256.44
 
You have according to that page you posted three different nvidia drivers installed.

nvidia-current, 256.35, 2.6.35-13-generic, x86_64: installed
nvidia-current, 256.35, 2.6.32-24-generic, x86_64: installed
nvidia-173, 173.14.27, 2.6.35-13-generic, x86_64: installed

Wise Ferret 08-02-10 03:29 PM

Re: Incorrect gtk rendering & sluggish compiz animations with 256.44
 
Quote:

Originally Posted by brucecadieux (Post 2296645)
You have according to that page you posted three different nvidia drivers installed.

nvidia-current, 256.35, 2.6.35-13-generic, x86_64: installed
nvidia-current, 256.35, 2.6.32-24-generic, x86_64: installed
nvidia-173, 173.14.27, 2.6.35-13-generic, x86_64: installed

In the meanwhile I removed the extra kernels and the 173 driver (which was not activated) and upgraded to 256.44 (as noted in the bug comments). The problems are still there.

Wise Ferret 08-02-10 04:08 PM

Re: Incorrect gtk rendering & sluggish compiz animations with 256.44
 
Upon further investigation it seems that the cause for these issues are incompatibilites between the nvidia driver and the latest 1.9 series of libcairo2.

bearoso 08-03-10 03:49 AM

Re: Incorrect gtk rendering & sluggish compiz animations with 256.44
 
Quote:

Originally Posted by Wise Ferret (Post 2296667)
Upon further investigation it seems that the cause for these issues are incompatibilites between the nvidia driver and the latest 1.9 series of libcairo2.

Personally, I'd guess that it's the same Composite/X sync problem that's been there from the start. The 1.9 snapshots are slower than the 1.8 versions, so Compiz is now probably picking up the window contents before they're fully drawn.

Try enabling the "Workarounds" extension in Compiz, and make sure the "Force synchronization between X and GLX" option is checked. Or just try disabling Compiz.

Wise Ferret 08-03-10 05:30 AM

Re: Incorrect gtk rendering & sluggish compiz animations with 256.44
 
This is not a sync problem of any kind, as it is reproducible without compiz. This is a rendering problem.

The libcairo people insist that this is a very specific nvidia driver issue:
https://bugs.freedesktop.org/show_bug.cgi?id=29368

The murrine people has narrowed down the part of libcairo which triggers the nvidia problem:
https://bugs.launchpad.net/murrine/+bug/605979

This issue means that with the new cairo, which is going to be used by all linux distributions, the nvidia driver will render all themes, save the most ancient, sluggish and ugly. I would really like to know if the nvidia developers recognise this as a problem.


All times are GMT -5. The time now is 04:44 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.