nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Ubuntu 10.04 with 3100M - 75% boot failure, black screen (http://www.nvnews.net/vbulletin/showthread.php?t=153724)

captsens 08-03-10 04:10 PM

Ubuntu 10.04 with 3100M - 75% boot failure, black screen
 
1 Attachment(s)
I have a Dell E6510 laptop containing an NVIDIA 3100M card. I'm running 32 bit Ubuntu Lucid (10.04), currently using the 256.44 driver.

About 75% of the time the machine fails to boot - after 3-4 seconds, and without showing anything on the screen (text or graphical), it hangs with a black screen with a flashing text-mode cursor. Pressing Ctrl-Alt-F7 (or any other keys) has no effect.

However, roughly once in every 4 attempts ureadahead and plymouthd are killed by the OOM killer (this shows on a text-mode screen), and the machine boots correctly and functions without problem.

Any help or pointers would be very appreciated.

Thanks ........................ JD

captsens 08-05-10 04:38 AM

Re: Ubuntu 10.04 with 3100M - 75% boot failure, black screen
 
I'd really appreciate any tips - things I could try, information I can gather, a better place to ask this question, even ways of attracting the attention from someone who can help :)

Thanks in advance .................. John

NvFuchs 08-05-10 05:18 AM

Re: Ubuntu 10.04 with 3100M - 75% boot failure, black screen
 
Hello John,

first of all you seem to have installed the driver by compiling it manually. This is not recommended at all and might lead to problems. Please either use the packages provided by ubuntu or at least some ppa packages which hook up the driver correctly with dkms.

Then: The OOM-killer is invoked when the machine is out of memory. In this case the problem seems, at least to me, unrelated to the nvidia driver. The only problem related to the driver seems to me the display port, which it has problems with. Are you using display port?

But the information found in the bug report (dmesg / /var/log/messages) is valuable. I'd recommend you go over to launchpad and report this as a bug there.

In the meantime you could try to disable the ureadahead service. If the system never comes up, you can use a live system with chroot. I have some wiki articles regarding this, but unfortunately they are all in german.

Kind regards,

Fuchs

captsens 08-05-10 06:06 AM

Re: Ubuntu 10.04 with 3100M - 75% boot failure, black screen
 
Hi Fuchs

Thanks very much for your reply. But I have a few questions...

I installed the driver by downloading NVIDIA-Linux-x86-256.44.run from the NVIDIA site. I previously tried the version provided with Ubuntu 10.04, but this is much older and didn't work at all. Do you know of a suitable ppa package, or should I just search?

I don't understand the display port question. How would I find out if I'm using display port?

How do I disable ureadahead? I don't see it in /etc/init.d.

Anyway, thanks again for your help.

John

NvFuchs 08-05-10 12:41 PM

Re: Ubuntu 10.04 with 3100M - 75% boot failure, black screen
 
Quote:

Originally Posted by captsens (Post 2298148)
Hi Fuchs

Thanks very much for your reply. But I have a few questions...

I installed the driver by downloading NVIDIA-Linux-x86-256.44.run from the NVIDIA site. I previously tried the version provided with Ubuntu 10.04, but this is much older and didn't work at all. Do you know of a suitable ppa package, or should I just search?

Usually the VDPAU PPA has quite good and recent packages.

Quote:

I don't understand the display port question. How would I find out if I'm using display port?
In that case you probably aren't. It is a port you can use to connect a monitor to your graphic card. If you are using your laptop internal display, you are not using display port.

Quote:

How do I disable ureadahead? I don't see it in /etc/init.d.
Ubuntu switched to upstart, which is now managing services.
In case of ureadahead, (re)moving the config file should already help.

Try to rename /etc/init/ureadahead.conf to something different, e.g. sudo mv /etc/init/ureadahead.conf /etc/init/ureadahead.conf.disabled

Even though I am supporting ubuntu machines, I am not using it myself. So maybe a ubuntu forum would be more helpful.

Quote:

Anyway, thanks again for your help.

John
No problem.

Fuchs

danix 08-06-10 06:02 PM

Re: Ubuntu 10.04 with 3100M - 75% boot failure, black screen
 
Actually, some newer laptops have their internal panels wired up as DisplayPort instead of LVDS these days. This appears to be one of them:

(--) Aug 03 20:53:54 NVIDIA(0): Connected display device(s) on NVS 3100M at PCI:1:0:0:
(--) Aug 03 20:53:54 NVIDIA(0): LGD (DFP-3)
(--) Aug 03 20:53:54 NVIDIA(0): LGD (DFP-3): 480.0 MHz maximum pixel clock
(--) Aug 03 20:53:54 NVIDIA(0): LGD (DFP-3): Internal DisplayPort

The DisplayPort warning message that appears in the X log is probably not related to the problem here. I've heard reports of Ubuntu Lucid machines not being able to start gdm properly every time, but I haven't been able to reproduce this failure myself:

https://bugs.launchpad.net/bugs/532436

It seems like some kind of timing issue that Ubuntu's startup process can trigger sometimes, but not always.

captsens 08-08-10 02:42 AM

Re: Ubuntu 10.04 with 3100M - 75% boot failure, black screen
 
Thanks very much Danix - that launchpad bug sounds similar to mine, although not quite the same. I'll raise another one over there.

And thanks for the note about the internal display port - that increases my knowledge, which is always helpful when dealing with these issues.

Cheers .................... JD


All times are GMT -5. The time now is 06:39 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.