nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Severe system slow down with NVIDIA driver (openSUSE 11.2, Quadro FX 2700M) (http://www.nvnews.net/vbulletin/showthread.php?t=154377)

euromonkey 08-23-10 10:55 AM

Severe system slow down with NVIDIA driver (openSUSE 11.2, Quadro FX 2700M)
 
1 Attachment(s)
Hi all,

I have a Dell M6400 laptop with a Quadro FX 2700M running openSUSE 11.2 with KDE 4.4.4.

When my system starts up, everything works fine and performance is good. However, after a while I experience severe slowdown and can see in top that the Xorg and kwin processes are consuming ~20% CPU each.

If I reinstall the NVIDIA driver, the problem clears up for a while but soon returns without any system changes being made. I have seen this with driver versions 195,36.15, 256.44 and 256.35 (current). It seems to be worse if I configure twinview for my two LCD monitors rather than running with just the notebook display.

The output of nvidia-bug-report.sh is attached. What can I tweak/change/upgrade to cure this please?

Many thanks!

gisl 08-23-10 02:35 PM

Re: Severe system slow down with NVIDIA driver (openSUSE 11.2, Quadro FX 2700M)
 
Can you try removing the power supply for a few seconds, and plugging it in again?

euromonkey 08-23-10 06:06 PM

Re: Severe system slow down with NVIDIA driver (openSUSE 11.2, Quadro FX 2700M)
 
Ok, the symptoms occurred, I unplugged AC power and top immediately showed the CPU usage return to normal for Xorg/kwin. Within a couple of minutes (I was running a CPU intensive task), it happened again, I yanked the power and saw the same immediate improvement.

So, it seems you are on to something! I'm guessing this is something to-do with when the system has to adjust fan/clock rates in response to heat? Note that I am running with CPUFREQ=no on the boot line. nvidia-settings shows the GPU temperature as ~78 degrees with maximum performance being used in Powermizer with clock rates 530/799 MHz for the GPU/memory clock respectively.

I'm hoping there is a fix or tweak for this since flicking the power continuously is a nice workaround but a little inconvenient! :)

gisl 08-24-10 09:09 AM

Re: Severe system slow down with NVIDIA driver (openSUSE 11.2, Quadro FX 2700M)
 
Quote:

Originally Posted by euromonkey (Post 2306774)
I'm hoping there is a fix or tweak for this since flicking the power continuously is a nice workaround but a little inconvenient! :)

I reported this problem in http://www.nvnews.net/vbulletin/show...8&postcount=28 and the comment #29 in that thread suggests that a newer version of the driver contains some fixes regarding the driver's "Powermizer". I haven't tried the newer driver yet, though.


All times are GMT -5. The time now is 04:17 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.