nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   VDPAU hangs/freezes even with 256.52 (http://www.nvnews.net/vbulletin/showthread.php?t=154559)

terau 08-29-10 01:41 AM

VDPAU hangs/freezes even with 256.52
 
I was waiting for this new release to fix my VDPAU issues with my GTX460, but still no go with the new pre-release drivers. So I think it is time to post here.

Sometimes when I start playing a video with (-vo vdpau) mplayer, the system stops responding (even mouse can't be moved) for some seconds (~7secs).

A full proof way to trigger the bug is if I press "f" (toggle full screen) many times doing playback, or by rapidly resizing the video window, the temporary hang always happens then.

It also happens with VLC vaapi-vdpau, not only with mplayer.

Everything else (opengl, 3d compiz etc) works fine, with zero problems.I only get hangs when vdpau is used.

I tried VDPAU_TRACE but it doesn't show any errors.

I am using Gentoo stable amd64 with xorg 1.7.7.

Any ideas?

gradinaruvasile 08-29-10 03:54 AM

Re: VDPAU hangs/freezes even with 256.52
 
If you want vdpau hardware decoding you should start with
mplayer -vo vdpau -vc ffh264vdpau, ffmpeg12vdpau, ffwmv3vdpau, ffvc1vdpau, ffh264vdpau, ffodivxvdpau moviename

Edit: do yuo run a compositing manager such as mutter?

terau 08-29-10 06:17 AM

Re: VDPAU hangs/freezes even with 256.52
 
The problem exists with compositing manager or not.

As long as the output is vdpau with the hardware vdpau codecs the hangs appear, if I use software codecs the hangs disappear.

Licaon 08-29-10 07:09 AM

Re: VDPAU hangs/freezes even with 256.52
 
Quote:

Originally Posted by terau (Post 2309182)
I was waiting for this new release to fix my VDPAU issues with my GTX460, but still no go with the new pre-release drivers. So I think it is time to post here.

Sometimes when I start playing a video with (-vo vdpau) mplayer, the system stops responding (even mouse can't be moved) for some seconds (~7secs).

can you read http://www.nvnews.net/vbulletin/showthread.php?t=46678 and generate a good report with the debug info as instructed after the issue appears ?
also attach the mplayer output

Stephen Warren 08-30-10 11:39 AM

Re: VDPAU hangs/freezes even with 256.52
 
terau,

It sounds like you may have multiple ways to reproduce your issue?

Our next driver release series after r260 fixed a bug described as "Fixed a bug in VDPAU that could cause a 'display preemption' when toggling MPlayer to full-screen the first time." Does that sound like your issue? Do you use the "-fs" (full-screen) option to MPlayer?

If not, or if you do have multiple issues, then please provide an nvidia-bug-report, and details of the other issues you're having. Thanks.

jcornwall 08-30-10 07:15 PM

Re: VDPAU hangs/freezes even with 256.52
 
I also raised this issue in http://www.nvnews.net/vbulletin/showthread.php?t=154261 on a 470 with 256.44 drivers. Bug report in there.

terau 08-31-10 02:42 AM

Re: VDPAU hangs/freezes even with 256.52
 
Quote:

Originally Posted by Stephen Warren (Post 2309752)
terau,

It sounds like you may have multiple ways to reproduce your issue?

Our next driver release series after r260 fixed a bug described as "Fixed a bug in VDPAU that could cause a 'display preemption' when toggling MPlayer to full-screen the first time." Does that sound like your issue? Do you use the "-fs" (full-screen) option to MPlayer?

If not, or if you do have multiple issues, then please provide an nvidia-bug-report, and details of the other issues you're having. Thanks.

I doesn't happen only in full screen mode. The freeze seems to trigger when vdpau initializes or the window size is changed (be it full screen or not).

I will post a bug report later.

terau 09-04-10 12:58 PM

Re: VDPAU hangs/freezes even with 256.52
 
Ok I have some new info for this freeze/hang problem.

I increased the mplayer cache to ~32M and the problems disappeared.

I was playing the video from network, so the cache wasn't enough for the network latency.

However using XV, the video just dropped some frames because of the low cache / network latency.

When VDPAU is used, the whole system gets frozen instead of frame skipping like XV when low on cache. It seems to me that vdpau makes the whole system wait for the "next" stream in case it gets delayed for whatever reason.

It should just make mplayer fail not the whole system.

The massive resize/fullscreen seems to temporarily disable mplayer's "stream input", that's why the bug happened more often there.

Is there a known problem about this?

Stephen Warren 09-07-10 03:48 PM

Re: VDPAU hangs/freezes even with 256.52
 
We're aware of some bugs when toggling full-screen or resizing windows. Some have been fixed and will be included in the next driver release. We're still investigating some others.

Lysius 09-08-10 10:06 AM

Re: VDPAU hangs/freezes even with 256.52
 
I'm also seeing this freeze with my GTX460 and 256.53 or 260.19.04 in qvdpautest during the test "H264 DECODING (1920x1080)".

terau 09-08-10 05:31 PM

Re: VDPAU hangs/freezes even with 256.52
 
Well it seems my mplayer "cache" theory was wrong, freezes always happen on massive resize/fullscreen.

260.19.04 didn't help.

For the sake of it, I also tried vdpau with FreeBSD 8.1, in case the problem was linux specific, and there the system completely hangs (not temp freeze like linux) with sound loop.

Lysius 09-15-10 05:31 PM

Re: VDPAU hangs/freezes even with 256.52
 
Still seems to be present in 260.19.06


All times are GMT -5. The time now is 10:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.