nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   kernel: NV0: isr request failed 0xfffffff0 (http://www.nvnews.net/vbulletin/showthread.php?t=1552)

Shark 09-05-02 01:12 PM

kernel: NV0: isr request failed 0xfffffff0
 
I am about to become insane about this. This happens on my friend's computer, and he has an nVidia Geforce 2.. So I figured it would be pretty easy to make 3D-acceleration work in his Linux. I've done it several times before on other PC's (including my own computer), so it is usually pretty easy.
But this one is officially driving me nuts!

I have tried, checked and double checked if the XF86Config file (XF86Config-4 actually, since it's Mandrake) was properly configured and the module loaded. I have tried changing the card to a TNT2, switching to another screen, installing another Linux distro. But it still spits out the dreaded "(EE) NVIDIA(0): Failed to initialize the NVdriver kernel module!"

However, now I just fell over something new that the driver apparantly writes to the "/var/log/message" file upon failing to load. This weird message:
"kernel: NV0: isr request failed 0xfffffff0"

I have no particular idea what this could mean... But I figured it is an actual pointer as to what could be wrong.
I'd be happy if someone could explain that message to me. Even more happy if they could help me find a solution to it :)

Edit: PS: I always use the *.tar.gz drivers. That way I know it _should_ work on practically any Linux system I install it on.

Klaus-P 09-05-02 03:52 PM

Hello,

You wrote:

"...request failed 0xfffffff0"

It looks like 'no executable driver code is
loaded at this memory address'.

Do you also have checked the XFree86 log file?

Shark 09-06-02 01:40 AM

Yes, the Xfree86 log file is where I find the "(EE) NVIDIA(0): Failed to initialize the NVdriver kernel module!" message.

There is also a message saying "Screen(s) found, but none have a usable configuration", but I believe that always shows up if the nVidia driver fails. I could of course be wrong. If it's an essential message, I apologize for not including it in my first post :)

Klaus-P 09-06-02 03:17 AM

If that Geforce card is a "2 MX card" then make sure
that the monitor is correctly connected. Geforce MX
cards suppport twin view, e.g. two monitors at one card.

If any conflics could be caused by the motherboard
compare

http://www.insanehardware.com/articles.php?i=00003

Cf. the GeForce FAQs page here on this news forum.

Shark 09-06-02 08:52 AM

It is very likely that the motherboard somehow is the cause of the problem. Since it doesn't matter if I stuff a TNT2 or Geforce2 card in the PC.

Btw, your link to insanehardware.com just redirects me to something called ez-search.com :confused:

Klaus-P 09-06-02 09:20 AM

This link i've tested just a few moments ago:

http://www.g256.com/guides/geforcecomp.shtml

Klaus-P 09-06-02 10:06 AM

At

http://cdb.suse.de

Also language option Engl. available

you can also check out over 600 mainboards
working or not working under linux.

Shark 09-06-02 10:34 AM

Hmm.. And now to figure out exactly which motherboard it actually is :)
(My bad. I forgot to collect that information from him)
But I'll find out. Either by contacting him or taking a look on that board myself..

Klaus-P 09-06-02 11:49 AM

Did you run an installation attempt
of an extremly well-known commercial OS? just curious. ;-)

Shark 09-06-02 12:47 PM

That particular OS is already installed dual-boot on that machine, but it wasn't even necessary to resort to that :)
The motherboard is a Microstar MSI
MS-6156ZX.. But it wasn't on the list of Geforce/motherboard compatibility. And the MSI boards which were listed, were listed under "Motherboards successfully tested"

And btw, the acceleration seems to work very well on a certain something-98 OS :)

Why it wont work in Linux is still beyond me.
I still have the strong feeling that it's the motherboard which doesn't like the Linux nVidia driver.

Shark 09-06-02 02:57 PM

Acceleration works now!!!
I would like to strangle the guy who set "Assign IRQ to VGA" to "No" in the BIOS :mad:
(No, I don't believe my friend even know there's anything named "BIOS" in his computer :))

But oh well.. I works now. Sorry for the inconvenience.

- Palle

Klaus-P 09-10-02 11:36 AM

You wrote while ago:

" There is also a message saying "Screen(s) found, but none have a usable configuration", but I believe that always shows up if the nVidia driver fails."

Exactly this message i've got today while experimenting with nvidia kernel source. I forgot
to do a depmod -a , then it was working again.

BTW meanwhile i had success to force my Geforce into SBA mode by modifying the source a little bit.


All times are GMT -5. The time now is 07:07 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.