nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [Bug] X-server hangs when switch VDPAU video to fullscreen (http://www.nvnews.net/vbulletin/showthread.php?t=155751)

CobrA_SK 10-04-10 12:59 PM

[Bug] X-server hangs when switch VDPAU video to fullscreen
 
1 Attachment(s)
Hi,

sometimes when i switch VDPAU video to fullscreen (i'm using mplayer), X-server hangs and in X log, i found this

Code:

[  238.259] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[  238.259]
Backtrace:
[  238.259] 0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x48daf8]
[  238.260] 1: /usr/bin/Xorg (mieqEnqueue+0x1f4) [0x48b804]
[  238.260] 2: /usr/bin/Xorg (xf86PostMotionEventP+0xc4) [0x46f9f4]
[  238.260] 3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f4a95f83000+0x43f5) [0x7f4a95f873f5]
[  238.260] 4: /usr/bin/Xorg (0x400000+0x79b87) [0x479b87]
[  238.260] 5: /usr/bin/Xorg (0x400000+0xedeb3) [0x4edeb3]
[  238.260] 6: /lib64/libc.so.6 (0x7f4a9b62a000+0x32a60) [0x7f4a9b65ca60]
[  238.260] 7: /lib64/libc.so.6 (0x7f4a9b62a000+0xffff80b563fd6177) [0xffffffffff600177]
[  240.246] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a280, 0x0000a280)
[  243.247] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a2b4, 0x0000a2b4)
[  246.248] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a2e8, 0x0000a2e8)
[  249.249] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a31c, 0x0000a31c)
[  252.250] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a350, 0x0000a350)
[  255.251] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a384, 0x0000a384)
[  258.252] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a3b8, 0x0000a3b8)
[  261.253] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a3ec, 0x0000a3ec)
[  264.254] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a420, 0x0000a420)
[  267.255] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a454, 0x0000a454)
[  270.256] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a488, 0x0000a488)
[  273.257] (WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x0000a4bc, 0x0000a4bc)

I am using openSUSE 11.3, nvidia driver 260.19.06 and X.org server 1.8.

Any ideas?

Thanks

Stephen Warren 10-08-10 01:47 PM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
CobrA_SK, Thanks for the information. We've had some reports of issues when resizing windows (which includes going fullscreen) in this driver release. I've added your information to the bug report, and we'll continue to try to repro and fix the issue.

CobrA_SK 10-08-10 03:14 PM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
Well, sometimes when X server doesnt freeze, switching fullscreen causes serious visual corruption. But it helps when I suspend my notebook and turn it on (kind of "turn it off and on again" solution) - all loaded pixmaps (icons etc) remains corrupted but newly refreshed windows looks fine.

And in logs i got ton of these

Code:

Sep 30 19:46:13 b02-217b kernel: [82465.351540] NVRM: Xid (0001:00): 13, 0006 00000000 00005039 00000160 00000000 00000040
Sep 30 19:46:13 b02-217b kernel: [82465.711668] NVRM: Xid (0001:00): 13, 0003 00000000 00008297 000019d0 0000003c 00000100
Sep 30 19:46:14 b02-217b kernel: [82466.365235] NVRM: Xid (0001:00): 13, 0003 00000000 00008297 000019d0 0000003c 00000100
Sep 30 19:46:15 b02-217b kernel: [82467.569063] NVRM: Xid (0001:00): 13, 0001 00000000 00005097 000015e0 00000000 00000040
Sep 30 19:46:22 b02-217b kernel: [82474.712790] NVRM: Xid (0001:00): 13, 0001 00000000 00005097 000015e0 00000000 00000040
Sep 30 19:46:24 b02-217b kernel: [82476.617703] NVRM: Xid (0001:00): 13, 0001 00000000 00005097 000015e0 00000000 00000040
Sep 30 19:46:26 b02-217b kernel: [82478.620756] NVRM: Xid (0001:00): 13, 0001 00000000 00005097 0000194c 00000000 00000040
Sep 30 19:46:30 b02-217b kernel: [82482.619396] NVRM: Xid (0001:00): 13, 0001 00000000 00005097 000015e0 00000000 00000040

or

Code:

Oct  8 20:53:52 b02-217b kernel: [10721.437973] NVRM: Xid (0001:00): 13, 0005 00000000 00005039 00000160 00000000 00000040
Oct  8 20:53:54 b02-217b kernel: [10723.302764] NVRM: Xid (0001:00): 13, 0003 00000000 00008297 000015e0 00000000 00000040
Oct  8 20:53:54 b02-217b kernel: [10723.375056] NVRM: Xid (0001:00): 9, Channel 00000004 Instance 00000480 status 0000001d
Oct  8 20:53:54 b02-217b kernel: [10723.376675] NVRM: Xid (0001:00): 9, Channel 00000004 Instance 00000480 status 0000001d
Oct  8 20:53:54 b02-217b kernel: [10723.443970] NVRM: Xid (0001:00): 9, Channel 00000004 Instance 00000480 status 0000001d

Hope it helps, because this release is unusable for me :(

CobrA_SK 10-19-10 02:55 PM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
This bug is still present in 260.19.12 and it's really annoying (i have to reboot at least 3 times a day because of this)

artem 10-19-10 03:15 PM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
I suppose instead of rebooting, you could have tried going to runlevel 3, removing nvidia driver then starting X server again by
Code:

init 3; rmmod nvidia; init 5

CobrA_SK 10-19-10 04:30 PM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
well the problem is when the X server hangs, keyboard is not responding - so i cant switch to terminal nor can I restart X server. The only thing I can do is reboot (via hw button or SysRq)

zchronos 10-20-10 01:37 AM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
1 Attachment(s)
Hello!

In my case something goes wrong:

Sometimes when I use Mplayer or SMPlayer with VDPAU, the video in fullscreen change of color, repeat, sometimes...

I would like to specify that I have uncommented the line in my configuration mplayer (/etc/mplayer/mplayer.conf)

Code:

# Specify vdpau codecs when using -vo vdpau.
#[vo.vdpau]
vc=ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau,ffh264vdpau,ffodivxvdpau,

When open the video the log is:

Code:

mplayer \[Yousei-raws\]\ To\ Aru\ Kagaku\ no\ Railgun\ 02\ \[BDrip\ 1920x1080\ x264\ FLAC\].mkv > archivolog.log
----------
MPlayer dev-SVN-r31930-4.5-openSUSE Linux 11.3 (x86_64)-Packman (C) 2000-2010 MPlayer Team
Playing [Yousei-raws] To Aru Kagaku no Railgun 02 [BDrip 1920x1080 x264 FLAC].mkv.
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0, BDrip by Yousei
[lavf] stream 1: audio (flac), -aid 0, -alang jpn, LPCM -> flac
VIDEO:  [H264]  1920x1080  0bpp  24.000 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Forced video codec: ffmpeg12vdpau
Forced video codec: ffwmv3vdpau
Forced video codec: ffvc1vdpau
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 0.0 kbit/0.00% (ratio: 0->192000)
Selected audio codec: [ffflac] afm: ffmpeg (FFmpeg FLAC audio)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] Trying pixfmt=0.
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 H.264 VDPAU acceleration
[VD_FFMPEG] XVMC-accelerated MPEG-2.
A:  0.3 V:  0.0 A-V:  0.341 ct:  0.000  0/  0 ??% ??% ??,?% 2 0 
A:  0.6 V:  0.0 A-V:  0.516 ct:  0.017  0/  0 ??% ??% ??,?% 3 0 
A:  0.6 V:  0.1 A-V:  0.484 ct:  0.032  0/  0 ??% ??% ??,?% 4 0 
A:  0.5 V:  0.1 A-V:  0.361 ct:  0.038  0/  0 ??% ??% ??,?% 5 0 
A:  0.5 V:  0.2 A-V:  0.378 ct:  0.042  0/  0 ??% ??% ??,?% 6 0 
A:  0.6 V:  0.2 A-V:  0.342 ct:  0.047  0/  0 ??% ??% ??,?% 6 0 
A:  0.6 V:  0.2 A-V:  0.346 ct:  0.051  0/  0 ??% ??% ??,?% 7 0 
A:  0.6 V:  0.3 A-V:  0.306 ct:  0.054  0/  0 ??% ??% ??,?% 8 0 
A:  0.6 V:  0.3 A-V:  0.277 ct:  0.057  0/  0 ??% ??% ??,?% 9 0 
A:  0.7 V:  0.4 A-V:  0.296 ct:  0.060  0/  0 ??% ??% ??,?% 10 0 
A:  0.7 V:  0.4 A-V:  0.257 ct:  0.063  0/  0 ??% ??% ??,?% 11 0 
A:  0.7 V:  0.5 A-V:  0.227 ct:  0.065  0/  0 ??% ??% ??,?% 11 0 
A:  0.7 V:  0.5 A-V:  0.246 ct:  0.067  0/  0 ??% ??% ??,?% 12 0 
A:  0.7 V:  0.5 A-V:  0.204 ct:  0.069  0/  0 122% 54%  3.5% 13 0 
A:  0.8 V:  0.6 A-V:  0.176 ct:  0.071  0/  0 113% 52%  3.2% 14 0 
A:  0.8 V:  0.6 A-V:  0.192 ct:  0.072  0/  0 107% 56%  3.0% 14 0 
A:  0.8 V:  0.7 A-V:  0.152 ct:  0.073  0/  0 101% 53%  2.9% 15 0 
A:  0.8 V:  0.7 A-V:  0.125 ct:  0.075  0/  0 95% 52%  2.7% 15 0 
A:  0.8 V:  0.8 A-V:  0.097 ct:  0.076  0/  0 91% 49%  2.5% 16 0 
A:  0.9 V:  0.8 A-V:  0.115 ct:  0.077  0/  0 89% 51%  2.4% 16 0 
A:  0.9 V:  0.8 A-V:  0.074 ct:  0.078  0/  0 84% 49%  2.3% 17 0 
A:  0.9 V:  0.9 A-V:  0.045 ct:  0.078  0/  0 80% 48%  2.2% 17 0 
A:  1.0 V:  0.9 A-V:  0.063 ct:  0.079  0/  0 78% 51%  2.1% 17 0 
A:  1.0 V:  1.0 A-V:  0.022 ct:  0.080  0/  0 75% 49%  2.0% 17 0 
A:  1.0 V:  1.0 A-V:  0.039 ct:  0.084  0/  0 72% 52%  1.9% 17 0 
A:  1.0 V:  1.0 A-V:  0.002 ct:  0.084  0/  0 69% 50%  1.9% 17 0 
A:  1.1 V:  1.1 A-V:  0.002 ct:  0.084  0/  0 66% 48%  1.8% 17 0 
A:  1.1 V:  1.1 A-V:  0.002 ct:  0.084  0/  0 64% 46%  1.7% 17 0 
A:  1.2 V:  1.2 A-V:  0.001 ct:  0.084  0/  0 61% 45%  1.7% 17 0 
A:  1.2 V:  1.2 A-V:  0.001 ct:  0.084  0/  0 59% 43%  1.6% 17 0 
A:  1.3 V:  1.3 A-V:  0.001 ct:  0.084  0/  0 57% 42%  1.6% 17 0 

Exiting... (Quit)

NOTE: In VLC (with VDPAU), this does not happen, the video works fine even in fullscreen, the bug only appears with mplayer or SMPlayer.


Another thing that is strange in:

Nvidia Control Panel > X Screen 0 > X Server Color Correction

The "Brightess", "Contrast" and "Gamma" always returns to default configuration, does not display the values previously stored.

CobrA_SK 11-12-10 07:45 AM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
And with 260.19.21 X server is still (sometimes) freezing when switching to fullscreen. I have tested with 256.53 - no freeze in few weeks - so its definitely a driver issue.

<rant>c'mon guys - entire 260 series is big mess and nothing really works. Please fix it or admit you cant make a working driver (not to mention good driver), release specs and let someone who actually have the skills to do the job</rant>

ioni 11-12-10 11:07 AM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
Quote:

Originally Posted by CobrA_SK (Post 2346269)
<rant>c'mon guys - entire 260 series is big mess and nothing really works. Please fix it or admit you cant make a working driver (not to mention good driver), release specs and let someone who actually have the skills to do the job</rant>

dude, are you serious? does any other (intel or amd) which has opened partially specs, have hardware decoding that can be compared with nvidia?

NO, then stfu

zivagolee 11-20-10 10:56 AM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
Has anyone found a solution for this issue? I'm also experiencing this every so often with the 260.19.21 driver as well.

I've also used VLC (vdpau via vaapi) without issues. Mplayer is the one causing issues.

zivagolee 11-29-10 10:22 AM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
Interestingly, I grabbed the mplayer-vaapi source package and force compiled it for Ubuntu 10.10 (it seems the newer libva has a different way of validating itself as a proper library then previously) and it is working perfectly through VA-API (as does VLC). No hangups etc.

zivagolee 12-01-10 10:12 PM

Re: [Bug] X-server hangs when switch VDPAU video to fullscreen
 
Just tried out beta 260.19.26. Same issue so this latest version must be for something else..


All times are GMT -5. The time now is 10:30 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.