nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   260.19.06 doesn't work on NVIDIA 320M (http://www.nvnews.net/vbulletin/showthread.php?t=155915)

nuovodna 10-09-10 01:11 PM

260.19.06 doesn't work on NVIDIA 320M
 
1 Attachment(s)
My Nvidia card (320m on sony VPCCW2S8E) doesn't work with 260.19.06 drivers. When i start the X server the system freeze on a black screen and i have to hard reset the machine.

System Tested:

Ubuntu 10.10 + 260.19.06

Fedora 14 + 260.19.06

Any solution?

xorg.conf

nuovodna 10-10-10 04:46 AM

Re: 260.19.06 doesn't work on NVIDIA 320M
 
1 Attachment(s)
I attach the bug report

mdriftmeyer 10-10-10 05:27 AM

Re: 260.19.06 doesn't work on NVIDIA 320M
 
Perhaps my xorg.conf helps you with a LCD flat panel on Debian Sid will help.


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
# path to defoma fonts
FontPath "/usr/local/share/fonts"
FontPath "/usr/share/fonts/type1"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/100dpi:unscaled"
FontPath "/usr/share/fonts/X11/75dpi:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "i2c"
# Load "bitmap"
# Load "ddc"
# Load "extmod"
# Load "freetype"
# Load "glx"
# Load "int10"
# Load "dbe"
# Load "dri"
# Load "type1"
EndSection
# Dedicated "Extensions" section (may not be present already)
Section "Extensions"
Option "Composite" "enable"
EndSection

Section "InputDevice"
Identifier "Apple, Inc. Keyboard"
Driver "evdev"
Option "CoreKeyboard"
Option "SendCoreEvents" "true"
Option "Name" "Apple, Inc Apple Keyboard" # (cat /proc/bus/input/devices)
# Option "Device" "/dev/input/by-id/usb-Apple__Inc_Apple_Keyboard-event-kbd" # (cat /proc/bus/input/devices)
# Option "Device" "/dev/input/event2"
Option "Phys" "usb-0000:00:1d.7-3.2/input0"
Option "XkbRules" "xorg"
Option "XkbModel" "macintosh"
Option "XkbGeometry" "applepro"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "evdev"
Option "CorePointer"
Option "SendCoreEvents" "true"
Option "Name" "Logitech USB-PS/2 Optical Mouse" # (cat /proc/bus/input/devices)
# Option "Device" "/dev/input/by-id/usb-Logitech_USB-PS.2_Optical_Mouse-event-mouse"
# Option "Device" "/dev/input/event1"
Option "Phys" "usb-0000:00:1d.7-3.1/input0"
Option "Buttons" "3"
Option "Resolution" "1000"
Option "Emulate3Buttons" "false"
# Option "GrabDevice" "false"
EndSection

Section "Device"
Identifier "Nvidia 8600 GTS"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "gEfORCE 8600 GTS"
#BusID "PCI:0:2:0"
BusID "PCI:4:0:0"
VideoRam 262144
# Option "AperTexSize" "131,072"
# Option "XVideo" "true"
# Option "XAA" "true"
# Option "BackingStore" "true"
Option "AllowSHMPixmaps" "false"
# Option "AddARGBGLXVisuals" "True"
Option "FlatPanelProperties" "Scaling = DFP"
Option "ExactModTimingsDVI"
EndSection

Section "Monitor"
Identifier "LP2475w"
ModelName "Hewlett Packard HP LP2475w"
HorizSync 30.0 - 94.0
VertRefresh 48.0 - 85.0
Gamma 1.00 1.00 1.00 # created by KGamma
Option "DPMS"
# calc: (x|y)pixels * 25.4 / dpi
# DisplaySize 168 126 # 96 DPI @ 640x480
# DisplaySize 210 157 # 96 DPI @ 800x600
# DisplaySize 269 201 # 96 DPI @ 1024x768
# DisplaySize 302 227 # 96 DPI @ 1152x864
# DisplaySize 336 252 # 96 DPI @ 1280x960
# DisplaySize 336 210 # 96 DPI @ 1280x800 (non 4:3 aspect)
# DisplaySize 339 271 # 96 DPI @ 1280x1024 (non 4:3 aspect)
# DisplaySize 370 277 # 96 DPI @ 1400x1050
# DisplaySize 380 238 # 96 DPI @ 1440x900 (non 4:3 aspect)
# DisplaySize 420 315 # 96 DPI @ 1600x1200
# DisplaySize 444 277 # 96 DPI @ 1680x1050 (non 4:3 aspect)
#DisplaySize 506 315 # 120 DPI @ 1920x1200 (non 4:3 aspect)
Option "UseEdidDpi" "DFP-1"
Option "DPI" "109 x 109"
EndSection

#Section "Monitor Two"
# Identifier "SC190"
# ModelName "Sylvania SC190"
# HorizSync 30.0 - 96.0
# VertRefresh 50.0 - 160.0
# Option "DPMS"
#EndSection

Section "Screen"
Identifier "Default Screen"
Device "Nvidia 8600 GTS"
Monitor "LP2475w"
DefaultDepth 24
Option "CustomEDID" "DFP-1:/etc/X11/hp2475w-edid.bin"
Option "UseEDID" "True"
Option "TwinView" "0"
Option "metamodes" "1920x1200 +0+0; 1280x1024 +0+0; 1280x960 +0+0; 1152x864 +0+0; 1024x768 +0+0; 832x624 +0+0; 800x600 +0+0; 720x400 +0+0; 640x480 +0+0"
SubSection "Display"
Depth 24
EndSubSection
# Option "TwinView" "0"
# Option "TwinViewXineramaInfoOrder" "CRT-0"
# Option "metamodes" "1600x1200_75 +0+0; 1600x1200 +0+0; 1280x1024 +0+0; 1280x960 +0+0; 1152x864 +0+0; 1024x768 +0+0; 832x624 +0+0; 800x600 +0+0; 720x400 +0+0; 640x480 +0+0"
# SubSection "Display"
# Depth 1
# Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
# EndSubSection
# SubSection "Display"
# Depth 4
# Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
# EndSubSection
# SubSection "Display"
# Depth 8
# Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
# EndSubSection
# SubSection "Display"
# Depth 15
# Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
# EndSubSection
# SubSection "Display"
# Depth 16
# Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
# EndSubSection
# SubSection "Display"
# Depth 24
# Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
# EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Apple, Inc. Keyboard" "CoreKeyboard"
# InputDevice "Apple, Inc. Keyboard" "SendCoreEvents"
InputDevice "Configured Mouse" "CorePointer"
# InputDevice "Configured Mouse" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection


From your gz file:

Quote:

[ 1263.331] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[ 1263.331] (II) NVIDIA(0): enabled.
[ 1263.333] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
[ 1263.333] (EE) NVIDIA(0): system's kernel log for additional error messages and
[ 1263.333] (EE) NVIDIA(0): consult the NVIDIA README for details.
under /lib/modules/2.6.35-22-generic/nvidia

you should see:

nvidia.ko

Check the size and time stamp of installation [assuming it's there].

nuovodna 10-10-10 06:12 AM

Re: 260.19.06 doesn't work on NVIDIA 320M
 
1 Attachment(s)
Using edid file doesnt sort any effects :(

kwizart 10-11-10 09:46 AM

Re: 260.19.06 doesn't work on NVIDIA 320M
 
In the Fedora case:
If you have tried with F14 2.6.35.6-38 kernels or olders, that's unlikely that anyone succeeded in using the proprietary nvidia driver with that kernel.
That was because that kernel was still built with debug enabled, so the nvidia kernel module failed to build with the error:
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'debug_lockdep_rcu_enabled'

This problem was solved when using kernel-2.6.35.6-39.fc14 and later, because they are not compiled with debug information.

If you follow carefully the instruction provided there, this should work without problem:
http://rpmfusion.org/Howto/nVidia

THX

eXpert 10-11-10 11:35 AM

Re: 260.19.06 doesn't work on NVIDIA 320M
 
have you tried waiting for say 10 min
because my system starts after ages and uses 100% of one core
strange bug

auxbuss 10-11-10 02:32 PM

Re: 260.19.06 doesn't work on NVIDIA 320M
 
In the Ubuntu 10.10 case: there have been a lot of issues. Easiest, for now, is to use the 256.53 from directly from nvidia.


All times are GMT -5. The time now is 12:50 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.