nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles (http://www.nvnews.net/vbulletin/showthread.php?t=155966)

ioni 10-11-10 09:13 AM

mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
2 Attachment(s)
Hi,
i noticed this behavior after i switch to nvidia beta.

when i watch movies with subtitles when the subs are draw the ram is slowly growing and with time it can use even 1GB of ram. also noticed that when drawing the video is lagging a bit.

i'm attaching the mplayer log after exporting VDPAU_TRACE=1 and VDPAU_NVIDIA_DEBUG=3

this is a seriously bug and i hope it would get fixed before marking a new stable version

Stephen Warren 10-11-10 10:19 AM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
ioni,

Thanks for the bug report. Can you please upload a media sample that demonstrates this problem to the NVIDIA file drop (see VDPAU sticky post in this forum). Thanks.

Stephen Warren 10-11-10 10:24 AM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
ioni,

If you could also tell us exactly which MPlayer version you're using, and which driver version you previously used without this problem, that would be useful. Thanks.

ioni 10-11-10 10:47 AM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
ioni-sample-mkv.tar.gz is up. note that this is happening with all codecs and is not specific to h264 and mkv container.

i'm using the latest mplayer revision 32479 at the time when i built it(yesterday) just to be sure is not a mplayer bug.

latest working nvidia is the stable one, 256.53.

Steps to reproduce the bug.
1) start the movie without subs let it play couples of second and watch the memory usage
2) enable subtitles and watch how the memory usage is growing

Stephen Warren 10-11-10 11:06 AM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
ioni,

Does the RAM usage keep growing forever? I suspect that RAM usage quickly grows to a very large value, but is then fairly stable.

I think your problem is simply the same as in http://www.nvnews.net/vbulletin/showthread.php?t=155849. The symptom is simply that VDPAU will now use an extremely large amount of system memory. However, I don't think there's a leak per se; none of the memory is ever lost, it's just that some structure is now far larger than it should be, and hence consumes more memory before. This is probably more noticeable when playing streams with subtitles, since more VDPAU objects are allocated, which triggers this condition.

ioni 10-11-10 11:10 AM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
is growing until is starting to swap and my machine became very unstable.

the difference between vdpau with or without subtitles is enormous. i pretty sure that something is screwed in the drivers.

dk75 10-11-10 12:54 PM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
It must be either your software or driver is faulty at some specified hardware.
I have no memory rush.

MPlayer with VDPAU and with OSD subtitles engine used 89M all the time (I've tested 30min. clip)
MPlayer with VDPAU and ASS subtitles engine started at 98M without sub, used 865M at start ASS engine and it stoped at 871M - it didn't repeated again.
Second run started ASS engine at 483M and ended at 634M after 5min to the near end. Then there was something strange - new chapter or something and it went to 763M. Still... it left 1.5G memory free for me so no problem. ;P
Thrid run started at 485M and growed to 634M in 5min. Then suddenly 763M near the end (28min of the clip).
It seems repeatable.
MPlayer with XV started at 48M with no sub and ended at 56M with ASS engine and 6 fonts loaded.

ION/9400M hardware with 260.19.06 driver
Code:

mplayer -nosub -noautosub -ass -vo vdpau movie_file.mkv
and I've turned subtitles ON by typing "J" 2 min after clip started.

ioni 10-12-10 10:42 AM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
Quote:

Originally Posted by dk75 (Post 2330473)
ION/9400M hardware with 260.19.06 driver
Code:

mplayer -nosub -noautosub -ass -vo vdpau movie_file.mkv
and I've turned subtitles ON by typing "J" 2 min after clip started.


if you use those mplayer options, then you are NOT using vdpau. you need to pass -vc too

mplayer -vc help | grep vdpau

Stephen Warren 10-12-10 11:21 AM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
We believe we've identified and fixed this bug. The fix will be included in a future driver release.

ioni 10-12-10 02:36 PM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
Quote:

Originally Posted by Stephen Warren (Post 2330946)
We believe we've identified and fixed this bug. The fix will be included in a future driver release.


thanks a lot. looking forward to test the new release when is out

dk75 10-12-10 02:47 PM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
Quote:

Originally Posted by ioni (Post 2330928)
if you use those mplayer options, then you are NOT using vdpau. you need to pass -vc too

mplayer -vc help | grep vdpau

don't need to... have config file :cool:
Code:

# Write your default config options here!

[gnome-mplayer]
profile-desc="profile for Gnome-MPlayer GUI"
vo=vdpau
ao=alsa
msglevel=all=5

[vo.vdpau]
profile-desc="profile for VDPAU video output"
vc=ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau,ffh264vdpau,
#vc=ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau,ffh264vdpau,ffodivxvdpau,
ao=pulse
vf-clr=1

[protocol.dvdnav]
profile-desc="profile for DVDNAV DVD menu navigation system"
#vc=ffmpeg12,
mouse-movements=yes
nocache=yes

[extension.flv]
profile-desc="profile for FLV flash files"
vo=xv

[default]
vo=xv
ontop=yes
#ao=alsa:device=hdmi
ao=alsa:noblock
#ao=pulse
rtsp-port=47956
#spuaa=0
#spualign=-1
sub-fuzziness=1
cdrom-device=/dev/cdrom1
dvd-device=/dev/dvd1


ioni 10-13-10 06:55 PM

Re: mplayer vdpau with nvdia 260.19.06 using 1 gb of ram when drawing subtitles
 
@Stephen my issue is supposed to be fixed in 260.19.12? i'm asking because i'm still affected


All times are GMT -5. The time now is 12:58 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.