nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA GeForce 200 Series (http://www.nvnews.net/vbulletin/forumdisplay.php?f=60)
-   -   GT220 hdmi audio help needed (http://www.nvnews.net/vbulletin/showthread.php?t=155977)

yamaha200 10-11-10 04:27 PM

GT220 hdmi audio help needed
 
I have been attempting to follow the XBMC wiki (http://wiki.xbmc.org/?title=HOW-TO_s...20%2C_or_GT240) to get audio out over hdmi working without success. Any suggestions appreciated.

-I have a galaxy GT220, I'm running ubuntu (mythbuntu) on a Dell Vostro 200, kernel version 2.6.27-14

-nvidia-settings reports my driver version as 256.53. Video over hdmi is working fine (i'm currently setup with cloned displays out the hdmi and dvi ports)

-I used the alsa upgrade script to update to 1.0.23, alsamixer reports I am indeed running 1.0.23. It is my understanding that this version of the alsa drivers should not require any additional patches and the stock release should support this card, correct?

-the linux-backports-module is not installed (and never was that I can tell)

-I have disabled my onboard sound card in the bios

-my user is in the audio group

-I am using the suggested settings in /etc/asound.conf and have no other .asoundrc files anywhere on the system

Now for the interesting part...

I have tried all possible combinations of using enable_msi=0 (or omitting it) along with all possible combinations of probe_mask=0xffff,0xfff2 (or only one or the other or neither). Also tried no options at all. In all cases, aplay -l reports either that no sound cards were found, or all 4 of the nvidia hdmi:

**** List of PLAYBACK Hardware Devices ****
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

From what I have seen, it seems that it is necessary to get it down to a single device using the probe_mask before things will work correctly? Ideas what I am doing wrong that I can only get 0 or 4?

Using aplay -D plughw:1,3 /usr/share/sounds/alsa/Noise.wav, I get no messages, it appears to play and run for a couple seconds before returning to the prompt, but no noise. I have tried all combinations of 1,3 (or 7,8,9) and plughw vs hw. No sound on any of them. I do get errors on using hw rather than plughw.

In alsamixer, I can see the card, and it shows that it has 4 S/PDIF outputs. All of them are unmuted. There does not appear to be any sort of volume indicator for any of them, which seems odd to me. I thought there should be some iec958s in addition to/instead of S/PDIF but maybe I'm confused there?

Any suggestions or help would be greatly appreciated!

Thanks,
laura

Drolfrawd 10-11-10 04:33 PM

Re: GT220 hdmi audio help needed
 
Hi Laura

too much for me , but welcome to the forum :D
Follow the link in my sig to have bearfail change hid avatar. do this and i luv you long time

sharangad 10-13-10 11:30 AM

Re: GT220 hdmi audio help needed
 
Even in Windows GT240/220 and 400 series cards have 4 HDMI audio devices visible in device manager. I suspect that this is because both DVI/HDMI ports can simultaneously output sound as independent devices. However they would only need 2 devices for this.

[Albator] 10-23-10 12:29 PM

Re: GT220 hdmi audio help needed
 
Hello, I still have troubles with my Twintech G210.
My HDMI output is connected to my SONY TV but I cannot get any sound from this nvidia card !

When running my old Geforce 8500GT HDMI + SPDIF output from Soundblaster Audigy, I get perfect sound with a passthrough cable, but I not to want to have 2 separate cards in the computer just for TV playback, so I bought a GF210.

lspci says:
Code:

04:00.0 VGA compatible controller [0300]: nVidia Corporation GT200 [GeForce 210] [10de:0a65] (rev a2)
04:00.1 Audio device [0403]: nVidia Corporation High Definition Audio Controller [10de:0be3] (rev a1)

I'm running Linux Mandriva 2010 Spring with updated kernel (2.6.36) and latest nvidia driver:
Code:

$ uname -a
Linux arcadia.vtf 2.6.36-desktop-1mnb #1 SMP Thu Oct 21 01:58:22 CEST 2010 x86_64 x86_64 x86_64 GNU/Linux
$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.23.
$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  260.19.12  Fri Oct  8 11:17:08 PDT 2010
GCC version:  gcc version 4.4.3 (GCC)

I've modprobed my snd-hda-intel with option "probe_mask=0x102" since I found that eld#1.0 is the right one for me.
I see the PCM device in alsamixer and I unmuted it.

dmesg extract:
Code:

HDA Intel 0000:04:00.1: PCI INT A -> GSI 16 (level, low) -> IRQ 16
hda_intel: Disable MSI for Nvidia chipset
hda_intel: codec_mask forced to 0x2
HDA Intel 0000:04:00.1: setting latency timer to 64
HDMI: detected monitor SONY TV
    at connection type HDMI
HDMI: available speakers: FL/FR
HDMI: supports coding type LPCM: channels = 2, rates = 44100 48000 88200, bits = 16 20

Code:

$ cat /proc/asound/card0/eld#1.0
monitor_present        1
eld_valid              1
monitor_name            SONY TV
   
connection_type        HDMI
eld_version            [0x2] CEA-861D or below
edid_version            [0x3] CEA-861-B, C or D
manufacture_id          0xd94d
product_id              0xfe00
port_id                0x20000
support_hdcp            0
support_ai              0
audio_sync_delay        0
speakers                [0x1] FL/FR
sad_count              1
sad0_coding_type        [0x1] LPCM
sad0_channels          2
sad0_rates              [0xe0] 44100 48000 88200
sad0_bits              [0xe0000] 16 20 24

Everything looks fine, BUT it still does not work.
Code:

$ aplay -L
[...]
hdmi:CARD=NVidia
    HDA NVidia, NVIDIA HDMI
    HDMI Audio Output

Code:

$ aplay -D"hdmi:CARD=NVidia" ~/saez-mapetitecouturiere.mp3.wav
Playing WAVE '/home/albator/saez-mapetitecouturiere.mp3.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
aplay: pcm_write:1603: write error: Erreur d'entrée/sortie

(the last message says, in english: "input/output error")

And then dmesg says:
Code:

playback write error (DMA or IRQ trouble?)
I've tried to add options to snd-hda-intel:
probe_msi=0 : does not change anything. AFAIK, it's not needed anymore on latest kernel (see dmesg output above).
position_fix : no success with setting 0 , 1 or 2...

What can I try next ? Am I condemned to keep my old 8500GT ?


All times are GMT -5. The time now is 12:15 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.