nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   HDMI and ALSA with GTS 450 (http://www.nvnews.net/vbulletin/showthread.php?t=156279)

asw3 10-20-10 12:02 PM

HDMI and ALSA with GTS 450
 
Hi,

i have been unsuccessful in getting HDMI audio working with fedora 13 x64.


i followed the instructions from post http://www.nvnews.net/vbulletin/show...20&postcount=7 with little success. .. :

* the system automatically detects and adds kernel module snd_hda_codec_nvhdmi.
* i now have 4 IEC958 alsa controls ( which i un-muted).
* i was able to probe_mask only the active eld ( now i only have 1 IEC958 alsa control).


the result is, "System becomes slow with attempting to play sounds. Sound still does not work! " .




i.e. when i attempt to play a sound via mplayer or xbmc the system become extremal slow.

at one point mplayer output the following interesting message:
Code:

          ************************************************
          **** Your system is too SLOW to play this!  ****
          ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver





- i'm a little confused what i can try next? ..
- once i apply the patches is card just meant to work.. or is there more core needed to support my device?
- is this problem better suited for the alsa-users mailing list?

Note:
* patch_nvhdmi.c looks like it only part of the kernel repository.. i assume submitted by nvidia? (module snd_hda_codec_nvhdm.ko)
* in the alsa-drivers package i did find the same code was recently merged under patch_hdmi.c ( i just worked out that's why it was loading load snd_hda_codec_hdm.ko module instead of snd_hda_codec_nvhdmi.ko)

Note:
i have exact same problem with and without pulseaudio.




i have tried kernels:
* vanilla 2.6.36 rc8 kernel
* fedora kernel-2.6.35.6-43 (built from rawhide srpm)
* fedora kernel-2.6.34.7-56 ( re-buillt to include the required changes to patch_nvhdmi.c )
* also attempted to build kernel modules from alsa-drivers daily snapshots on the above (based on atrpms alsa-drivers)

i have also tried nvidia driver versions:
* 256.53-2 (provided by rpmfusion)
* 260.19.12 (provided by rpmfusion.. actually caused mplayer an xbmc segmentation fault ( think it could be VDPAU) .. but that's a diffrent issue )




any help would be appreciated.

Thanks,
Peter.


==== various outputs ====
Code:

[root@matrix log]# aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, NVIDIA HDMI
    HDMI Audio Output
[root@matrix log]#

[root@matrix log]# amixer
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
[root@matrix log]#



extract from lsmod
Code:

[root@matrix log]# lsmod | egrep -i 'snd|hda'
snd_hda_codec_nvhdmi    13645  1
snd_hda_intel          23960  2
snd_hda_codec          85624  2 snd_hda_codec_nvhdmi,snd_hda_intel
snd_hwdep              6454  1 snd_hda_codec
snd_seq                53005  0
snd_seq_device          6159  1 snd_seq
snd_pcm                80324  3 snd_hda_intel,snd_hda_codec
snd_timer              19882  2 snd_seq,snd_pcm
snd                    62913  11 snd_hda_codec_nvhdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
soundcore              6390  1 snd
snd_page_alloc          7437  2 snd_hda_intel,snd_pcm
[root@matrix log]#


<<or with latest alsa-drivers installed module becomes snd_hda_codec_hdmi as code is intergated into patch_hdmi.c>>

[baartzp@matrix ~]$ lsmod | egrep -i 'snd|hda'
snd_hda_codec_hdmi    21770  1
snd_hda_intel          23144  2
snd_hda_codec          80305  2 snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep              6390  1 snd_hda_codec
snd_seq                50203  0
snd_seq_device          6111  1 snd_seq
snd_pcm                75005  3 snd_hda_intel,snd_hda_codec
snd_timer              19210  2 snd_seq,snd_pcm
snd                    61528  11 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
soundcore              6390  1 snd
snd_page_alloc          7549  2 snd_hda_intel,snd_pcm
[baartzp@matrix ~]$


eld info:
Code:

[root@matrix log]# ls  /proc/asound/card*/eld*
/proc/asound/card0/eld#1.0
[root@matrix log]# cat  /proc/asound/card*/eld*
monitor_present        1
eld_valid              1
monitor_name            SAMSUNG

connection_type        HDMI
eld_version            [0x2] CEA-861D or below
edid_version            [0x3] CEA-861-B, C or D
manufacture_id          0x2d4c
product_id              0x509
port_id                0x20000
support_hdcp            0
support_ai              0
audio_sync_delay        0
speakers                [0x1] FL/FR
sad_count              1
sad0_coding_type        [0x1] LPCM
sad0_channels          2
sad0_rates              [0xe0] 44100 48000 88200
sad0_bits              [0xe0000] 16 20 24
[root@matrix log]# cat /etc/modprobe.d/snd_hda_intel.conf
options snd-hda-intel  probe_mask=0x102

[root@matrix log]#

extract from lspci -vv
Code:

01:00.1 Audio device: nVidia Corporation Device 0be9 (rev a1)
        Subsystem: Giga-byte Technology Device 34fe
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin B routed to IRQ 17
        Region 0: Memory at f7000000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [60] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
                Address: 0000000000000000  Data: 0000
        Capabilities: [78] Express (v2) Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 <64us
                        ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <256ns, L1 <4us
                        ClockPM+ Surprise- LLActRep- BwNot-
                LnkCtl: ASPM L0s Enabled; RCB 128 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Not Supported, TimeoutDis+
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
                LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
                        Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                        Compliance De-emphasis: -6dB
                LnkSta2: Current De-emphasis Level: -6dB
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel


NinjaNumberNine 10-22-10 12:28 PM

Re: HDMI and ALSA with GTS 450
 
mainly for the purpose of bumping your thread (I've heard of this issue in several threads here and otherwise, but I don't think I could be of any help myself as I'm no hardware geek) is this your problem?
http://www.pubbs.net/200905/mplayer/...play-this.html

-NNN

asw3 10-23-10 03:04 AM

Re: HDMI and ALSA with GTS 450
 
Quote:

Originally Posted by NinjaNumberNine (Post 2335596)
mainly for the purpose of bumping your thread (I've heard of this issue in several threads here and otherwise, but I don't think I could be of any help myself as I'm no hardware geek) is this your problem?
http://www.pubbs.net/200905/mplayer/...play-this.html

-NNN

The mplayer developers have put the message in the code because buggy/broken audio was one of the common re-occurring cause of playback problems.


i only see performance problem when attempting to play audio via the HDA nvidia HDMI audio device.

e.g.

there is no performance problems if :
- if i disable sound when i play a movie:
"mplayer -ao null movie.mkv"

- if i play sound via one of the motherboards HDA intel audio devices


anyway i created issue# 0005171 in the alsa bug tracker:
https://bugtrack.alsa-project.org/al...ew.php?id=5171

Stephen Warren 10-25-10 01:19 PM

Re: HDMI and ALSA with GTS 450
 
Can you please try aplay and speaker-test; those applications should help isolate any issue to ALSA itself, or MPlayer.

Another thing to check: Is the audio HW correctly configured by MPlayer for the sample rate of audio that's being played (e.g. if MPlayer thingks it's playing 48000Hz audio, the audio HW should be set up for 48000Hz playback).

asw3 10-26-10 06:44 AM

Re: HDMI and ALSA with GTS 450
 
no sound using aplay or speaker-test

aplay would simply hang after the following:
Code:

[root@matrix ~]# aplay -Dplug:hdmi /usr/lib64/openoffice.org/basis3.2/share/gallery/sounds/cow.wav
Playing WAVE '/usr/lib64/openoffice.org/basis3.2/share/gallery/sounds/cow.wav' : Signed 16 bit Little Endian, Rate 11025 Hz, Mono



speaker-test output the following error:
Code:

[root@matrix ~]# speaker-test -Dplug:hdmi -c2

speaker-test 1.0.23.32.gb67d2

Playback device is plug:hdmi
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
 0 - Front Left
Write error: -5,Input/output error
xrun_recovery failed: -5,Input/output error
Transfer failed: Operation not permitted
[root@matrix ~]
#


Note: speaker-test would hang (similar to aplay) after "0 - Front Left" gets printed, if i change argument "-c2" to "-c6"

Stephen Warren 11-02-10 11:43 AM

Re: HDMI and ALSA with GTS 450
 
11025 isn't a valid sample rate for HDMI audio, so your aplay test may not have been valid. Please try a 48000 or 44100Hz sample.

The speaker-test results sound odd. Can you try hw:0,3 as the output device rather than plug:hdmi. That will directly drive the HW rather than layering various plugins on top of it.

Either way, it sounds like the audio driver is having some basic problem communicating with the audio HW. The best people to debug this are probably the alsa-users mailing list, since they have more experience with audio issues.


All times are GMT -5. The time now is 02:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.