nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia drivers still conflict with vm (http://www.nvnews.net/vbulletin/showthread.php?t=156633)

barrynv 10-29-10 03:30 PM

nvidia drivers still conflict with vm
 
The last two Nvidia driver updates have broken KVM. I have to drop back to 256.53 to be able to run my vm's. The vm's start to boot but don't get very far before they quit. This affects all the vms, Linux and Windows.

It's enough of a pain to reinstall the driver with each kernel update, but this is too much. The machine I have is an AMD -- an Athlon 64 with an nVidia Quadro FX 580. Maybe this doesn't affect Intel based hardware and is low priority.

This is a Centos 5.5 box, kernel 2.6.18-194.17.4.el5. When I first bought the machine, the distribution's nv driver didn't do well with two monitors, so I've been using the nVidia driver.

toracat 11-01-10 06:35 PM

Re: nvidia drivers still conflict with vm
 
Quote:

Originally Posted by barrynv (Post 2339090)
It's enough of a pain to reinstall the driver with each kernel update

[ This may be OT here but I could not help making a comment. ]

I recommend you install the kernel version independent, kABI-tracking nvidia kernel module from the ELRepo Project. It survives kernel update and, because there is no compilation process required, you do not need development software.

http://elrepo.org/tiki/kmod-nvidia

The current version in the main repo is 256.53-1.el5. The latest version 260.19.12-1.el5 is in the *testing* repo. However, because of the ongoing problem with vmware/KVM, I doubt it gets promoted to the main repo any time soon.

Akemi (ELRepo team member)

toracat 11-10-10 11:51 AM

Re: nvidia drivers still conflict with vm
 
I just installed 260.19.21 and did a quick test. Starting a kvm guest does not cause segfault any more. Will continue testing but things are looking good.

barrynv 04-09-11 09:40 AM

Re: nvidia drivers still conflict with vm
 
fyi:

Finally, I've got the graphics drivers up to date.

I tried in December after a kernel update, but I still had the problem, and had stayed with the older drivers since. I went to Centos 5.6 today, and then brought the nvidia driver up to date and everything's cool.

So a belated thanks.


All times are GMT -5. The time now is 06:45 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.