nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   A7N8X2.0 deluxe hangs - especially when burning cdrom (http://www.nvnews.net/vbulletin/showthread.php?t=15722)

Worf 07-31-03 10:41 AM

A7N8X2.0 deluxe hangs - especially when burning cdrom
i got a A7N8X2.0 deluxe, and i have serious stability issues in Linux.

when i try to burn a cdrom, the whole system locks up. i tried at the console (no X loaded), and i did see as last output of cdrecord:

aborting command due to timeout: pid <pid>, scsi0, channel 0, id 0, lun 0 write (10) 00 00 00 0c 98 00 00 1f 00
hdd: timeout waiting for DMA
hdd: timeout waiting for DMA
hdd: (__ide_dma_test_irq) called while not waiting

Then the box is locked up.

I do have read the installation guides, i do have selected AMD Viper support, i don't have enabled ACPI support, i have searched around but i am clueless.

Kernels i have tried:
2.4.21 vanilla

Is there a kernel or patch i shall try?
What about the hdparm settings - could they help? if yes, then which? I could really use some help!


galaxor 07-31-03 12:11 PM


I am using A7N8X 2.0 && 2.4.21 (vanilla with AGP-patch) without any problems. Try to reproduce the hangups with BIOS-failsave-defaults.

Worf 07-31-03 01:19 PM

i tried to set BIOS settings to as failsave as possible. No change. I did eaven try with my 2500+ underclocked to 650MHz. Only thing i have not yet tried is to assemble a P200 of my spare parts and burn with that box, but that's not what i intended when buying this board.

Worf 08-04-03 12:16 PM

Still didn't find anything that could help me solving that issue. And nobody seems to have a idea.
I did some experimenting:

the faster i burn, the more likely it works:
8x and below always fails within the first 10MB
12x get's pretty far, and sometimes eaven finishes.
24x usually finishes.

However - I prefer to burn at a slow speed, so the result is as readable as possible. Nothing worse if you burn a knoppix cd, and the drive slows down because it has troubles reading the cd

I put my burner into my old box, so i can burn the new knoppix cd. Actually i bought the new board because the old one is unstable, but until now it's just a big disappointment :|

Kiamu 08-05-03 03:48 AM

are u using any ACPI or APIC features of the kernel? if yes: try to disable these...

Worf 08-05-03 04:43 AM


Originally posted by Kiamu
are u using any ACPI or APIC features of the kernel? if yes: try to disable these...
No. When i installed this mainboard i learned quickly that this causes problems. if i don't use the append = "pci=noacpi noapic", then usb, sound and network doesn't work. however - it doesn't change the issue with the cdwriter

geowiz 08-05-03 09:19 AM

Another thing to try

I've found that using the pci=noacpi was not enought. I had to use acpi=off as the parameter to the linux kernel. It does make a difference. append="hdd=ide-scsi acpi=off"

I also have to set DMA as on for the cd drives (in my rc.local file on boot). The command is "/sbin/hdparm -d1 /dev/hdd" to set DMA as on. 2.4.21 seems to not want to set the DMA on for cd drives. You can issue the hdparm command from the command line too.

As a side note, in 2.4.22-preX I've had to remove ACPI from the kernel all together to get nvnet and audio to work stabilly.

Good luck.....

Worf 08-06-03 05:50 PM

Thanks for the tip. But there was no change. Btw - at least one of my kernels didn't have acpi compiled in. I tested several combinations, but it doesn't seem to have any effect.

kgroombr 08-08-03 10:21 PM

I have been banging away at this for three weeks, trying different combinations of things. Used a promise ide controller, rebuilt the kernel at least twice a day with a new patch or changed options, and my system still locks up in 10 minutes or less when working on it. If I let it sit idle, it can go up to three or four hours, but eventually it still locks up.

geowiz 08-09-03 09:41 AM

More questions ...

Question - are you using the native kernel Nforce ide driver or the Nvidia 1.0-0261 driver for ide?

Additionally, If you run /sbin/hdparm /dev/hdd (as root) does the result indicate that you are using dma? If so, then run /sbin/hdparm -i /dev/hdd and check to see that the highest UDMA has a "star" indicating that it is being used.

In the earlier 2.4.20, I had to pass parms to the kernel to use dma with the Nforce2 chipset.


Worf 08-09-03 10:28 AM

Um - that is strange - i don't see any ide driver in the Nvidia 1.0-0261 driver package. Only nvaudio, nvgart and nvnet. Did i miss something?. I use the native kernel driver. Do i have a choice?

hdparm -d <device> did tell "using_dma = 1 (on)", that i do remember. The whole info (-I) i'll have a look at when i can do a reboot, the burner is in my old box right now.

Oh - and i now got Windows installed - if i now eaven find the cd that was shipped with the burner, i'll do a test in Windows...

geowiz 08-09-03 10:50 AM


I missed it. I thought that the 0261 from Nvidia had a fix to recognize the Nforce2 chipset .... I just went and looked at an unpacked tar and you are right - no apparent patch to the ide drivers. Sorry about that ... my mind is going ........

Still check to see if it's using the highest UDMA.

Sorry about the ide driver suggestion - need more coffee ;-)


All times are GMT -5. The time now is 04:07 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.