nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   VDPAU nvidia: Error detected 10 279 5 (http://www.nvnews.net/vbulletin/showthread.php?t=157804)

walter.austria 12-08-10 07:45 AM

VDPAU nvidia: Error detected 10 279 5
 
1 Attachment(s)
I have an old pentium4 prescott 3.4 and a Palit 9500GT Super 512 PCI-E,
which should allow me to use VDPAU for speeding up x264 playback,
according to the nvidia linux page.

As far I've tried several solutions and seached the forum,
but nothing I've tried did help me yet.

Everytime i invoke vdpauinfo (as root and user) it just says:

Code:

display: :0.0  screen: 0
VDPAU nvidia: Version: NVIDIA VDPAU Driver Shared Library  260.19.21  Thu Nov  4 20:56:20 PDT 2010
VDPAU nvidia: Error detected 10 279  5
VDPAU nvidia: Backtrace:
--: /usr/lib/libvdpau_nvidia.so.1 [0xb725a000] DSO load base
00: /usr/lib/libvdpau_nvidia.so.1 [0xb729d00e]
01: /usr/lib/libvdpau_nvidia.so.1 [0xb728d343]
02: /usr/lib/libvdpau_nvidia.so.1 [0xb726dd59] vdp_imp_device_create_x11
Error creating VDPAU device: 1

and of course, mplayer wouldn't work either with -vo vdpau.

I checked the symlinks in /usr/lib as suggested on another forum,
I recompiled my whole gentoo system twice,
double-checking that vdpau is enabled for all packages,
I checked my xorg.conf and Xinerama was already disabled,
and my driver version (260.19.21) should work fine, but nada.


VDPAU just won't work :(


Are there any kernel configuration options relevant to VDPAU,
that I might have missed out? That's the only guess I have left,
besides the two 'Stupid motherboard (MSI945GCM with latest BIOS)' and 'stupid Palit-Card'.

I attached the bugreport, as recommended.

Any help is appreciated & Thanks in advance!


Bump.
I gave the card a MSI-VGA-BIOS, it has the same frequencies
and memory timings as the Palit, but nothing changed.
Reverted back to original Palit-BIOS.

Are there any nvidia devs around who could help me?
The one who can solve this annoying problem
will get a sixpack of austrias finest beer via snail-mail.

Stephen Warren 12-13-10 02:15 PM

Re: VDPAU nvidia: Error detected 10 279 5
 
Walter,

You may be affected by the symptoms described in the following thread:

http://www.nvnews.net/vbulletin/showthread.php?t=130690

In particular, see my post:

http://www.nvnews.net/vbulletin/show...=130690&page=3

walter.austria 12-14-10 08:16 AM

Re: VDPAU nvidia: Error detected 10 279 5
 
1 Attachment(s)
Stephen,
thanks for pointing out these issues to me, mine seems to be similar.

Unfortunately the first pre-185 version gentoos portage system has to offer is 173.14.28,
which doesn't support VDPAU...at least vdpauinfo dies with a short message,
saying that the vdpau libraries are missing.

Anyway I attached the bugreport generated with 173.14.28.


So I have these to offer for trying out:

Code:

190.53-r1
195.36.24
195.36.31
256.44
256.44-r1
256.52
256.53
260.19.21
260.19.26

If it's worth investigating to you/nvidia,
I could send my card, if I could get a replacement
whilst mine is out of country - (it's the only PCI-E I have)

...but since it seems that at the moment
I'm the only one hit by this error code, i guess it's not worth it.

But maybe you have a reference VGA-BIOS around somewhere,
that i could flash, after checking the timings and clocks?

I think you were asking abut the memory type on the other thread, mine is a DDR2.

If you think a new BIOS might help, I dare to fry my card and decorate my flat with it.

Stephen Warren 01-03-11 12:53 PM

Re: VDPAU nvidia: Error detected 10 279 5
 
walter.austria,

You can download NVIDIA drivers from ftp://download.nvidia.com/XFree86/Linux-x86/ and use our installer.

Unfortunately, I don't have access to any updated VBIOS; the VBIOS are often updated by our OEMs.

Either way, if you are experiencing the error in the other thread I mentioned, this is a board HW issue, not a SW/VBIOS issue.


All times are GMT -5. The time now is 04:47 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.