nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Webpage rendering slow in kde/qt apps (http://www.nvnews.net/vbulletin/showthread.php?t=158339)

dae 12-30-10 06:33 AM

Webpage rendering slow in kde/qt apps
 
Rendering webpages in kde/qt apps is really slow if -graphicssystem=native is used. Using raster improves the situation *a lot*. This is true for at least both konqueror and rekonq, using either khtml or webkit as backend (but note that rekonq up to, and including 0.6.1 programmatically switches to raster - latest git version doesn't, due to rendering issues with raster on some hw/driver configs).

I know that it is a pretty well known fact that raster is faster than native. But raster is also buggy (for me, and many others as well it would seem). Furthermore, web rendering is the only thing I'm aware of where the performance diff is actually an issue. The rest of my kde4 desktop is "flying" and has no noticable performance issues at all.

Anyone else seeing this? Is nvidia working on a fix? Anyone know of any workarounds, except switching browser?

dae 12-30-10 10:28 AM

Re: Webpage rendering slow in kde/qt apps
 
*sigh* appears to be the old anti-aliasing issue again; turning on anti-aliasing improves performance considerably.

I *really* hope this will be fixed someday.

dae 12-30-10 10:45 AM

Re: Webpage rendering slow in kde/qt apps
 
One more data point; performance with "native" (anti-aliasing off) is actually pretty good in konqueror - until you open up a second tab. As soon as you have more than one page open, performance drops noticeably.

Rekonq always uses tabs, even though you have only one page open. And I don't see any difference in performance with one or more tabs.

So perhaps the problem isn't really that trivial? Anyone know what qt does differently when tabs are used?

dae 12-30-10 01:49 PM

Re: Webpage rendering slow in kde/qt apps
 
Now this is very interresting... I was playing around with various theme/style settings, and noticed that changing the QT style from oxygen to plastique caused performance to jump up drastically.

I tried a number of other styles as well, and oxygen seems to be the only one suffering from slow rendering.

So, looks like bad interaction between oxygen and the nvidia drivers. Guess I'll head over to bugs.kde.org and file a bug report against oxygen.

dae 12-30-10 02:27 PM

Re: Webpage rendering slow in kde/qt apps
 
For the record: https://bugs.kde.org/show_bug.cgi?id=261658


All times are GMT -5. The time now is 11:41 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.