nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia driver (270.18,x86_64) causes kernel oops on GT420M card ( BUG in _nv022095rm) (http://www.nvnews.net/vbulletin/showthread.php?t=159393)

darkraven 02-05-11 08:36 AM

[SOLVED]nvidia driver causes kernel oops on GT420M card (BUG in _nv022095rm)
 
Problem also exists in driver version 256.53 260.19.{06,12,36} (with kernel version 2.6.{36,37})
I know there is some rule that says 'Only report problems which are new in current release',but I still want to report this bug *again* to draw your attention.
Here is the backtrack information (for 270.18):
Code:

[<ffffffffa08f0861>] ? _nv022095rm+0x76/0x9e [nvidia]
[<ffffffffa08ec9d0>] ? _nv022052rm+0xd9/0x30b [nvidia]
[<ffffffffa08eccac>] ? _nv022102rm+0xaa/0x173 [nvidia]
[<ffffffffa08ecdc5>] ? _nv022051rm+0x50/0x5d [nvidia]
[<ffffffffa08f267c>] ? _nv022043rm+0x6e/0x78 [nvidia]
[<ffffffffa0dbeb4e>] ? _nv018866rm+0x69/0x123 [nvidia]
[<ffffffffa0dbeacc>] ? _nv018880rm+0xe8/0x101 [nvidia]
[<ffffffffa0910f33>] ? _nv004492rm+0x68/0x1d6 [nvidia]
[<ffffffffa0be903c>] ? _nv014737rm+0x176/0x4c3 [nvidia]
[<ffffffffa0be8153>] ? _nv015033rm+0xe9/0x165 [nvidia]
[<ffffffffa08c35d1>] ? _nv015212rm+0xd/0x12 [nvidia]
[<ffffffffa0dbe88a>] ? _nv002393rm+0x17b/0x271 [nvidia]
[<ffffffffa0dbf694>] ? _nv002387rm+0x4a5/0x684 [nvidia]
[<ffffffffa0dc5219>] ? rm_init_adapter+0x89/0xfd [nvidia]
[<ffffffffa0de1fc4>] ? nv_kern_open+0x524/0x6a0 [nvidia]
[<ffffffff81139a4b>] ? chrdev_open+0x19b/0x2a0
[<ffffffff811398b0>] ? chrdev_open+0x0/0x2a0
[<ffffffff81133903>] ? __dentry_open+0x103/0x390
[<ffffffff811ccb15>] ? devcgroup_inode_permission+0x125/0x150
[<ffffffff81134bb1>] ? nameidata_to_filp+0x61/0x70
[<ffffffff81143560>] ? do_last+0x480/0x7a0
[<ffffffff81143a75>] ? do_filp_open+0x1f5/0x690
[<ffffffff8114f284>] ? alloc_fd+0xf4/0x150
[<ffffffff81134c24>] ? do_sys_open+0x64/0x110
[<ffffffff81134918>] ? sys_chown+0x68/0xa0
[<ffffffff81134ceb>] ? sys_open+0x1b/0x20
[<ffffffff8100bf12>] ? system_call_fastpath+0x16/0x1b

My laptop is Acer Aspire 4741G.
I am using a up-to-date Archlinux system,with Xorg server version 1.9.3.901.
Tried boot with kernel version 2.6.37/2.6.38-rc3, both kernel oops.
Now the latest working driver for me is the 256.44 driver,which is quite annoying because of the font rendering performance problem,so I hope this problem could be quickly fixed.

P.S.
Here is backtrack information for 260.19.36 (with kernel version 2.6.36),which is different with above one:
Code:

[<ffffffffa05dcf86>] ? _nv021141rm+0x76/0x9e [nvidia]
[<ffffffffa05d9090>] ? _nv021098rm+0xd9/0x30b [nvidia]
[<ffffffffa05d936c>] ? _nv021148rm+0xaa/0x19a [nvidia]
[<ffffffffa05d94ac>] ? _nv021097rm+0x50/0x5d [nvidia]
[<ffffffffa05deccc>] ? _nv021089rm+0x6e/0x78 [nvidia]
[<ffffffffa0a8b5b7>] ? _nv018042rm+0x69/0x121 [nvidia]
[<ffffffffa0a8b535>] ? _nv018056rm+0xde/0xf7 [nvidia]
[<ffffffffa05f9df6>] ? _nv004163rm+0x68/0x1ec [nvidia]
[<ffffffffa08bfaea>] ? _nv014526rm+0x176/0x4f0 [nvidia]
[<ffffffffa08beb13>] ? _nv014808rm+0xea/0x167 [nvidia]
[<ffffffffa05b0c82>] ? _nv014987rm+0xd/0x12 [nvidia]
[<ffffffffa0a8b2e4>] ? _nv002158rm+0x160/0x26f [nvidia]
[<ffffffffa0a8c105>] ? _nv002152rm+0x493/0x671 [nvidia]
[<ffffffffa0a91b59>] ? rm_init_adapter+0x89/0xfd [nvidia]
[<ffffffffa0aadc04>] ? nv_kern_open+0x5c4/0x790 [nvidia]
[<ffffffff81132317>] ? chrdev_open+0x127/0x270
[<ffffffff811321f0>] ? chrdev_open+0x0/0x270
[<ffffffff8112c39d>] ? __dentry_open+0x11d/0x3c0
[<ffffffff811b082a>] ? security_inode_permission+0x1a/0x20
[<ffffffff8112d654>] ? nameidata_to_filp+0x54/0x70
[<ffffffff8113bce0>] ? do_last+0x480/0x790
[<ffffffff8113c1dd>] ? do_filp_open+0x1ed/0x680
[<ffffffff81147744>] ? alloc_fd+0xf4/0x150
[<ffffffff8112d6d0>] ? do_sys_open+0x60/0x120
[<ffffffff8112d3c8>] ? sys_chown+0x68/0xa0
[<ffffffff8112d7ab>] ? sys_open+0x1b/0x20
[<ffffffff8100af42>] ? system_call_fastpath+0x16/0x1b


darkraven 04-10-11 09:13 AM

Re: nvidia driver (270.18,x86_64) causes kernel oops on GT420M card ( BUG in _nv02209
 
this turns out not to be a nvidia driver bug.
Everthing is working fine now, after I update my BIOS.

FYI, my laptop is aspire 4741g with GT420m, I updated my BIOS from v1.19 to v1.25


All times are GMT -5. The time now is 01:27 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.