nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Unable to configure twinview on CRT and DFP (http://www.nvnews.net/vbulletin/showthread.php?t=159976)

oisch 02-24-11 10:25 AM

Unable to configure twinview on CRT and DFP
 
2 Attachment(s)
Hello,

I have the following configuration:
2 Nvidia graphics cards with each 1x DVI-Out and 1x VGA-Out.
For each graphics card I have connected the same monitors (1xTFT and 1xCRT). The TFT should be a clone of the TFT so I configured them as Twinview Clones.

The second card is configured exactly the same. My goal is to have 2 X screens (no twinview), each screen consisting of two monitors on clone configuration.

But the way I configured only the DFP-0 of GPU-0 shows a picture. All other devices stay off.
Note that display autodetection does not work for me for some reason, so I have to work with "ConnectedMonitors".
I have also captured the display's EDIDs to be sure that the correct modelines are being set.

The most confusing thing is however the Xorg.0.log output for GPU-1 (the second card).
I set ConnectedMonitors "DFP-0, CRT-0", but it seems to ignore that and reports CRT-1, which I'm sure is wrong.

Please have a look at my xorg.conf and Xorg.0.log . Any help would be greatly appreciated.

Cheers, Hans

danix 02-24-11 07:47 PM

Re: Unable to configure twinview on CRT and DFP
 
It's possible that CRT-0 and DFP-0 are the same physical connector on your board (remember: the DVI-I connector has pins for VGA on it), in which case CRT-1 could be correct.

oisch 03-02-11 03:51 AM

Re: Unable to configure twinview on CRT and DFP
 
Hi Danix,

thanks for the hint. I tried to set connectedMonitors to "CRT-1, DFP-0" and surprisingly I get the same effect on my monitors: Only DFP-0 works. All other monitors are off.
The Xorg log file looks just like before (only CRT-0 is not CRT1):

Code:

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "ConnectedMonitor" "CRT-1, DFP-0"
(**) NVIDIA(0): Option "TwinView" "1"
(**) NVIDIA(0): Option "TwinViewOrientation" "Clone"
(**) NVIDIA(0): Option "MetaModes" "DFP: 1600x1200_60 +1600+0; CRT: 1600x1200_60 +0+0"
(**) NVIDIA(0): Option "CustomEDID" "CRT:/etc/X11/edid-nec2190.bin; DFP:/etc/X11/edid-necp401.bin"
(**) NVIDIA(0): Option "RandRRotation" "on"
(**) NVIDIA(0): Option "Rotate" "CCW"
(**) NVIDIA(0): Option "UseEdidDpi" "FALSE"
(**) Mar 02 09:52:40 NVIDIA(0): Enabling RENDER acceleration
(**) Mar 02 09:52:40 NVIDIA(0): Using static 90-degree counterclockwise screen rotation.
(**) Mar 02 09:52:40 NVIDIA(0): ConnectedMonitor string: "CRT-1, DFP-0"
(II) Mar 02 09:52:40 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Mar 02 09:52:40 NVIDIA(0):    enabled.
(II) Mar 02 09:52:41 NVIDIA(0): NVIDIA GPU GeForce 210 (GT218) at PCI:16:0:0 (GPU-0)
(--) Mar 02 09:52:41 NVIDIA(0): Memory: 1048576 kBytes
(--) Mar 02 09:52:41 NVIDIA(0): VideoBIOS: 70.18.4f.00.00
(II) Mar 02 09:52:41 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Mar 02 09:52:41 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Mar 02 09:52:41 NVIDIA(0): Connected display device(s) on GeForce 210 at PCI:16:0:0
(--) Mar 02 09:52:41 NVIDIA(0):    NEC LCD2190UXp (CRT-1)
(--) Mar 02 09:52:41 NVIDIA(0):    NEC P401 (DFP-0)
(--) Mar 02 09:52:41 NVIDIA(0): NEC LCD2190UXp (CRT-1): 480.0 MHz maximum pixel clock
(--) Mar 02 09:52:41 NVIDIA(0): NEC P401 (DFP-0): 330.0 MHz maximum pixel clock
(--) Mar 02 09:52:41 NVIDIA(0): NEC P401 (DFP-0): Internal Single Link TMDS
(**) Mar 02 09:52:41 NVIDIA(0): TwinView enabled
(II) Mar 02 09:52:41 NVIDIA(0): Display Devices found referenced in MetaMode: CRT-1, DFP-0
(II) Mar 02 09:52:41 NVIDIA(0): Assigned Display Devices: CRT-1, DFP-0
(II) Mar 02 09:52:41 NVIDIA(0): Validated modes:
(II) Mar 02 09:52:41 NVIDIA(0):    "DFP:1600x1200_60+1600+0"
(II) Mar 02 09:52:41 NVIDIA(0):    "CRT:1600x1200_60+0+0"
(II) Mar 02 09:52:41 NVIDIA(0): Virtual screen size determined to be 3200 x 1200
(==) Mar 02 09:52:41 NVIDIA(0): DPI set to (75, 75); computed from built-in default
(WW) Mar 02 09:52:41 NVIDIA(0): RandR rotation is not compatible with the Rotate option.
(II) Mar 02 09:52:41 NVIDIA(0): The RandR extension is not compatible with the Rotate option.
(II) Mar 02 09:52:41 NVIDIA(0):    Disabling RandR.
(==) Mar 02 09:52:41 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.

What I don't understand is why all monitors except DFP-0 are off. I would at least expect the CRT monitor on the same BusID to work.
Note that I can get it to work once I remove the plug of DFP-0 and configure it w/o Twinview (as CRT-0).

Any ideas?

oisch 03-02-11 10:13 AM

Re: Unable to configure twinview on CRT and DFP
 
OK, I'm one step further now.
The reason why I could not get both, CRT and DFP to work was a semicolon instead of a comma in the metamodes string :(

Anyway: Now I have both screens on GPU-0 but on GPU-1 the displays don't seem to work.
here's the relevant section of Xorg.0.log:

Code:

(II) Mar 02 17:11:46 NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
(WW) Mar 02 17:11:46 NVIDIA(GPU-1): Unable to read EDID for display device CRT-0
(II) Mar 02 17:11:46 NVIDIA(GPU-1): NVIDIA GPU Quadro NVS 290 (G86GL) at PCI:16:0:0 (GPU-1)
(--) Mar 02 17:11:46 NVIDIA(GPU-1): Memory: 262144 kBytes
(--) Mar 02 17:11:46 NVIDIA(GPU-1): VideoBIOS: 60.86.70.00.12
(II) Mar 02 17:11:46 NVIDIA(GPU-1): Detected PCI Express Link width: 16X
(--) Mar 02 17:11:46 NVIDIA(GPU-1): Interlaced video modes are supported on this GPU
(--) Mar 02 17:11:46 NVIDIA(GPU-1): Connected display device(s) on Quadro NVS 290 at PCI:16
:0:0
(--) Mar 02 17:11:46 NVIDIA(GPU-1):    CRT-0
(--) Mar 02 17:11:46 NVIDIA(GPU-1): CRT-0: 400.0 MHz maximum pixel clock
(II) Mar 02 17:11:46 NVIDIA(0): Initialized GPU GART.
(II) Mar 02 17:11:47 NVIDIA(0): Setting mode "DFP:1600x1200_60,CRT:1600x1200_60"
(II) Loading extension NV-GLX
(II) Mar 02 17:11:47 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Mar 02 17:11:47 NVIDIA(0): Initialized X Rendering Acceleration
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(--) RandR disabled


What is strange is that it seems to ignore all my Options which I set in the screen/device section like ConnectedMonitor.
Did I put them in the wrong place?
Are these options global and not on a per-screen /per-device basis?

oisch 03-03-11 08:22 AM

Re: Unable to configure twinview on CRT and DFP
 
1 Attachment(s)
OK, figured it out.

I attached an xorg.conf file that works for me now


All times are GMT -5. The time now is 08:19 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.