nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   notebook Asus: the valid display devices are 'CRT-0' (http://www.nvnews.net/vbulletin/showthread.php?t=160009)

donuhr 02-25-11 05:28 AM

notebook Asus: the valid display devices are 'CRT-0'
 
1 Attachment(s)
Hello! I have Asus P52Jc notebook. OS is Ubuntu 10.10, kernel 2.6.38rc5 (also tested with 2.6.35-22 kernel).
I am configured my xorg.conf to sturtup from Nvidia adapter and try to use DFT display, but recived this warning in Xorg.0.log:
"Invalid ConnectedMonitor request; request was for 'DFP-0', but NVIDIA(GPU-0): the valid display devices are 'CRT-0'."
X-session don`t work. Using of old drivers didn't resolve my problem.
Can I fix this problem?
nvidia-bug-report.log.gz in attach.

p.s.: Bug report was sent.

donuhr 02-28-11 12:41 AM

Re: notebook Asus: the valid display devices are 'CRT-0'
 
Nothing about? Please don`t ignore my question...

bones_was_here 02-28-11 01:32 AM

Re: notebook Asus: the valid display devices are 'CRT-0'
 
I guess this is an "optimus" problem - if that's the case, and if there's no BIOS option to switch GPUs, you may be out of luck.

donuhr 02-28-11 04:08 AM

Re: notebook Asus: the valid display devices are 'CRT-0'
 
For switching to nvidia adapter i use directive in xorg.conf:
Quote:

BusId "PCI:1:0:0"
. Define of device is correct with this (Xorg.log):
Quote:

[ 26.124] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 26.124] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[ 26.124] (--) NVIDIA(0): Connected display device(s) on GeForce 310M at PCI:1:0:0
[ 26.124] (--) NVIDIA(0): CRT-0
[ 26.124] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[ 26.129] (II) NVIDIA(0): Assigned Display Device: CRT-0
But define of display type is wrong. Probably, this is bug related with type of my hardware...
Linux bug-support don`t comment my report. Or i misunderstand something?

donuhr 03-01-11 07:22 AM

Re: notebook Asus: the valid display devices are 'CRT-0'
 
I create EDID hex file for my monitor in windows and past it in xorg.conf:
Code:

Option  "CustomEDID" "CRT-0:/etc/X11/asus.bin"
In this case result in xorg.log is
Quote:

[ 2564.112] (**) NVIDIA(0): Option "CustomEDID" "CRT-0:/etc/X11/asus.bin"
[ 2564.325] (II) NVIDIA(GPU-0): Display (AUO (CRT-0)) does not support NVIDIA 3D Vision
[ 2564.326] (II) NVIDIA(GPU-0): stereo.
[ 2564.328] (II) NVIDIA(0): NVIDIA GPU GeForce 310M (GT218) at PCI:1:0:0 (GPU-0)
[ 2564.328] (--) NVIDIA(0): Memory: 1048576 kBytes
[ 2564.328] (--) NVIDIA(0): VideoBIOS: 70.18.64.00.0a
[ 2564.328] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 2564.328] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[ 2564.328] (--) NVIDIA(0): Connected display device(s) on GeForce 310M at PCI:1:0:0
[ 2564.328] (--) NVIDIA(0): AUO (CRT-0)
[ 2564.328] (--) NVIDIA(0): AUO (CRT-0): 400.0 MHz maximum pixel clock
[ 2564.337] (II) NVIDIA(0): Assigned Display Device: CRT-0
[ 2564.337] (==) NVIDIA(0):.
[ 2564.337] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[ 2564.337] (==) NVIDIA(0): will be used as the requested mode.
[ 2564.337] (==) NVIDIA(0):.
[ 2564.337] (II) NVIDIA(0): Validated modes:
[ 2564.337] (II) NVIDIA(0): "nvidia-auto-select"
[ 2564.337] (II) NVIDIA(0): Virtual screen size determined to be 1366 x 768
[ 2564.339] (--) NVIDIA(0): DPI set to (102, 102); computed from "UseEdidDpi" X config
[ 2564.339] (--) NVIDIA(0): option
[ 2564.339] (--) Depth 24 pixmap format is 32 bpp
[ 2564.339] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[ 2564.345] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
And i also have black screen.


All times are GMT -5. The time now is 12:30 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.