nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Freeze on X startup (Quadro FX 880M) (http://www.nvnews.net/vbulletin/showthread.php?t=161143)

bjacob 04-01-11 03:17 PM

Freeze on X startup (Quadro FX 880M)
 
1 Attachment(s)
Since I upgraded my Debian/unstable system, I can't use the NVIDIA driver anymore as my whole system freezes upon X startup.

I have tried many combinations of the following, all give me the same problem:
* nvidia driver: 260.19.44 from debian repository, 260.19.44 with NVIDIA installer, and 270.30 from "Frickelplatz" repository (I'm actually on Aptosid, a debian/unstable derivative).
* kernel: 2.6.38, 2.6.37, 2.6.36

This is on a Quadro FX 880M, with xorg 1.9.5.

bjacob 04-01-11 03:20 PM

Re: Freeze on X startup (Quadro FX 880M)
 
Also, my system works with the "vesa" or "nouveau" drivers, and under Windows.

Here is the output of `startx -- logverbose 6` :

X.Org X Server 1.9.5
Release Date: 2011-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.38-1-amd64 x86_64 Debian
Current Operating System: Linux cahouette 2.6.38-2.slh.2-aptosid-amd64 #1 SMP PREEMPT Tue Mar 29 01:27:22 UTC 2011 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2.slh.2-aptosid-amd64 root=UUID=65550910-ea98-44f6-8ced-3737494e0472 ro single
Build Date: 26 March 2011 03:32:34AM
xorg-server 2:1.9.5-1 (Cyril Brulebois <kibi@debian.org>)
Current version of pixman: 0.21.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Apr 1 14:42:38 2011
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "nouveau" (module does not exist, 0)
(EE) Failed to load module "nv" (module does not exist, 0)
(EE) open /dev/fb0: No such file or directory
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
(EE) Query no Synaptics: 6003C8
(EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
(EE) PreInit returned NULL for "SynPS/2 Synaptics TouchPad"
xinit: connection to X server lost

waiting for X server to shut down error setting MTRR (base = 0xcf000000, size = 0x00e00000, type = 1) Invalid argument (22)

artem 04-01-11 04:36 PM

Re: Freeze on X startup (Quadro FX 880M)
 
From your X.org log it seems like you do NOT have a /etc/X11/xorg.conf.d configuration file for NVIDIA and you must have one.

You can grab one from here, NVIDIA configuration file for X.org server >=1.8, download this file and save it to /etc/X11/xorg.conf.d directory.

bjacob 04-01-11 04:58 PM

Re: Freeze on X startup (Quadro FX 880M)
 
I have such a 20-nvidia.conf file in my xorg.conf.d directory, though it's simpler than that (basically just saying Driver "nvidia"). It used to work fine until my last system upgrade. I will try the file given on that page, but it has a few weird options:

Code:

Section "Device"
        Identifier      "Videocard0"
        BusID          "PCI:5:0:0"
        Driver          "nvidia"
        VendorName      "NVIDIA"
        BoardName      "nVidia Corporation Quadro FX 880M"
        Option          "CursorShadow" "on"
        Option          "RandRRotation" "on"
        Option          "OnDemandVBlankInterrupts" "on"
        Option          "Coolbits" "5"
        Option          "FlatPanelProperties" "Scaling = Native"
EndSection

For sure I'll have to remove the BusID line and I'm not sure I want the Coolbits.

bjacob 04-01-11 05:34 PM

Re: Freeze on X startup (Quadro FX 880M)
 
So, I tried this 20-nvidia.conf file (without the BusID and Options) and got the same freeze.

artem 04-01-11 07:22 PM

Re: Freeze on X startup (Quadro FX 880M)
 
Sorry, I have no idea then. Can you login remotely (via SSH) when you system freezes? Can you switch to text terminals? (Ctrl + Alt + F1-F6)?

ledoc 04-01-11 07:46 PM

Re: Freeze on X startup (Quadro FX 880M)
 
Just use a standard xorg.conf.
You probably also want to switch to 270.30 from debian experimental, just to be sure.

(all recent slh kernels and all recent nvidia drivers work perfectly well for the fx880 in my w510)

bjacob 04-01-11 09:53 PM

Re: Freeze on X startup (Quadro FX 880M)
 
So, I am "solving" this by installing Debian Stable and, of course, the NVIDIA driver. In this way, I will only have to deal with upgrading once in two years ;-)

@ Artem:

When it's frozen, keyboard input doesn't work at all --- no Ctrl+Alt+Fx. I know that trying to SSH into it, e.g. to attach gdb to X, would have been a good idea, but I didn't have a spare machine; would have tried that at some point.

@ Ledoc:

Having tried 270.30 from that 'frickelplatz' repo that AptoSid people recommend, as well as the debian/sid package for 260.19.44, I doubt that 270.30 from experimental would suddenly solve my problem. It looks more like an issue with the X server (given that that's the only thing I haven't been able to change) and Debian doesn't support downgrading, so I'm stuck.

Again, fixing this by moving to debian/stable + nvidia.

Btw thanks for your help :-)

ledoc 04-03-11 02:50 AM

Re: Freeze on X startup (Quadro FX 880M)
 
I have the same hardware, also on debian sid, and this should really work.

Do you start the kernel with any obscure parameters? Something is a bit weird with your setup. I get

Quote:

$cat /proc/driver/nvidia/gpus/0/information
Model: Quadro FX 880M
IRQ: 59
Video BIOS: 70.16.5f.00.0a
Card Type: PCI-E
DMA Size: 40 bits
DMA Mask: 0xffffffffff
Bus Location: 0000:01.00.0
while your BIOS version isn't recongised properly and we have different DMA sizes?

If could help if you use MSI interrupt handling for the GPU; add
options nvidia NVreg_EnableMSI=1 in /etc/modprobe.d/options.conf
This is supposed to be better anyway.


All times are GMT -5. The time now is 08:51 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.