nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Who all has nforce2 lockups? (http://www.nvnews.net/vbulletin/showthread.php?t=16167)

kgroombr 08-08-03 10:01 PM

Who all has nforce2 lockups?
 
I have been trying my best to identify why Linux 2.4.21 kept locking up on my new Abit NF7-S board. My system rarely runs five minutes without it completely freezing. I have had it run a few hours under light load, but as soon as I start copying files, buring a CD, etc, I am guaranteed to have it lockup in a minute or two. Even doing an fsck after a rebooot from a previous system freeze results in another lockup. Here is what I pretty much determined so far:

Ensured power supply and all components were good. Even replaced power supply because some voltages were close to marginal, but still in spec. Now all voltages are nearly right on. (Thanks to an Antec Tru550 power supply). Loaded Windows 2000 (and all device drivers) on a partition and ran two different stress test programs on the system for three days straight without any problem at all.

Now back to Linux. Disabled ACPI, didn't load nvnet, used a promise IDE controller and not the onboard one. Pulled every card but the video card, rebuilt the kernel with different patches and options (too many to list here).

And now after three weeks of beating my brains out on this, I have found nothing that helped even a little bit. I can make this puppy lock up in a heartbeat.

One possible solution is to use the test 2.6.X kernels. Someone that has just as many lockups as me that tried pretty much everything I did plus others I didn't said that this is working for him.

So has anybody out there have a solution to this for the 2.4.X kernels. If not, please post your finding so maybe we can get this fixed.

geowiz 08-09-03 09:25 AM

Question and ideas
 
kgroombr,

I'm running an Abit NF7-S V1.1 and haven't experienced the lockup problem -other problems but no lockup.

Did you apply the Nvidia 1.0-0261 drivers to the system? The reason I ask is that many of the other threads with problems seem to have applied that driver patch. I had great stability (month+ uptime at 100% cpu) using 2.4.21 using the native kernel Nforce drivers with nvnet from the 1.0-0261 drivers. *****It was pointed out to me that the 0261 doesn't patch the ide .... my mess up******

I have had problems with the 2.4.22-preX series of kernels with audio and nvnet though. I found that in the 2.4.22-preX series that ACPI is a problem. I had to pass the kernel "acpi=off" (pci=noacpi didn't give stability) to get audio and nvnet stabilty. I use the stock Nforce driver, not the Nvidia supplied version.*** no ide patch in the 0261 driver pack ... my error ******

If I look at the /proc/interupts file, USB, network, Nforce2 chip (audio+ide) are on the same interupt (10). These are the same systems that seem to be at the core of the current issues.

So, I'm wondering if the Nvidia ide drivers may not be a problem with the added complication of changes to ACPI that are leading to the rash of issues.

Hopefully an idea pops out that may help your issue.

FYI - I run RH 9.0, custom kernels, BIOS 19, SETI@HOME all the time + my normal activities. 2xdisks, 1 cdrom, 1 cd/rw, no SATA, FIrewire enables, USB enabled. GForce 2 GTS graphics card. XP 2100+ o/c to 2700+ w/333 FSB. nvnet and Lite-on tulip network card.

Good luck bug hunting!

Geowiz

kgroombr 08-09-03 09:10 PM

Hi,

Thanks for taking the time to try to help with this problem.

I am not sure since I have not researched it, but was told that the version 1.x of the Abit boards had a different revision of the nforce2 chipset. It seems that they all run fine. Been told that anyway.

I just tried the 2.4.22-rc2 patch and whatever was in there fixed my stability problems, but the system runs slower than molasses in January, and now X refuses to load with the nvidia driver. The 2D nv driver seems OK though. The XFree86.log shows that it is hanging when it tries to load glx. I think I might try the 2.6.X test kernel today. Just downloaded all the patches I need to make it work.

Thanks again,
Ken

geowiz 08-09-03 10:03 PM

Glad you got something to work. I think I had a brain fart this AM but I'm much better now ;)

I had a "slow" system with the 2.4.20 series when I had ACPI on. When I turned it off, things got much better. Don't know if you put ACPI in the rc2 but if you did, you might do the acpi=off and see if it runs better.

You're right that the 1.x and 2.0 NF7 series used different chips. It took a long time to get the 1.x series BIOS sorted out, maybe it is taking some time for them to sort out the 2.0 version.

Sorry your X isn't up to snuff. I presume you reloaded the new Nvidia driver. If it was having problems with GLX, you might look to see that the following links got done in the install as they are the glx libs used with the driver:
/usr/X11R6/lib/modules/extensions/libglx.so -> libglx.so.1.0.4496
/usr/X11R6/lib/modules/extensions/libglx.so.1.0.4496

Glad you're up and (semi-)stable. It can be frustrating getting there but when the box runs for months without a hickup, it's good!

geowiz 08-10-03 04:34 PM

NVidia X driver patch
 
Patches and instructions for the NVidia graphics drivers for the 2.6.0 series kernel.....
http://www.minion.de/

Hope it solves your X problem.

kgroombr 08-10-03 07:04 PM

I beat my brains on on this yesterday. I am going to start a new thread to see if anybody has a clue. Got some interesting stuff.

My fix was that I have to run with APIC. If I turn it off, my lockups return.

If you like, check out my new thread. I think I will put something like "$20 will be sent to whoever gives me the fix to my problem." and I will definately send $20 too!

Thanks,
Ken


All times are GMT -5. The time now is 01:51 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.