nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nvnet + RH + 2.4.22-rc1 = trouble (http://www.nvnews.net/vbulletin/showthread.php?t=16173)

Censo 08-09-03 03:10 AM

nvnet + RH + 2.4.22-rc1 = trouble
 
I have RH 9.0 with new kernel - 2.4.22-rc1.
Nvnet module is compiled and installed without errors, but network card dosn't work at all. Neither with static IP, nor with DHCP. It doesn't see neighbour computers. Even all pings are lost.
The same nvnet driver compiled for kernel 2.4.20-8 (with the same kernel config) works fine (sometimes it freezes a system for a few seconds but it works).
No log messages, no warnings, no errors. I've checked everything several times, it was done in a right way.
Interface is up and running, but according to ifconfig output there are no received packets, only TX.
Any suggestions?

Censo 08-09-03 05:27 AM

BTW USB mouse didn't work too...
usb-ohci.c: USB OHCI at membase 0xce8cf000, IRQ 22
usb-ohci.c: usb-00:02.1, nVidia Corporation nForce2 USB Controller (#2)
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 3 ports detected
hub.c: new USB device 00:02.0-2, assigned address 2
usb_control/bulk_msg: timeout
usb-ohci.c: unlink URB timeout
usb.c: USB device not accepting new address=2 (error=-110)
hub.c: new USB device 00:02.0-2, assigned address 3
usb_control/bulk_msg: timeout
usb-ohci.c: unlink URB timeout
usb.c: USB device not accepting new address=3 (error=-110)

Hmm... I've found a solution. When i added 'pci=noacpi' to kernel prompt, mouse and network began to work fine.
Did anyone face this problem?


All times are GMT -5. The time now is 03:37 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.