nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Blank Screen After Nvidia Driver 270.41.06 Install (http://www.nvnews.net/vbulletin/showthread.php?t=161898)

ragada 04-25-11 10:18 PM

Blank Screen After Nvidia Driver 270.41.06 Install
 
1 Attachment(s)
I did a clean install of ubuntu 11.04 without the nvidia drivers. I booted into the OS & installed the nvidia driver 270.41.06. It installed successfully but after a reboot, i just get a blank screen. The OS has booted & i can ssh into it. Its just that i dont see anything on the screen.

Adding acpi=off in the kernel command line fixes the blank screen but the desktop freezes after login. nvidia bug report attached

jolan 04-26-11 02:03 AM

Re: Blank Screen After Nvidia Driver 270.41.06 Install
 
Hrm, well the module didn't load:

*** /var/log/Xorg.0.log
[ 8.474] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[ 8.474] (EE) NVIDIA: system's kernel log for additional error messages.
[ 8.474] (II) UnloadModule: "nvidia"
[ 8.474] (II) Unloading nvidia
[ 8.474] (EE) Failed to load module "nvidia" (module-specific error, 0)
[ 8.474] (EE) No drivers available.

But it loaded fine before:

*** /var/log/Xorg.0.log.old
[ 9.594] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32

Have you installed all updates? There was a bug open on this but it's been closed as fix released:

https://bugs.launchpad.net/ubuntu/+s...th/+bug/684083

Tormentum 04-29-11 01:19 AM

Re: Blank Screen After Nvidia Driver 270.41.06 Install
 
got the same problem here...
  • I did a clean install of ubuntu 11.04.
  • Installed all updates.
  • Downloaded the nvidia driver 270.41.06.
  • Stopped the X Server
  • Installed NVidia Driver
  • Stared X Server

After reboot, i get blank screen...

So I did clean install again without updates. This time I tried the recommended nvidia driver from "Additional Drivers" section. After installing and rebooting OS, i get the same problem... blank screen.

I got an Nvidia GeForce GTX 460

ragada 04-30-11 03:16 AM

Re: Blank Screen After Nvidia Driver 270.41.06 Install
 
Hey Jolan,

It loaded fine before i ran the kernel with acpi=off. Although this fixes the blank screen, the desktop is unresponsive after login.

I filed a bug hoping that a future update of the nvidia driver will let people run with acpi.

Thanks

Venkat

hrmsfo 05-05-11 05:21 PM

Stuck Screen After Nvidia Driver update from 260.19.44 to 270.41.06
 
1 Attachment(s)
Running OpenSuSE 11.4, 32 bit, kernel Linux 2.6.37.6-0.5-default i686, KDE: 4.6.00 (4.6.0) "release 6"
Graphic card is GeForce 7200 GS

Was running fine with nvidia driver 260.19.44
I then did the proprietary nVidia driver update to 270.41.06-5.1. with Yast from repository ftp://download.nvidia.com/opensuse/11.4/. Rebooting after that does not work correctly.
Also, I deleted the nVidia 270.41.06 driver with Yast, rebooted, installed the nVidia driver using file NVIDIA-Linux-x86-270.41.06.run from http://www.nvidia.com/object/linux-d...06-driver.html. Problem remained the same.

I had added nomodeset to the boot options in /boot/grub/menu.lst. In /etc/sysconfig/kernel NO-KMS-IN-INITRD = yes is set.

With driver 270.41.06, on boot GRUB goes to the login window OK. With a normal log in, the screen shows only the splash image with a thin, distorted line. At that screen, ctrl+alt+del, then down arrow key, then enter key, does a proper system halt, although nothing changes on the screen during the keystrokes.

I did a console login, became root, then ran startx -- -logverbose 6. That gave the start screen with the progress bar stuck about 75% done. I logged into the machine remotely via ssh and ran `nvidia-bug-report.sh` in the remote shell. Log file is uploaded, and hopefully available.

I can log in to failsafe KDE plasma mode, which uses 2D driver: fbdev

I have now switched the nvidia driver back to 260.19.44 the manual way, using NVIDIA-Linux-x86-260.19.44.run. Everything works correctly again, and uses the nvidia drivers.

Regards,
Howard


All times are GMT -5. The time now is 12:54 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.