nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   KDE 4.6.2 splash screen will not clear on login (http://www.nvnews.net/vbulletin/showthread.php?t=162041)

davegriffiths62 04-29-11 08:04 AM

KDE 4.6.2 splash screen will not clear on login
 
1 Attachment(s)
Hi all,

Couldn't find any help so far for this specific problem so I thought I'd give it a try here. Currently running openSUSE 11.4 with KDE 4.6.2 and latest Xorg available from openSUSE repositories. I also have system updates from the Tumbleweed repositories. With the NVIDIA-Linux-x86_64-260.19.44 driver, everything works without issue. I saw that the official release of NVIDIA-Linux-x86_64-270.41.06 appeared so I decided to install that.

I logged out of KDE, dropped to a console as root and went to init level 3.
Uninstalled NVIDIA-Linux-x86_64-260.19.44 and rmmod nvidia to clear the current module from memory.
Installed NVIDIA-Linux-x86_64-270.41.06. This went without a hitch.
Issued a change to init level 5 and got the KDM login screen back OK. Entered my credentials and the KDE splash screen appeared.
Now the progress bar advances to 75% then stops and the screen remains indefinitely.
KDE continues to load, confirmed by the login tune and normal hard drive access. I cannot get the splash screen to clear. If I turn off the splash screen after reverting to NVIDIA-Linux-x86_64-260.19.44, then reinstalling NVIDIA-Linux-x86_64-260.19.44 I just get a black screen once the KDM login screen is cleared. The mouse still moves the pointer about but all buttons do nothing. So I am currently unable to successfully use the NVIDIA-Linux-x86_64-260.19.41.06 driver.

I have attached the Xorg.0.log obtained after the 270.41.06 install and can see no errors within. Any advice on what may the causing this would be greatly appreciated.

Thanks in advance
Dave

loftwyr 04-29-11 09:36 AM

Re: KDE 4.6.2 splash screen will not clear on login
 
More information is needed, please read this:

http://www.nvnews.net/vbulletin/showthread.php?t=46678

davegriffiths62 04-29-11 10:39 AM

Re: KDE 4.6.2 splash screen will not clear on login
 
2 Attachment(s)
Hi.

Apologies for not providing enough info. Here are the 2 files requested. Along with the original attachment I hope this helps to understand the problem.

A further note. Once the KDE splash screen progress bar reaches 75% and stops, if I switch to a console and then back again the splash screen is replaced by a completely black screen with only the mouse cursor visible. As stated previously, this will move but the mouse buttons do not appear to produce any effect.

I have also taken the time to install Gnome 3 from the official repositories. In this case logging in with the NVIDIA-Linux-x86_64-270.41.06 driver results in the display of the main workspace but it is also frozen apart from mouse movement as with KDE. Again, uninstalling NVIDIA-Linux-x86_64-270.41.06 and reinstalling NVIDIA-Linux-x86_64-260.19.44 returns the system to full functionality. I have tried all users, including root, and have consistently got the same result.

Thanks in advance for any possible solutions you may be able to offer.

Dave

davegriffiths62 05-07-11 10:32 AM

Re: KDE 4.6.2 splash screen will not clear on login
 
Quote:

Originally Posted by loftwyr (Post 2425345)
More information is needed, please read this:

http://www.nvnews.net/vbulletin/showthread.php?t=46678

Any chance you can advise on possible solutions yet? I have previously posted the missing info you requested.

Many thanks

Dave

majlo 05-07-11 11:27 AM

Re: KDE 4.6.2 splash screen will not clear on login
 
Bug was reported in this thread: http://www.nvnews.net/vbulletin/showthread.php?t=160115. When KDE lunch desktop effects screen stops refreshing. Try to disable effects by pressing shift+alt+f12.

davegriffiths62 05-07-11 12:24 PM

Re: KDE 4.6.2 splash screen will not clear on login
 
Quote:

Originally Posted by majlo (Post 2429743)
Bug was reported in this thread: http://www.nvnews.net/vbulletin/showthread.php?t=160115. When KDE lunch desktop effects screen stops refreshing. Try to disable effects by pressing shift+alt+f12.

Thanks for the pointer. I will wait for the next release, it's not that critical to me at the moment as the 260.19.44 driver is fully functional.

Kind regards

Dave


All times are GMT -5. The time now is 10:10 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.