nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   RH7.3 + nForce 420-D + startx = FROZEN (http://www.nvnews.net/vbulletin/showthread.php?t=1625)

ctaggart 09-07-02 04:21 PM

RH7.3 + nForce 420-D + startx = FROZEN
1 Attachment(s)
I've got an ASUS A7N266-E Socket A Motherboard. It has an nVidia nForce 420-D Chipset built in. I downloaded and installed Redhat 7.3. I installed Redhat with the workstation option and I selected the development package + KDE + Gnome. I installed the kernel source from the Redhat CD2. I used up2date in order to get the latest gcc and glibc-kernheaders.

I used the following to packages to make and install the nVidia drivers:

Redhat's installer (I think it is called anaconda.) created the /etc/X11/XF86Config-4 and I editted it by:
# Load "dri" # Commenting out this line
# Load "GLcore" # Commenting out this line
Load "glx" # making sure this one existed and it does
# Driver "nv" # commenting out this line
Driver "nvidia" # replacing it with this one

Is this part correct? I loaded the NVdriver by typing:
insmod NVdriver

I then start X by typing:
and my computer's screen becomes black. I am able to reboot my computer by hitting ctrl+alt+delete. I had similar results when I tried loading the binary rpm's.

I need help. I can be emailed directly at ctaggart@alumni.washington.edu by anyone willing to help. I will post the solution if I ever figure it out.

My XF86Config-4 is attached.

venkat 09-12-02 04:00 PM

visit http://www.nforcershq.com/forum/viewforum.php?f=29 for a detailed faq and tips

Andy Mecham 09-12-02 10:33 PM

Can you post a copy of your /var/log/XFree86.0.log file?



ctaggart 09-13-02 12:00 PM

Mandrake 9.0 RC1 Worked

Thanks for the reply. Unfortunately, I replaced Redhat with a newly downloaded Mandrake 9.0 RC1 and the installer detected my hardware and installed some drivers for it that allow me to get to KDE and Gnome just fine. I may try installing Redhat again in the future or the nVidia drivers on my Mandrake PC, but untill then everything is working fine.

I'm still somewhat of a Linux newbie and I'll probably play around on Mandrake untill the next Redhat release.

ctaggart 10-02-02 08:28 PM

Redhat 8 + nForce 420-D + startx = FROZEN
1 Attachment(s)
I was hoping the new version of Redhat would solve my problems, but X freezes when I try to start it. What I don't understand is why Mandrake Linux 9.0 RC1 didn't have any problem detecting my video card and montitor and configuring X appropriately. I am tempted to reinstall Mandrake Linux to grab a copy of the XFConfig files and compare them to Redhats.

I'm not trying to install the drivers from NVidia yet, as the NV ones should work with Redhat. They are working with Mandrake.

Here is the log file /var/log/XFree86.1.log

Any help would be appreciated.

ctaggart 10-02-02 08:31 PM

1 Attachment(s)
Here is the /etc/X11/XF86Config (XF86Config-4 doesn't exist) file created from Redhat 8's installation program, Anaconda.

ctaggart 10-03-02 03:09 AM

Redhat 8 XServer Not Working
1 Attachment(s)
I reinstalled Mandrake Linux 9.0 RC1 in order to get a copy of the /etc/X11/XF86Config-4. This configuration works with Mandrake Linux (It is attached to this post.)

I then reinstalled Redhat Linux 8.0 and I compared that file to Redhat's /etc/X11/XF86Config file. (I already posted it in a previous reply.)

The main differences I could see when looking at the two files are that Mandrake doesn't load the modules: dri, fbdevhw, or record. Mandrake also uses the "fbdev" driver rather that the "nv" driver.

I tried making a lot of different change to the Redhat XF86Config file, but I would hang evertime. As a last resort, I even tried replacing it with Mandrake's XF86Config-4 file, but that didn't help either. (Should I have just removed the current XF86Config file and copied XF86Config-4 in from Mandrake.) I noticed Mandrake has both a XF86Config and a XF86Config-4. What is the relationship? Does XF86Config get read at all; my assumption was no.

Any help getting Redhat to work with my nVidia nForce would be greatly appreciated. Thanks.

ctaggart 10-04-02 01:48 AM

Making Progress with Redhat 8
I downloaded and installed the latest 1.0-3123 nVidia graphics drivers from source .tar.gz files. For those of you following along, I have Redhat 8 Workstation installed. The only addition package I had to install to compile (make install) those packages was kernel.source.rpm from CD2.

I'm now posting messages primarily in the nforcershq.com forum, because I have a motherbaord with an nforce chipset. I just posted my /etc/X11/XF86Config-4 file and the /var/log/XFree86.0.log file there.

I hope those that can help, especially those of you from nvidia can read my postings there. I'm still having problems, but a lot of progress has been made.


The log message is reporting errors like this:

(II) Loading extension NV-GLX
(II) Loading extension NV-CONTROL
Symbol TypeMask from module /usr/X11R6/lib/modules/extensions/libextmod.a is unresolved!
Symbol lastResourceType from module /usr/X11R6/lib/modules/extensions/libextmod.a is unresolved!
Symbol FindAllClientResources from module /usr/X11R6/lib/modules/extensions/libextmod.a is

Symbol lastResourceType from module /usr/X11R6/lib/modules/extensions/libextmod.a is unresolved!
Symbol lastResourceType from module /usr/X11R6/lib/modules/extensions/libextmod.a is unresolved!
Symbol ResourceNames from module /usr/X11R6/lib/modules/extensions/libextmod.a is unresolved!
Symbol lastResourceType from module /usr/X11R6/lib/modules/extensions/libextmod.a is unresolved!
Symbol RegisterResourceName from module /usr/X11R6/lib/modules/extensions/libextmod.a is

Symbol ResourceNames from module /usr/X11R6/lib/modules/extensions/libextmod.a is unresolved!
Symbol FindClientResourcesByType from module /usr/X11R6/lib/modules/extensions/libextmod.a is


All times are GMT -5. The time now is 09:01 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.