nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVidia drivers 270.41.06 and Biostar GeForce 210 (http://www.nvnews.net/vbulletin/showthread.php?t=162542)

RAMChYLD 05-15-11 12:54 PM

NVidia drivers 270.41.06 and Biostar GeForce 210
 
3 Attachment(s)
Ok, due to the silent treatment I've revceived over the <expunged> GeForce4 card, I've went ahead and swapped in my MCPC's mobo, memory, vidcard and CPU into my other Linux box. The MCPC will get a M4N78 Pro and a GeForce GT520 once those are available locally, but until then it's an empty case with parts strewn around.

Now, this box has a vidcard that is a Biostar branded GeForce 210 (GT218), and this card does not play nice with Windows 7 since after Driver 197.45- hence all this while it's been running on 197.45 drivers. It also has an identity crisis- it's BIOS lists it as a GeForce G210 even though it is in fact a GeForce 210. What is confusing me even more is that certain websites claim that GeForce210 = GeForce G210.

For the sake of my sanity, I've decided to go back to Debian Sid. As predicted, it ships with XOrg 1.10.1.

Driver doesn't work either -.-

XOrg dump (filtered to show only NVidia-related errors):
Code:

[  129.131] X.Org X Server 1.10.1
Release Date: 2011-04-15
[  129.138] X Protocol Version 11, Revision 0
[  129.141] Build Operating System: Linux 2.6.32-5-amd64 x86_64 Debian
[  129.143] Current Operating System: Linux clementine 2.6.38-2-amd64 #1 SMP Sun May 8 13:51:57 UTC 2011 x86_64
[  129.148] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-amd64 root=UUID=7fb395d3-0ffe-4a51-b714-48274e508616 ro quiet
[  129.154] Build Date: 28 April 2011  12:13:00PM
[  129.156] xorg-server 2:1.10.1-2 (Julien Cristau <jcristau@debian.org>)
[  129.159] Current version of pixman: 0.21.8
[  129.162]        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  129.168] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
...
[  129.207] (II) NVIDIA GLX Module  270.41.06  Mon Apr 18 15:10:15 PDT 2011
[  129.207] (II) Loading extension GLX
[  129.207] (II) LoadModule: "record"
[  129.207] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[  129.207] (II) Module record: vendor="X.Org Foundation"
[  129.207]        compiled for 1.10.1, module version = 1.13.0
[  129.207]        Module class: X.Org Server Extension
[  129.207]        ABI class: X.Org Server Extension, version 5.0
[  129.207] (II) Loading extension RECORD
[  129.207] (II) LoadModule: "dri"
[  129.207] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[  129.208] (II) Module dri: vendor="X.Org Foundation"
[  129.208]        compiled for 1.10.1, module version = 1.0.0
[  129.208]        ABI class: X.Org Server Extension, version 5.0
[  129.208] (II) Loading extension XFree86-DRI
[  129.208] (II) LoadModule: "dri2"
[  129.208] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  129.208] (II) Module dri2: vendor="X.Org Foundation"
[  129.208]        compiled for 1.10.1, module version = 1.2.0
[  129.208]        ABI class: X.Org Server Extension, version 5.0
[  129.208] (II) Loading extension DRI2
[  129.208] (II) LoadModule: "nvidia"
[  129.208] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  129.209] (II) Module nvidia: vendor="NVIDIA Corporation"
[  129.209]        compiled for 4.0.2, module version = 1.0.0
[  129.209]        Module class: X.Org Video Driver
[  129.209] (II) NVIDIA dlloader X Driver  270.41.06  Mon Apr 18 14:55:25 PDT 2011
[  129.209] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  129.209] (--) using VT number 7
...
[  129.214] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[  129.214] (==) NVIDIA(0): RGB weight 888
[  129.214] (==) NVIDIA(0): Default visual is TrueColor
[  129.214] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  129.325] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:4:0:0.  Please
[  129.325] (EE) NVIDIA(0):    check your system's kernel log for additional error
[  129.325] (EE) NVIDIA(0):    messages and refer to Chapter 8: Common Problems in the
[  129.325] (EE) NVIDIA(0):    README for additional information.
[  129.325] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
...
[  129.325] (EE) Screen(s) found, but none have a usable configuration.
[  129.326]
Fatal server error:
[  129.326] no screens found
[  129.326]
Please consult the The X.Org Foundation support
        at http://wiki.x.org
 for help.
[  129.326] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  129.326]

This is the error that appeared in the kernel dmesg (filtered to show only NVIDIA-related errors), starting from when the NVIDIA driver is loaded:
Code:

[    7.584662] nvidia: module license 'NVIDIA' taints kernel.
...
[    9.727486] nvidia 0000:04:00.0: PCI INT A -> Link[APC8] -> GSI 16 (level, low) -> IRQ 16
[    9.727495] nvidia 0000:04:00.0: setting latency timer to 64
[    9.727501] vgaarb: device changed decodes: PCI:0000:04:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[    9.727940] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  270.41.06  Mon Apr 18 14:53:56 PDT 2011
...
[  33.851322] NVRM: RmInitAdapter failed! (0x26:0x28:1050)
[  33.851345] NVRM: rm_init_adapter(0) failed
[  129.325643] NVRM: RmInitAdapter failed! (0x26:0x28:1050)
[  129.325654] NVRM: rm_init_adapter(0) failed
...

This is the card's entry when I do a lspci -v
Code:

04:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce 210] (rev a2) (prog-if 00 [VGA controller])
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at ee000000 (64-bit, prefetchable) [size=32M]
        I/O ports at 9c00 [size=128]
        [virtual] Expansion ROM at e0000000 [disabled] [size=512K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Capabilities: [b4] Vendor Specific Information: Len=14 <?>
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Kernel driver in use: nvidia

For the records, this is the BIOS info shown when the system starts:
http://i.imgur.com/W4RDh.jpg

Attached are the full log files.

Someone please help!

RAMChYLD 05-15-11 08:49 PM

Re: NVidia drivers 270.41.06 and Biostar GeForce 210
 
Nevermind, swapped out the problematic 210 for a older 8400GS card and all is well again.


All times are GMT -5. The time now is 01:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.