nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   $20 sent to whoever gives me the fix this problem (seriously). (http://www.nvnews.net/vbulletin/showthread.php?t=16264)

kgroombr 08-10-03 07:28 PM

$20 sent to whoever gives me the fix this problem (seriously).
Seriously, I will send $20 to the person who gives me the fix to this.

As I posted in a previous post, I was getting severe lockups with my system. I have now fixed the lockups but at the expense of a system that runs slower than molasses in January.

The system:

Abit NF7-S 2.0 with the BIOS 18 update (latest one as of 11 Aug). Barton 2500+, Maxtor 160GB and Seagate 80GB on a promise ultra 133 tx2 controller. LG DVD on EIDE #1 of the nforce2 and a Zip 250 on EIDE #2 of the nforce2.

Video card: Xtasy Geforce3 Ti500
Kworld BT878 capture card
Advansys SCSI controller

Kernel is 2.4.22-pre2 (something between 2.4.21 and this pre2 kernel fixed my lockups, but now it runs super slow).

For some reason I have to have ACPI turned on in order for my lockups to go away. This causes my system to run super slow and here is what I think is going on:

Everytime I added a device that required an interrupt (using modprobe), my system would get progressively slower. At one point it was so slow that it took (no joke) about 45 minutes to load X.

Here is /proc/interrupts immediately after booting:

0: 21576 IO-APIC-edge timer
1: 132 IO-APIC-edge keyboard
2: 0 XT-PIC cascade
6: 6 IO-APIC-edge floppy
8: 1 IO-APIC-edge rtc
9: 0 IO-APIC-level acpi
12: 4745 IO-APIC-edge PS/2 Mouse
14: 7 IO-APIC-edge ide0
15: 22 IO-APIC-edge ide1
16: 23970871 IO-APIC-level bttv
18: 25148787 IO-APIC-level ide2, ide3
19: 19967973 IO-APIC-level nvidia
22: 10012602 IO-APIC-level NVidia nForce2
NMI: 0
LOC: 21524
ERR: 51
MIS: 12207

Anything loaded in the APIC irq range is totally wacked. IRQ 22 is my sound, and I noticed that it was the only one that currently not changing.

Here is /proc/interrupts only moments later:

0: 35578 IO-APIC-edge timer
1: 1111 IO-APIC-edge keyboard
2: 0 XT-PIC cascade
6: 13 IO-APIC-edge floppy
8: 1 IO-APIC-edge rtc
9: 0 IO-APIC-level acpi
12: 5185 IO-APIC-edge PS/2 Mouse
14: 7 IO-APIC-edge ide0
15: 22 IO-APIC-edge ide1
16: 40344618 IO-APIC-level bttv
18: 41495938 IO-APIC-level ide2, ide3
19: 36337043 IO-APIC-level nvidia
22: 10012602 IO-APIC-level NVidia nForce2
NMI: 0
LOC: 35490
ERR: 53
MIS: 12345

Checking out my processes, I found a aplay process that appeared to be hung up (plays the intro music when logging into KDE). I killed the process and checked out /proc/interrupts again:

0: 41843 IO-APIC-edge timer
1: 1568 IO-APIC-edge keyboard
2: 0 XT-PIC cascade
6: 20 IO-APIC-edge floppy
8: 1 IO-APIC-edge rtc
9: 0 IO-APIC-level acpi
12: 5185 IO-APIC-edge PS/2 Mouse
14: 7 IO-APIC-edge ide0
15: 22 IO-APIC-edge ide1
16: 46664621 IO-APIC-level bttv
18: 47809364 IO-APIC-level ide2, ide3
19: 42653097 IO-APIC-level nvidia
22: 21695941 IO-APIC-level NVidia nForce2
NMI: 0
LOC: 41735
ERR: 53
MIS: 12401

In order to run these, I had to rmmod by SCSI card (for my CDRW), and my USB ports). If I didn't, the system would be even so slow it would have taken me forever to do this test.

Again, if I turn APIC off, the system runs super fast, but unfortunately will lock in in about two to three minutes.

Sound will sometimes play a fraction of a second of the sound, but then appears to hang.

It appears that the IRQs go berzerk with APIC.

Again, $20 goes to the person that gives me the correct fix to this problem. No hack, and nothing like "buy another motherboard".

Need more info, just let me know. More than happy to provide.


bahamot 08-11-03 12:38 AM

have u tried 2.6.0-test* + akpm patches?
try it, ACPI working flawless there :D

kgroombr 08-11-03 02:17 AM


Yes, I tried that. I haven't yet tried the patches on the 2.4 series kernel, the compile failed on the 2.4.22-rc2 kernel. Will download the pre8 patch (since that is what it was written for) and try that one.

I really appreciate all your help. Not sure if this is a BIOS thing either. It seems that the newer nforce2 based motherboards have a different version of the nforce2 chip. Found a lot of people with this problem. They all have pretty much given up on it. I won't go without a fight, but will hopefully lose $20 soon.


bahamot 08-11-03 03:25 AM


Originally posted by kgroombr

Yes, I tried that.

so, it doesn't work either with 2.6.0-test + akpm patches?
so strange...... AFAIK, the APIC patch for nforce2 on 2.4.x kernel doesn't work well...but 2.6.0-test + akpm mm4 or mm5 patches works well

kgroombr 08-11-03 04:09 AM

I am going to try it again. There is a new akpm patch for the test3 kernel.


kgroombr 08-11-03 07:18 PM

I tried the 2.6.0-test3 with the new akpm patches. It compiled but wouldn't boot. I then just applied the nforce2 IRQ fragment patch (dated 7 Aug) from the same patch and it looked good. It actually made it several minutes without locking up. I was nearly ready to call it a success, but "WHAM", hard lock. Rebooted several times only to confirm it was still locking up.

More information about my system in case it helps to identify the problem:

1GB memory (2 x 512M Kingston HyperX PC 2700). BIGMEM is enabled in the kernel to support up to 4GB.


bahamot 08-12-03 12:03 AM

i don't think we could do anything other than waiting for the fixes. I really hope Nvidia itself can make the patches....
anyway sorry can't help u

kgroombr 08-12-03 07:11 PM

I think you are somewhat right about that. Right now my last hope is to make 2.4.22-rc2 compile with the latest acpi patch.

2.4.22-rc2 has been running for four days down without a problem. I had to remove most of the device (logical remove via rmmod) because every device that uses an interrupt that is loaded in the acpi space (irq 16 and above) generates billions of spurious interrupts every day. Last I looked my system had trillions of interrupts generated within the last few days. Anyway each device loaded in the acpi space causes the sytem to run slower and slower. Right now only two devices loaded in that area, and it runs about 1/3 the speed that I think it should be running.

If this latest acpi patch fixes this problem without reintroducing my lockup problem, I will be in business.

It is strange that 2.4.22-rc2 does't lockup, but if I run it with pci=noapic or acpi=off, my lockup problem comes back. Most of the people I know with this problem say that interrupts are somehow causing the problem. I have to agree with that from what I see now. Everybody that I have found with this problem have the nforce2 chipset revision 162.


Max3D 08-16-03 07:36 AM

I don't claim this will help "you", but might be worth a try just cause I been down this road and was no fun, was determined to get APIC or ACPI working but in the end it was out of my hands as I not a linux kernel programmer but a tweaker instead.

Heres all I did to stop lockups:
Enable APIC and ACPI in BIOS, then go into "make menuconfig" and leave ALL power management completely OUT of the kernel (APIC, APIC-IO, ACPI & regular Power managment) all unchecked, then enable Athlon CPU type, Enable MCE(Machine Check Exception), enable MTRR, right now you might be wondering why did I leave them enabled in BIOS?, simply cause I dual boot with XP and it's blazingly fast with it (very responsive), anyhow... build your new kernel-2.4.22-pre3-ac1 (or newer) without all this PM stuff and give it a try, might work different than the boot time disabling switch options, does for me. good luck, just my 02 cents.

If that APIC/ACPI patch works let us know, I'd be willing to give it a test drive.

cat /proc/pci shows (Rev 162) here.

btw: If you need to see my kernel config let me know and I'll try to find a way to link post it here.

kgroombr 08-20-03 12:19 AM

Thanks for the taking the time helping me try to fix this.

Unfortunately that didn't work either (taking all acpi support out of the kernel and setting the BIOS).

I just applied the latest acpi patch patch_2.4.22-rc2_to_acpi-2.4-20030813.bz2 from:


and it did fix my spurious interrupt problem, but my lockups have returned.

Under linux-2.4.22-rc2, my system was rock solid (only with acpi enabled), but essentially any device that loaded with IRQ 16 and above was pretty much useless because of the spurious interrupts. Using linux-2.4.22-rc2 (with acpi enable), I never had a system lockup ever. It ran for days without a problem (but without sound, slow hard disk access, no cd burning capabilities, etc, essentially useless).

There are dozens of folks like me. It seems it boils down to the nforce2 ultra 400 chipset. I find that those that had the previous version have absolutely no trouble at all. There are others that have the nforce2 ultra 400 that have no trouble as well.

There are dozens of us, that are having this exact same problems and I am wondering if there are different versions of the nforce2 ultra 400 chipset and we might have been hit with a version that just happens not to get along with Linux?

I have been over one month without a completely working computer. I am tempted to get a new motherboard with a different chipset, but there isn't really anything out there that fits my needs like the motherboard I have.

I appreciate all the help I have been given. Hopefully someone can shed a little light on why only a few dozen of us are affected.


kgroombr 08-22-03 08:21 PM

It appears that I have a fix.

I had done this before except for a newly introduced kernel parameter.

I turned off apic in the BIOS, compiled the kernel without support for apic, and sent the kernel the paramter noapic. This didn't work until I added another kernel parameter nolapic (notice the "l").

Been running a day now where before I was lucky to get 10 minutes.

It appears that this parameter was just recently introduced in both the 2.4.22-rc and 2.6.0-test kernels.

Going to run a few more days, but it looks like the person that sent this to me will be getting $20 in the mail.

Would still like to see apic completely working for the nforce2 chipsets. Right now there is definately something broken.

Thanks all,

bahamot 08-23-03 02:39 AM

glad to know it :D

All times are GMT -5. The time now is 09:34 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.