nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   New system and ut2004 stutters (http://www.nvnews.net/vbulletin/showthread.php?t=163009)

kriko 05-31-11 02:32 PM

[BUG]New system and ut2004 stutters
 
1 Attachment(s)
I got myself a new system:
- 4GB ram
- GTS 450 (PCIE-16x)
- Athlon 640 (quad)

So it has plenty of power to run ut2004 (patch 3369), however there are noticeable stutters in this game.
The worst observed is in BR-Anubis map - there are almost 1 sec pauses, though I've set to preload everything in ini file, after some time the pauses decrease and at some point seems to be gone.

I'm not sure where is the problem, it works flawlessly in windows - however the same stutter is observed when running in wine.

Could this be a driver issue or linux got bad at games?
I haven't played it for quite a while, but I know on old system with AGP graphics it used to run very well without this problems even under linux.

Bug report attached with detailed system info.

More explanation why it was changed to bug:
http://www.nvnews.net/vbulletin/show...52&postcount=6

weltall 05-31-11 02:35 PM

Re: New system and ut2004 stutters
 
try disabling composite managers (compiz kwin) I've had someone recently who had to disable compiz to get more than 10fps from his 460GTX (obtaining then way more fps), on another engine (crystal space) but it's worth a try

kriko 05-31-11 03:07 PM

Re: New system and ut2004 stutters
 
I disable effects completely prior entering game, the same problem persists if I launch game from bare X with xterm terminal, so the problem is not bound to effects.

Somehow I get suggestions it is due to PCI-E and missing agpgart, like this post:
http://forums.gentoo.org/viewtopic-p...fb15dd#2181415

but no solutions so far, unless if you count booting into windows a solution.

brebs 06-01-11 05:36 AM

Re: New system and ut2004 stutters
 
Have you really tested under Windows with the same hardware? Because this is a common problem for both Linux AND Windows - I've googled it extensively, in the past, and tried MANY things myself. There is no complete fix.

The Handedness fix helps, but a bit of stutter still remains.

Was smooth with nvidia 7950, but stuttering started with 8800GTS, and continues with 9700GT.

JaXXoN 06-01-11 05:47 AM

Re: New system and ut2004 stutters
 
Long time ago, I had some stuttering with ut2004 and the
solution was to set VARSize (in UT2004.ini) to 0. I don't think
this is still applicable, nowadays, but i guess it's worth a try.

Bernhard

kriko 06-01-11 11:31 AM

Re: New system and ut2004 stutters
 
I've tried Varsize=0 - doesn't help.

@brebs - it's butter smooth under windows, it was also on previous hardware
which was an athlon64 2800+ and gf7600GT (just not ultra high settings)
I've heard there were some dynamic lightning performance problems and never thought this would impact me on such overpowered configuration for an old game (GTS 450 should be enough?)

Thank you! Hiding weapon fixed things (lag is almost gone, very very small hitches remain, but they are barely noticeable).
Now, is there a proper fix for this?

CME 06-01-11 11:48 AM

Re: New system and ut2004 stutters
 
mh, could you try the performance frequency governor on all cores? i had a similar problem with my phenom and ondemand and when linux tries to move the application from a 3.2ghz core to a 800mhz core (for example games like GTA3 went from 20fps to over 100fps in virtualbox)

kriko 06-01-11 11:52 AM

Re: New system and ut2004 stutters
 
Already tried that, it's a nvidia + ut2004 issue - hiding weapon makes it playable.

mooninite 06-01-11 06:00 PM

Re: New system and ut2004 stutters
 
I haven't had any issues with UT2004. I have a 3ghz Core 2 quad and a 9800 gtx+ driving it very smoothly (with real time shadows enabled, too).

I wish they had released the Linux client on their recent game releases.

artem 06-02-11 04:17 AM

Re: New system and ut2004 stutters
 
You are lucky it even works for you :)

Here on Fedora in consistently crashes 3-5 minutes through playing. In short - it's unusable.

kriko 06-02-11 09:59 AM

Re: New system and ut2004 stutters
 
After more research - it is a crossplatform issue.
If I select OpenGL backend in windows, the same stuttering appears.
Probably driver problem with specific hardware-

Where should I report cross-platform openGL issues?

mooninite 06-02-11 10:48 AM

Re: New system and ut2004 stutters
 
Quote:

Originally Posted by artem (Post 2440357)
You are lucky it even works for you :)

Here on Fedora in consistently crashes 3-5 minutes through playing. In short - it's unusable.

Yep. I'm running Fedora 15 x86_64 on two boxes. Both run UT2004 flawlessly.

A friend running it on Arch also runs it with no problem.


All times are GMT -5. The time now is 04:26 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.