nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Fedora 15 / GNOME3 hangs and Xids (http://www.nvnews.net/vbulletin/showthread.php?t=163439)

lintweaker 06-13-11 09:13 AM

Fedora 15 / GNOME3 hangs and Xids
 
1 Attachment(s)
I never had problems with Nvidia drivers on my system before but now I get Xid messages and the systems hangs. It does not respond to keyboard or mouse input. If I am lucky a can still connect with ssh and reboot.

Code:

Jun 13 14:38:40 paragon kernel: [13251.654296] NVRM: Xid (0000:02:00): 13, 0003 00000000 00008297 00001514 00000000 00000040
Jun 13 14:38:40 paragon kernel: [13251.760910] NVRM: Xid (0000:02:00): 13, 0003 00000000 00008297 00001514 00000000 00000040
Jun 13 14:38:40 paragon kernel: [13252.177342] NVRM: Xid (0000:02:00): 13, 0003 00000000 00008297 00001514 00000000 00000040
Jun 13 14:38:41 paragon kernel: [13252.777928] NVRM: Xid (0000:02:00): 13, 0003 00000000 00008297 00001514 00000000 00000040
Jun 13 14:38:42 paragon kernel: [13253.377623] NVRM: Xid (0000:02:00): 13, 0003 00000000 00008297 00001514 00000000 00000040
Jun 13 14:38:42 paragon kernel: [13253.979354] NVRM: Xid (0000:02:00): 13, 0003 00000000 00008297 00001514 00000000 00000040
Jun 13 14:38:42 paragon kernel: [13254.159602] NVRM: Xid (0000:02:00): 13, 0003 00000000 00008297 00001514 00000000 00000040
Jun 13 14:38:42 paragon kernel: [13254.258605] NVRM: Xid (0000:02:00): 13, 0003 00000000 00008297 00001514 00000000 00000040

I am running Fedora 15, x86_64 with the Gnome 3 shell. Nvidia drivers: 270.41

kwizart 06-13-11 10:14 AM

Re: Fedora 15 / GNOME3 hangs and Xids
 
Can yu give a try with the 270.41.19 driver :
yum install akmod-nvidia --enablererepo=rpmfusion-nonfree-updates-testing
and reboot

lintweaker 06-13-11 10:46 AM

Re: Fedora 15 / GNOME3 hangs and Xids
 
Quote:

Originally Posted by kwizart (Post 2444693)
Can yu give a try with the 270.41.19 driver :
yum install akmod-nvidia --enablererepo=rpmfusion-nonfree-updates-testing
and reboot

I will give them a try, what is changed? Luckily the hangs do not come that often so it could be a while before I can draw a conclusion.

davezerave 06-13-11 04:55 PM

Re: Fedora 15 / GNOME3 hangs and Xids
 
1 Attachment(s)
I'm on Archlinux (gnome-shell) running the latest nvidia driver (270.41.19).

The Xids and system freezes randomly occur on trying to setup an external monitor. Sometimes it will happen several times in a row (after reboots in between). Sometimes it's instantly possible to setup the external monitor.

Really awkward behavior: Fragments scattered over both screens, mostly I can't even get to the ttys anymore and need to do a hard reboot.

Code:

Jun 12 17:31:05 davelab kernel: [  168.962040] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040
Jun 12 17:31:05 davelab kernel: [  169.056579] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040
Jun 12 17:31:10 davelab kernel: [  174.137974] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040
Jun 12 17:31:14 davelab kernel: [  178.198445] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040
Jun 12 17:31:14 davelab kernel: [  178.234127] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040
Jun 12 17:31:19 davelab kernel: [  183.299811] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040
Jun 12 21:16:13 davelab kernel: [  133.633598] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 000015e0 00000000 00000040
Jun 12 21:19:32 davelab kernel: [  133.503910] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 000015e0 00000000 00000040
Jun 12 21:39:15 davelab kernel: [  117.244187] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040
Jun 12 21:59:11 davelab kernel: [  131.562257] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040
Jun 12 22:09:32 davelab kernel: [  111.416186] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040
Jun 13 21:17:37 davelab kernel: [ 3930.002013] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 000015e0 00000000 00000040
Jun 13 21:22:13 davelab kernel: [  126.053893] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040
Jun 13 21:24:44 davelab kernel: [  117.211596] NVRM: Xid (0000:03:00): 13, 0003 00000000 00008397 00001514 00000000 00000040

Right now I'm booting with sole 20-nvidia.conf (Xorg settings file) and no preset config for my monitor (at first I thought it was related to Twinview explicitly switched on or off, but apparently it wasn't).

I'm not getting these glitches when I'm using Twinview setup from a config file!

Code:

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "DELL2407WFPHC"
    HorizSync      30.0 - 83.0
    VertRefresh    56.0 - 76.0
    Option        "DPMS" "1"
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 9400M G"
    BusID          "PCI:3:0:0"
    Option        "RenderAccel" "1"
    Option        "NoLogo" "True"
    Option        "TripleBuffer" "True"
    Option        "OnDemandVBlankInterrupts" "1"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "1"
    Option        "TwinViewXineramaInfoOrder" "DFP-0"
    Option        "metamodes" "DFP-0: 1280x800_60 +1920+0, DFP-1: 1920x1200_60 +0+0; DFP-0: 1280x800_60 +1920+0, DFP-1: nvidia-auto-select +0+0"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection

I have to disable the external "dead space" screen if it's not connected after login though and sometimes the driver will crash on disabling that non-existent monitor, too (black screen, gnome-session crashed).

The severity of this bug lies in its randomness I guess :(

[edit]
Oh, and one thing I found out:
When I'm still able to get to a tty I can restart the gdm daemon, log back in and kill a gnome-shell process (there are now two of them, run by my user) at 100% CPU usage.
After that I was able to setup the external monitor just fine, with several gnome-session related processes double-started.
[/edit]

sandipt 06-14-11 09:09 AM

Re: Fedora 15 / GNOME3 hangs and Xids
 
Please try with 275.09, 275.09.04 and Let us know the results.

lintweaker 06-17-11 11:54 AM

Re: Fedora 15 / GNOME3 hangs and Xids
 
1 Attachment(s)
Hmm just had a hang after a few seconds with mplayer playing a moving using vdpau. The keyboard went completely dead, fortunately the network still functioned. I managed to create a bugreport,I saw a few Xids with dmesg. This is with 270.41.19-1 from rpmfusion. I see there are now 275.09.07 packages, I will give them a try.

edit:
BTW I ran a few graphics intensive benchmarks (from Phoronix) without problems using 270.41.19 a couple of days ago. So hard to tell what caused the Xids and complete freezes.
I am now running 275.09.07, lets see how that goes.

davezerave 06-20-11 07:27 AM

Re: Fedora 15 / GNOME3 hangs and Xids
 
So far my problems are resolved with 275.09.07 (it seems).
But now the driver is causing another issue with the "tray icons" in gnome3. They're all the same... :>


All times are GMT -5. The time now is 03:56 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.